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About HyperCube

HyperCube is a Macintosh and Windows application program specifically directed to
the analysis and display of multi and hyperspectral imagery. This includes the static and
dynamic display of the image cube and the generation of spectral classifications using both
imagery and spectral libraries. In addition, HyperCube contains functions to filter, warp,
mosaic, reformat, calibrate, combine, photogrammetrically project and to perform arithmetic
on imagery and data.

The current version number of HyperCube is shown in the lower right hand corner of the
splash screen by selecting About... in the Apple menu or the Help menu in the Windows ver-
sion.

Software

There are currently two Mac (Macintosh) versions of HypeCube. One version is for the
older Power PC processor and the other is for the current Intel based architecture. There are
also two Windows versions: a 32 bit and a 64 bit executable. They are both Windows® 95
through Windows 7 compatible.

The Mac and Windows programs are 99.9% identical with one significant difference: the
Windows version does not support the Mac Pict image format. Although this documentation
was prepared on a Mac version of Adobe InDesign® using Mac OS X examples, the Windows
GUI matches it one-for-one. Any slight (very slight) difference between the two systems is
delineated in the text (in particular see the “Load Selection” button in section Band List).
Also, see “Windows version” in the index.

The Windows version uses the Control (Ctrl) key instead of the Macintosh special com-
mand key. So, for example, to perform a paste operation press the Ctrl and V keys simultane-
ously. The Mac Option key is replaced with the Alt key in Windows.

Currently, the HyperCube executables, examples and documentation are available at
www.agc.army.mil/hypercube/index.html .
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oading Images
Files, Data, Images and Display

At the present time almost every window that is displayed on a computer monitor con-
sists of 8 bit gray or 24 bit color (or possibly a few bits more). HyperCube can handle data
up to 32 bits per pixel with a spatial extent up to at least 20,000 by 20,000 pixels. How data
is converted from a source file to a displayed image window is described below.

Pixel depth:
8 bit - display directly as gray or pseudo color.

24 bit color - display as true color.

16 bit signed or unsigned - keep 16 bits in memory as “attached data” and remap
by various methods to 8 bits for display (the image load dialogs contain
options for remapping),
See section Data Mapping for other ways to remap after loading).

32 bit float or long - keep full depth in memory and convert for display.
64 bit and higher - not presently supported in HyperCube.

Spatial size:

Image sizes greater than 2048 pixels or 2048 lines can be loaded as a scaled overview
image (see Related functions below) and used to outline areas that are loaded at full resolu-
tion. Image subsets may also be loaded.

Multiband Images:

Each band that is loaded into memory includes the attached source data for that band.
However, the number of bands loaded into memory does not affect spectral classifications in-
cluding most statistical operations. Therefore, it is not necessary to load an entire multiband
image in order to exploit it (see sections Header Files and Band List).

Related functions:
Attach Data,
Overviews,
Gray Mapping, Color Mapping, Data Mapping,
Statistical Measures,
Image Arithmetic,
Classify Function.

Note, to see the underlying data of a display pixel choose menu Windows -> Show Info
which in addition to listing the gray or color display pixel will also show any data value. Du-
plicating an image also makes a copy of the attached data. Some operations, such as menu
Applications ->_Shaded Relief, also copy the source data and attached it to the newly con-
structed image.
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Intrinsic File Types

The intrinsic image file format for the

Open: HyperCube

Mac and PC is TIFF. HyperCube also
automatically recognizes Pict, TIFF, JPEG

, PNG and .SUN (SRF) file types in the
menu File->Open... (shown at the right)
provided their Finder file types (not the file
name suffix) are properly set. If the list does
not show the file you are expecting then the
image must be opened using menu File ->
Open As... with you specifying the file type.
If Edit -> Options -> Detailed Messages
is checked then the header contents of the

PICT, JPEG, TIFF and .SUN file types

[«f»]) [= \EB] [ Images W‘!
= Mercury ) [a gimp-pri._#.2.1.dmg |a | 325ijpg [«
® Network p | HP Installer Log File 3 1754503 jpg 0
=} Orion P L;—f_ HYMAP » & Andromeda.tif
= Sirius » LF Hymap2 ! [l Annotated Class Map
[= HyMapLib L EE Annotate...ss Map.tiff
[ IKoMos " | H ape
@ lllustrator® 7.0 | B ape.ipg
L5 B BB ape.nt
¥ lomega OsX L & apeaif
L7 1sac "1 & BandList.uf
[~ IPEG docs " | & Bandscrolling.tif
[ Kodak L ES &ill final
L7 LANDSAT hdrs L = blackropdark copy.txt
= libexe v [# BLST.tif
¥ Library PIY = henoteontf b4
New Folder ) (" Cancel ) Open

various file types will also be listed and is a
good diagnostic tool.

The Windows version of HyperCube uses File -> Open... (shown below in General File
Types) to load all types of image formats except Pict which is not supported. TIFF is the
general file type for Windows. Use the Files of type: popup menu to select which type.

General File Types

Any image supported by HyperCube can be opened by Open As... in the Mac version
and just Open... in the Windows version as shown by the dialogs below and the following

page.
Look in: Ia Images j - £k B9~
|_13 bard [ Hymap-2000 radiance @ ape. kif @ Dtedi
1 Clip art CJonos CIE via ENVI [ g1 .4
[CdData_sa [CIMalapai runi4 =] DEM_3M~1.tiF & q1_te
1 Desert Radiance Canrre [ DEM_3mea3.tiF GeaTl
| 1DMsy s [ DEM_3Md tiE Grouel
| IForest Radiance [CJsEBass [ Demnazbit ki Grouel
|_1Ft Hood &= Shapefiles @Denise.jpg ifsar-li
|_1Ft Huachuca [ Terrain Denise,ntf ifsar-li
I Hymap 09-26-99 CJUrban @ Denise, kif Tanti
CI Hymapz 09-26-99 @ airpork 1, f - DTED OIM_:
"I Hymap-2000 ape.jpg 2] DTED.hdr [ o1m_
1] | i3
File name: IDTE o] j Dpen I
Files af lpe: IHaw 2] j Cancel |
|

Windows standard Open... file dialog.
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ASCII Lidar
Open As: HyperCube Bands
All file types ERDAS Imagine
_ ESRI Shape
Enable: | Multiband [ HDF
e JPEG
(«]») (= "[Zdr 1l run03 ] LASE
L T2 -0 Library
7 sirius M Deskiop Oancn ) > B8 B A wRiass
r) L____ Developer L A 4 class map.c2n NITF
[~ pistiller = B A mask Pict
E Desktop [ dmg's » oy [ Alib.dr P PNG
[ pmsv » ) [ Annotated DR lib » Raw
[ pocuments * | [ Annotate... Lib {small) | SRF
J= & & DR 1l Lib Classification Targa
[~ praw P DR Il Lib Cl._ fication.c2n Text
|7 ERDAS Imagine I [ DR Open House lib TIFF
L Everglades I B dri
[ for Rand » | @ drioviyva 3.00 Currently supported
|7 Fort Huachuca g * drll Ovly VA 3.00.c2n L l
[7 frurunos v @ DRIL_LIB.sea v ﬁ e Zypes.
4l (4 e 13
(" New Folder ) (" Cancel ) @
P
Macintosh OS X standard Open As... file dialog.
SRF (Sun Raster Files) and TARGA
Sun raster (SRF) and TARGA formatted images can be loaded by select- ASCI Lidar
ing Open As... from the File menu and then choosing the appropriate item in Ezg‘fs ot
. i . . . magine
the Format popup menu. No other dialog is required as these images contain ESRI Shape
sizing information in their header. HyperCube should be able to read 8 bit and F:EE
24 bit compressed and uncompressed Sun images. HyperCube can also save LASF
. . Library
images in the Sun format but not TARGA. Multiband
NITF
Pict
PNC
Raw
Targa
Text
TIFE
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ERDAS Imagine®

Certain types of ERDAS Imagine® *.img files can be read (imported in some cases) into
HyperCube by selecting menu File -> Open As... and choosing ERDAS Imagine® as the
file type. The supported pixels depths are: 8 bit unsigned, 16 bit unsigned, 16 bit signed, 32
bit signed and 32 bit float gray scale single and multiband images. Also, 8 bit pseudo and
24 bit true color images can be loaded. Once loaded the images may be saved in any format
including Imagine®.

An Imagine® multiband image should be reformatted into the HyperCube multiband
format with corresponding *.hdr and *.wvl files. Loading a multiband image brings up the
following dialog immediately after the Open As selection. Choosing either Load or Re-
format displays the two subsequent dialog paths. Spectral classifications can not be directly
performed until an Imagine® multiband image has been converted to HyperCube multiband.

W] This is an Imagine® multiband
image: 320 pixels, 1280 lines, 210
bands, 16 bits. You can load it
directly into memaory (172.0 MB) and
then save to a file or directly
reformat to a file (preferred).

(_ Load ) ( Cancel ) ( Reformat)

Load ERDAS Imagine® Data Reformat Imagine® Multiband
Imagine® image 'fthoodS_8.img' is: -- Source File Format --
3.20 pixels by 1280 lines by 210 bands by 16 bits Pixels: |320 Header bytes: 0
(signed) —
Lines: 1280 Pixel type: 16 bit signed |4 ]
Starting Pixel: l1 # of Pixels: 320 S DTEEEEE
| | —— Bands: : RS0 (hanc .
Starting Line: 1 # of Lines: 1280 Interleave: | BSQ (band ... '+
—_— B der: PC (littl di
Starting Band: 1 # of Bands: 210 ey Uhdeenclan)

-- Output Format --
E Swap bytes

Starting pixel: 1 # of pixels: 320
™ Remap display using: Starting line: 1 # of lines: 1280
) min & max @ median interval, % 98 Starting band: 1 # of bands: 210
Overview scale: 2 — = e ——
Min: Pixel type: 16 bit signed = ]
(Cancel )  ( Load Overview ) (€ Load Image ) Max: Interleave: @
. . . . I Flip left <-> right @5wap bytes, (change to Mac,5un)
ChOOSll’lg Load mn theﬁrSt dlCZZOg dlS- 1 Flip top <-> bottom [] Output header bytes
plays this dialog showing the initial C Apply scaling O Reverse band order
. . _| Limit to Min & Max [ Reverse wavelenth order
defaults for loading the specified mul- > - : 5
. . . ( Cancel ) ( Scaling/Calibration... ) @
tiband image file. Edit as needed and E .

select Load Overview or Load Image.
The Mac version of HyperCube will have
the Swap bytes check box on while in the
Windows version it will be off.

Choosing Reformat in the first dialog above
results in HyperCubes’s general Utilities ->
Reformat File dialog. See section Reformat-

ting a File.

If Load Overview is selected in the Load dialog then a scaled overview of the selected
band is loaded. Any portion of the overview image can be designated and saved, including
automatically reformatting the subset (see section Saving Overviews).
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The Hierarchical File Architecture (HFA) of a given ERDAS Imagine® image file can be
displayed by first toggling on menu Edit -> Options -> Detailed Messages and then loading
the file. It is quite extensive and is displayed in several text windows containing the HFA
nodes. Shown below are the results after loading a single 16 bit gray scale image. Note that
a 210 multiband image has over 2000 nodes.

® O O dma_dted.img HFA dma_dted.img dictionary ™ O O dma_dted.img tile o.
dictionary {2618 butes):
SiriusiERDAS Imagineldma_dted.img {1tlversion, 1 iLfreslist, 1 iLroatEntryP e, 1 Edms_State!
isentryHeaderlength, 1 :LdictionaryF tr, FERT numvirtualblocks: 64
headerP tr: G4 a_File,{1:Lnext,1:Lprev, 1 iLparent, 1 iLchi L rumobj ectsperblock . 4896
wersion: 1 dy 1ildata, 1 ldataSize, 64 ichame, 32 ictype, 1 rnextobjectnum: @
freelisti 17132 ttmodT ime, YEhfaEntry, {16iclabel, 1 iLheade compressionType: @
rootEntryPtr: 82 rPtr, FEhfa_HeaderTag, {1:LfreeList, 1:lfres Edm=_MirtualBlocklnfo!l
entryHeaderlength: 128 Size, )Ehfa_Freeli=tNode, {1 :lsize,!Lptr,t tile offsets:
dictionaryP tr: 538273 Ehfa_Data, {1 :lwidth, 1:lheight, 1:e3:themat 2768
ic,athematic, fft of real-walused 18968
Humber of Ehfa entries: 12 data, lagerType, 1 1213 iul, uz, ud, ud, =8, ulf, = 19152
Humber of Edms_State entries: 1 16,u32, =32, 732, 64,064,128, pixelTupe, 111 27344
blockHidth, 1 i lblackHeight, }Eimg_Layer, {1: 35536
image width: 512 lwidth, 1 i lhaight, 1 123! themat iz, athematic, 43728
image height: 512 fft of real-valued 51928
layer enum: athematic data, lager-Tupe, 1 te13ul, w2, ud, us, s8,ulb, = 6E112
pixel ehum: wlf 16,u32,532, 732, fo4,c64, 128, pixelTupe, 151 6E384
tile pixels: 64 blockHidth, 1 :lblockHeight, JEimg—Layer_Sub TEH406
tile Llines: B4 Sample,{1:eZiraster, vector, type, 1 :Ldictio 24628
imageBands: 1 naryPtr, FEhfa_Layer, {1 :=fi leCode, 1 tLoffse 9zesE
rgb order: @,8,8 ty1il=ize, ez false, true, logval id, 1 1aZin 1@a1avz
o compression, ESRlI GRID 189264
compression, compress i onType, YEdms_Virtual 117456
Ehfa_Entry 1 {82} ElockInfo,{1:lmin, 1:lmax, }Edm=_Free|DLi=t 125648
hext nodel @ » 41t lnumyirtualblocks, 1 lnumob j ectsperblo 1338348
previous node! B ok, 11 lhextobjectnum, 1122 tha 142832
parent node: @ comprassion, RLC 158224
child node: 2632 COmpress i on, compress i onType, 8 poEdms_Mirt 158416
data ptri B ualBlock Info,blockinfo, @ipoEdms_Free|DLis 166685
data size: @ t, freelist, 1 i tmodT ime, JEdms_State, {Bipcst 174260
hame @ root ring, FEmi f_String, {1 :0Emi f_String,algorit 152992
type: root hm, @ :poEmi f_String, namel i =t, E i mg_RROName 191184
mod time: 1337922975 sList, {1 :0Emi f_String, projection, 1 oEmif_ 199376
String,units, FEimg_HMapinformation, {1 :oEmi 2ATSES
Ehfa_Entry 2 {2632} f_String, dependent, }Eimg_DependentFi le, {1 215768
hnext node: 218 t0Emi f_String, Imagelayertame, +Eimg_Depend 223952
previous node! B entlagerName, {1 ! lnumrows, 1 ! lnumco lumns, 12 232144
parent node! 82 213 EGDA_TYPE_U1, EGDA_TYPE_IZ, EGDA_TYFE_U 240336
child node: 8 4, EGDA_TFE_UZ, EGDA_TYPE_S8, EGDA_TYFE_U1G 248528
data ptr: 2760 , EGDA_TYPE_516, EGDA_TYPE_I3Z, EGDA_TYPE_S3 256728
data size: 4 2, EGDA_TYPE_F32, EGDA_TYFE_FG&4, EGDA_TYFE_C 264912
name i IMGFormatinfo &4, EGDA_TYPEC128, datatypse, 1 ied iEGDA_SCAL 273184
type: ImgFormatinfof3l AR_DEBJECT, EGDA_TRELE_DBJECT, EGDA_MATRIX_0 281206
mod time: 13379232076 EJECT, EGOA_RASTER_OBJECT, 0bj ecttype, ¥Eqgda 280422
_Baselata, {11+ 297630

A partial listing of the 12 Corresponding dictionary A listing of offsets showing
HFA nodes in the loaded defining the structure of each the location of each image
image file. possible node. data block within the file.

Any loaded image can be saved in the Imagine® *.img format via menu Save As... and
selecting ERDAS Imagine® as the type. Note: HyperCube does not generate the histogram
or statistics of HFA nodes when saving, only those nodes needed for loading and displaying.
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ESRI Shape Files

HyperCube can load and display certain types of ESRI (Environmental Systems Research
Institute, Inc.) Shape Files. In particular are those produced by HyperCube via the Class
Map Editor Export function and those produced by menu Applications -> Contour. Shape
files consist of a main file that should have a .shp extension along with the index file (.shx
extension) and a dbase file (.dbf extension). The later two file’s contents can be displayed in
a scrollable text window by selecting File- > Open As..., choosing ESRI Shape and select-
ing the desired file extension type. Depending upon their size (number of records) multiple
output windows may be generated. For convenience, the_main shape file itself does not have
to have the .shp extension whereas the other two do require their proper extension.

Shown below is the result of opening the three shape files that were exported by the Utili-
ties -> Class Map Editor. Each text window contains a parsing and because of the possible
large size of shape files not all of the records may be shown. Also, the shape plot sizing is
arbitrary unless it was exported from HyperCube.

Gravel.shp 0 =———Graveldbf —0185
File Code: 9994 Flain dbf
File Length {bytes}: 125284 Date: Mow 6, 2888
Verszion: 1888 Mum Records: 241
Shape Type:! 5, Polugon Header Size {(bytes): 161
Imin: -B.5 Fecord Size {bytes}: 33
Ymin: -8.5 Language Driwer ID: @
Ymax: 171.5 Field 1
Ymax: 115.5 Mame: Record Mo
Tupe: H
Record Humber: 1 Length: 2
Content Length {bytes): 192 Dec Places: @
Shape Typei 5, Polugon Field 2
Box Xmin: -8.5 Hame: Hum Parts
Box Ymin: 113.5 Tupe: N
Box Xmax: 1.5 Length: &
Box Ymox: 115.5 Dec Floces: @
HumPart=s: 1 Field 2
MumPoints: 9 Mame: Hum Foints
Fart: 1 index: @ Tup=: N
-6.5 115.5 Length: &
8.5 115.5 Dec Ploces: @
1.5 115.5 Field 4
1.5 114.5 Mame: Area
Tup=: N
Length: &
Dec Flaces: @
Fecord 13 1 1 9 3
Gravel.shx Recard 2: z 1 7 2
Record 31 2 148 2002 D244
File Code: 0094 Rennds 2 ! : 4
File Length (bytes}: 2628 Facord 5e 5 1 5 1
ens o 1ne Fecord 71 7 30 1238 1536
Shc_lpe Type: 3, Polugon Eecord S a i 5 i
m:: :g-g Fecord 91 9 1 5 1
Xmax; 1_”'.5 Fecord 181 18 1 7 2
Vmascs 115.5 Fecord 111 11 1 a =2
F!ecor.'d Nun‘|ber‘: 1 Fecord 12: 12 2 54 3
Offset (butes}: 188 Length: 182 Rocondale: 13 ! 2 !
Record Humber: 2 Record 15: 15 i 5 1
Offset {bytes}! 388 Length! 168 BeCard g 16 1@ aza 256
Becord Humber: 3 o LA i . = }
[ Z

The three shape files and the corresponding plot that were produced via the
Utilities->Class Map Editor Export function. Only a portion of each file is
shown in the text windows. See section Class Map Editor for more details.

Wl Do you also want a text window(s)
list of the individual shape file
records in addition to the plot?

( cancel ) ( Yes ) EoNo)

Choosing an * shp file results
in the above dialog so that you
may skip the records output.
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HDF Files

The Hierarchical Data Format (HDF) was developed at the National Center for Super-
computing Applications (NCSA) at the University of Illinois at Urbana-Champaign. Most
of the image/data formats described in the NCSA HDF Specification and Developer’s
Guide, Version 4.1r5, November 2001 can be loaded and saved in HyperCube. The strong
exceptions are: the complex data type is not supported and the number of dimensions (rank)
must be less than or equal to three for Numeric and Scientific Data Groups.

Load an HDF image by selecting menu File -> Open As... and choosing HDF as the
file type. This results in the following dialog listing all of the single images and Scientific
Data sets residing in the file. The list displays the characteristics of each embedded image.
Select 1 or more images (use shift click for a contiguous region and command click for dis-
contiguous selections) and then Load. If an image is multiband (number of bands greater
than 1) then a subsequent dialog appears exactly as described in section Image Format
Dialogs allowing you to load any portion or overview of the multiband image.

EO1H2030252004116110PZ.L1R Images

The list displays the images contained within the
HDF file along with their characteristics. Use the
shift and command keys to select 1 or more
images to load.

# Pixels Lines Bands Bits Type Size Offset
1 256 3351 242 s16 wmulti 415202394 2582
2 256 242 1 f3az gray 247808 415704886
3 256 242 1 f3az gray 247883 415452614
4 256 242 1 fiz gray 2478R8 415780427
5 256 33s1 242 uf  multi 287601152 415948734

( cancel ) ( Load Image )
e e il e

A listing of the 5 images within the HDF file.
The first and last images are multiband with
pixel depths of 16 and 8 bits per pixels respec-
tively. Selecting the first image brings up the
dialog shown on the right (see section Image

Format Dialogs).

If menu item Edit -> Options -> Detailed Messages is Caonia 1 exopRIOE w2
L. . DFTAG_YERS |ON

toggled on (checked) then a listing of all of the recognized R ———

tags in the header portion of the HDF file is generated. e

This is a tiny fraction of the tags contained in the image ikl I e

example shown above.

Load EO1H2030252004116110PZ.L1R
Data length: 623553249 bytes.

Pixels: I256 Header (bytes): 2502

Lines: 3351 Interleave: [ BIL (line seq) ['3)

Bands: 242 Byte order: [ Mac,Su... | :]
Pixel type: | 16 bit signed i ]

Normalization to convert data to [0,1] interval:

scale: |1 offset: 0

Requested Input Size:

Starting pixel: 1 # of pixels: 256
Starting line: 1 # of lines: 3351
Starting band: 1 # of bands: 242

Display remapping:
O] Remap bands as a group, %: 95

) Remap bands individually, sigma: 2.5

_Use G & O ( Load Gains & Offsets... ) (Overview... )

( Cancel ) (‘Save hdr...) (‘Load hdr.. ) ( Stats ) {Load?)

® O O EO01H2030252004116110P...

ODH:
block size: 288
rnext block: 8 @

scientific data

0D 2 ExEEE0Ze

BxE2be 5 Bx18bfa5ch 247283
DFTAG_SO

scientific data

00 4 BxBe083a

BxBZbe 7 Bx18c34doh 247203
DFTAG_SD

scientific data

0D 5 @xEEaE046
Bx82be 9 B:x18c715c6 247282
DFTRG_SD
scientific data

00 & BxBEEEES2

BxEZbe 11 Bx18coddef  2O76E1152
DFTAG_SO

scientific data

4

HyperCube Pictorial User’s Guide  09/06/12

13



JPEG Files

Baseline JPEG files may be loaded and saved by HyperCube. Specifically, these are de-

fined by ISO 10918 as:

* DCT - base process

8 and 16 bit samples per component (a little beyond baseline)

* Sequential
* Huffman coding
* 1,2,3 or 4 components

¢ Interleaved and non-interleaved scans

To load a JPEG image file select File -> Open As..., JPEG and choose the file. If the

image is not in JPEG format then you will get an alert message. Once loaded, a JPEG image

is treated like any other loaded image and can be saved in any of the image formats.
Saving an image, either gray, pseudo or true color, is done via File- > Save As..., JPEG

when the image is the active window. This displays a subsequent dialog (after the standard

save file dialog) that allows you to choose the level of compression as shown below. Also

shown on the right is a text file dump of the various JPEG markers for the loaded image
which appears if Edit -> Options->Detailed Messages has been checked before the image

is loaded.

Note: Because JPEG is a lossy format you cannot save a classmap in JPEG format. The
color correspondence will be lost, use NITF, PICT, SRF or TIFF.

Select JPEG Compression

Select the compression quality level. The
higher the guality the less the
compression and the larger the file size.
‘Fine’ quality is visually indistinguishable
from the sourc ~

Normal s —
Quality:

= = Super Fine
[_ Cancel |

Three levels of compression
available to you when saving
an image in JPEG format.

A portion of the JPEG markers defining
the contents a loaded JPEG image. This
text window appears automatically if
Edit->Preferences->Detailed Messages is
checked.

Tulips.jpg_high markers

==

ffed lengthi 16

XY thumbhail: 8,8

ffed length: 6212
APF13: Photoshop 3.8

fffe length: 29

File written by Adobe Photoshopd 4.0

ffee length: 14
APF14: Adobe

ffdb length: 132
Precision/ID: @,8
aT table:
6 4 4 6 9111216
4 55 6 8181212
4 5 5 618121212
6 6 6111212 12 12
9 81812 12 12 12 12
118 12 12 12 12 12 12
12 12 12 12 12 12 12 12
16 12 12 12 12 12 12 12
Precision/I0: @,1
0T table:
7 71224 28 28 17 17
71216 14 14 12 12 12
13 16 14 14 12 12 12 12
24 14 14 12 12 12 12 12
28 14 12 12 12 12 12 12
2@ 12 12 12 12 12 12 12
1712 12 12 12 12 12 12
1712 12 12 12 12 12 12

ffcl@ length: 17
Sample precizion: &
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LASFE/ASCII LIDAR Files

Files of type LASF (e.g., LIDAR point cloud data) can be loaded using menu Open As
and choosing LASF as the Format. The file is converted from its individual points to a raster
image that can be resaved in LASF or any other HyperCube format. Any combination of
elevation, intensity, or RGB values can be extracted. In addition, LASF files that have been
converted into ASCII columnar text files, where columns represent X,Y,Z intensities and
RGB can be similarly processed by using Open As... ASCII LIDAR (this description follows

the current LASF details).

There are two basic problems when converting point data to raster data. Because point
cloud data doesn’t have a uniform spacing the resulting raster image will contain some
“holes” and some overstrikes (multple points mapped to the same pixel and line). The larger
the scale (expansion) the more voids and fewer overstrikes. The Returns popup menu per-
mits keeping a specific elevation in overstrikes (e.g., the lowest elevation mapped to a pixel/
line). The dialogs, shown below, specify which return values to rasterize, the output scale
and an option to interpolate single pixel holes by using neighboring raster values.

Generally, the scenario for loading LASF files is to load an overview and then select a
rectangular area to be loaded at full resolution. The resulting image will automatically be
given the reference coordinate system defined by the points’ X and Y values.

See section Utilities (Merge LLAS Files) for a method to merge two or more LAS files
having common UTM zones into a single LAS file.

Load LASF Data

This file does not contain
RGB values. Only eleva-
tion and intensity are
available.

Simple raster holes
can be interpolated.
See following pages
for an example. — |

Exclude zero only af-
fects the display.

— Source

File: '19907g_010.las'

# records: 30080142, pixels: 4151, lines: 7246
System ID: ALTM System (c) Optech

Gen Software: DashMap 1.1000 WD 04

I

— Output

E Load and rasterize elevations

E‘ Load and rasterize intensity values
Load and rasterize RGB image

Returns: | Process specific r... |4 l Return #: 1

Location of the Intensity return number:
() As defined in LASF 1.2 ®) OpTech/DashMap

— Display
"1 Spike suppression, delta (m): M/A # passes: MN/A

E‘ Remap display using:

() min & max (@) median interval, %: 95.0

™ ™ (M 199079 010 intens1 (1:8)

M Exclude zero values

Overview scale:

Interpolate "holes”, degree: [ Slight = ||

( Cancel ) { Load Overview ) Load |

Image file details.

Process all returns

v Process specific return #
Use lowest elevation
Use highest elevation

Additional criteria
to determine which
elevation values to
rasterize.

| The degree of
hole interpolation.

v

“ (&) W

A segment of the overview is shown on the left. The green
selection rectangle delineates the portion that will be
loaded using menu File -> Load Selection. The image

background was set to white for this illustration. The full
resolution subset appears on the following page.
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Load LASF Data

— Source
File: '19907g_010.las'

Selection: pixels: 672, lines: 816, scale = 1 ThlS Wlll be [he image
System ID: ALTM System (c) Optech ]
Gen Software: DashMap 1.1000 WD 04 T Size Of ﬂ’le Selection
Load both. S based upon an Output
E Load and rasterize elevations Scale Of 1 .
E Load and rasterize intensity values
Their are no RGB Load and rasterize RGB image
values lI’L ﬂ’liS ﬁle Returns: | Process specific r... }% l Return #: 1

Location of the Intensity return number:

() As defined in LASF 1.2 (@) OpTech/DashMap

Fill in missing ras-
— Display
ter values. Interpolate "holes”, degree: [ Slight I-E'!

["1Spike suppression, delta (m): /A # passes: MNfA

B Remap display using:
(I min & max () median interval, %: 98.0

The scale of the subset

E'Exclude zero values l
— / can be selected to mini-
Qutput scale: 10

mize the appearance of
Cancel | Load Overview (" Load Select ) voids.

This dialog appears after selecting an area on the overview and choosing menu
File -> Load Selection. Both the return intensity and Z values are selected as
well as the option to interpolate any zero (missing) rasterized values that.

19907g_010 intens1 19907g_010 z

h g
< (&) Y =

The LIDAR Return number: 1 intensity. The corresponding LIDAR Z values.
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The dialog to the right was used to load and

rasterize the two image subsets shown below

which were subsequently generated from
menu Applications -> Shaded Relief. Note
that Use lowest elevation has been selected
in order to minimize vegetation effects.

A spike is a rasterized elevation that ex-
ceeds each of its neighbors by the value set
in delta (m). # Passes ranges from I to 12
and determines the pattern of surrounding
elevations that form the comparison.

Load LASF Data

— Source
File: 'points_a2_mwtc_tilel.las'
# records: 114906659, pixels: 9826, lines: 11694
System ID: AGC Buckeye Optech 30/100
Cen Software: TerraScan

— Output
8 Load and rasterize elevations
ELoad and rasterize intensity values

| Load and rasterize RGB image

Returns: | Use lowest elevat. .. Hv-i Return #: MN/A

Location of the Intensity return number:

{®) As defined in LASF 1.2 () OpTech/DashMap

— Display

Interpolate "holes”, degree: [ Medium @‘

ESpike suppression, delta (m): 1.0

# passes: |12

ERemap display using:
() min & max (@) median interval, %: 98.0
E Exclude zero values

Overview scale: H_J

:I'-‘If .:.:.__JI_. b P{'rﬂ i rs
_':Il._-_ .i‘"':".J'J;. | ¢ = _‘?u'__r.-"! :

it

( Cancel ) (" Load Overview ) f—h'md'ﬁnma
BRI o T
I _llJ-___'I. ¥ -i:'l:-'-l_?-'II 1 .
L At ‘}f'r; '
Ly s s E
';“i',:r ﬂl_llf‘

subset of an LASF file in which the Returns
popup menu was set to Use lowest eleva-
tion. The black dots indicate shadows cast
by vegetation spikes.

A shaded relief of the same area after
selecting Spike supression and 12 passes
in the dialog shown above.

LIDAR data is sometimes stored in a text (ASCII) format consisting of three or more col-
umns. However, since there is no detailed header, processing requires doing an initial pars-
ing of the file to determine its X and Y boundaries. This requirement along with ASCII to
binary decoding results in much longer execution times than having the file in LASF. Plus,
the converted raster image may be in a local X,Y coordinate system. However, this can be
corrected by using menu Edit -> Options -> Image to Ref Coords. Shown on the lower

half of the following page is the dialog after opening a file as ASCII Lidar.
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™ M O 19907g_010.las hdr e &% 19907g_010.las hdr

File Source 1D: @ GeoDoub leParams {34736 )1
5378137
Global Encoding: @ EASETS2
202
GUID data 15 @ ]
GUID data 2i @ 8
GUID data 31 @
GUID data 4: Geofsci iParams {34737 ):
#P1E_DROZER " “0AL=SG% ™3erkd 07k [@&0E DireOp: EGE[=0
Yerzion Majori 1
Version Minar: @ Data {OpTech/DashMap 132
x W z Intens UUNDEF #_Rets Scon_Dir Edge FRet# Angle User Pi_I0 GPS_Time
System |dentifier! ALTH System {c) 321894 4853481 2868 13 1 1 1 a 1 [} 32 ] 414845
Optech 331884 4853481 2863 13 1 1 1 ] 4 a 32 G 414845
Generating Software: Dashfap 1.1868 WD 3IT1626  4B53651 5873 13 1 3 1 § 1 =} 32 2] 414845
a4 3IS1918 4653493 3966 1 3 2 1 ] 4 a 3z ] 414045
3IT1916 4653493 3966 [ 1 1 1 ] 1 a 3z ] 414045
File Creation Day: 1 381816 4853453 3866 a 1 1 1 a 4 a 32 ] 414845
File Creation Year: 1 381815 4853453 3866 ] 1 1 1 ] 1 a 32 ] 414845
IS5 4953483 3966 a 1 1 1 a 4 a 32 a 414045
Header Size: 227 31813 4853452 3967 1 1 1 1 ] 1 =} 32 ] 414845
Offsat to pt data: 759 31813 4853452 32867 1 1 1 1 ] 4 =} 32 ] 414845
Humber of wariable recs: 3 31811 4853452 32867 1 1 1 1 ] 1 =} 32 ] 414845
Pt Data Format |D: 1 3B1811 4853482 3867 1 1 1 1 a 4 a 32 a 414845
Pt Data Rec Length: 23 3B1818 4853481 3867 a 1 1 1 a 1 a 32 ] 414845
Humber Pt Recs! 38858142 331816 4853481 3867 2] 1 1 1 2] 4 a 32 ] 414845
Humber Pt Rec Returns: 321289 4853481 3967 2] 1 1 1 2] 1 a 32 2] 414845
15840871 321880 4853481 3967 o 1 1 1 o 4 o a2 o 414845
a 391982 4853481 3967 ] 1 1 1 ] 1 a 3z ] 414045
a 351983 4953431 3367 a 1 1 1 a 4 a 32 a 414045
15646871
a

X scale factor: @.81
Y scale factor: @.81
Z scale factor: @.881

e If menu Edit -> Options -> Detailed Messages is selected before
g artsa opening a LASF file then header information and approximately
Max X3 335299.82 the first 30 point cloud values will be listed in a text window

Min X: 321479.48
Max %@ 48532658.55 . M
Hin Vi 4n33018.07 (shown here broken into two parts for display purposes).
Max Z: 5872.38
Min Z: 2867.94
Yar- length record 1
Reserved: 43787
User |0 LASF_Projection
Rec 10X 34735
Rec length: 72

Load ASCII LIDAR

— Source

File: 'River 3A.txt'

# records: 12478170, # cols: 7, pixels: 2843, lines: 4388

Rec 1: N E El Intensity Red Green Blue

Rec 2: 4249276.376 283069.538 2015.826 -1136 103 80 73

Rec 3: 4240276.376 283069.538 2015.820 -1144 92 79 61 8.0.0 Ascii Lidar
Rec 4: 4249276.378 283069.533 2015.825 -1134 96 B1 64
(. Riwver 3A.tuxt
RE # pecords 12478178
" # zaro coords 1
Starting record: |1 ¥ min,max 252500.651008 253247654800
Y omingmox 4240020 547000 4240572, 705660
™ Load 2 2 mingmox 2611.200080 2565, 706686
T (— Intensity mingmax —-1717.0600808 26842 6608606
M Load Intensity Zone: 18 rgb 163606000 00 .GEG060 73066060
0 Delta X,Y¥,2 357.633860 551.261006 404.401608
g Load RGEB lHesolution, Fixels, Lines B.125765 2843 4388
— Display 7

Interpolate "holes”, degree: | Slight |4

Eﬂ Remap display using: . . .
Qs tmic @ medinieval % 900 This text window appears after parsing

™ Exclude zero values the file and displays information about
Overview scale: s the contents of the file.

{ cancel \ f' Load Overview ) ( Load Image ‘1

The ASCII LIDAR dialog above is very similar to the Load LASF dialog. The informa-
tion box at the top lists the first 4 records of the file and in this example shows that the first
record lists the order of the data which consisting of 7 columns: Northing, easting, elevation,
intensity and red, green and blue values.. The dialog contains the Starting record edit field
to allow skipping initial records. If you load the overview and select menu File -> Load
Selection another dialog will appear exactly like the one above permitting you to modify

some of the previously selected options (this works in the same manner as described in Load
LASF). Also, see section ASCII LIDAR to LASF.
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NITF Files

NITF (National Imagery Transmission Format) images are loaded via menu File ->
Open As... and then choosing the NITF item in the Format popup menu. HyperCube can
read versions 2.0 and 2.1 NITF data, gray, pseudo, true color and multiband images. It can
also extract embedded JPEG (DCT) and JPEG (2000) images (see Wrap JPEG in NITF
for inserting JPEG within NITF). Any graphics or text within the NITF file is ignored. If
the image is multiband, larger than 2048 (pixels or lines) or the pixel depth is greater than
8 bits (e.g., short or float) you are presented with the dialog shown below. This allows you
to load either an overview of the image (necessary if very large) or the entire image. Over-
view images are then used to select full resolution subsets that are subsequently loaded using
menu File -> Load Selection (see section Overviews). If there is insufficient memory to
load then you will be alerted with a message stating how much additional memory is needed.
Saving a 16 or 32 bit image as NITF saves the data as short or float.

If the NITF image is multiband you may select the starting band and the number of bands
to load and if Overview is chosen, the overview band and scale as well. To exploit a NITF
multiband image you must first save the loaded image cube. However, there are possible
memory constraints doing this and the best technique is to use menu Ultilities -> Reformat
Cube File to convert the NITF file into an image cube file.

A description of the image.

_ Load NITF Data
. NITF image '28_multispectral’ is:
What part Of the image to lOCld. 614 pixels by 512 lines by 9 bands by 16 bits (signed)
.o, . . . ™~
Initially, set to the image size. \ -
|_ Starting Pixel: 1 # of Pixels: 614

If multiband which bands to load. Starting Line: 1 #of Lines: 512

\

How to remap the data for display.
Also, see section Pixel Exclusion. \

r Starting Band: 1 # of Bands: |9

- ™ Remap display using:
@ min & max : median interval, %: MNJA

For the given size image, the scale ~—_————| Ovevewsale: 1

automatically computed to display (Cancet)  (toad — © € loadimage)

the whole image within the monitor. /

Select either an overview or the image at full resolu-
tion. You will be notified if insufficient memory.

[0 == 28_multispectral hdr = E1 B 28 multispectral imghdr
I‘f‘menu Edlt _> Optlons _> FHOR: MITFBZ.1@ 1Mz In
Detailed Messages is checked Fobei cro IDET i SoaRa i STt
. . OSTAID: i_322%9b TGTID:
then each NITF image load will FOT: 20000317i12510 1ip2: - This is an =xampls of o
. o . IPLTESTRROOUET T with i
produce windows listing the main ||| banss s o 1z. - iscLsv:
header and image header con- ESCLeY: ISCTL
. . FSCTLH: ISDCTR:
tents. Also, if the image header FSREL: ISDEDT £
FSOCTR: I S0CEM
defined a coordinate system, use Fanoan: \50007:
. . F50G: |SCLTX:
the Info Window to display them. || === - -
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PNG Files

A subset of Portable Network Graphics (PNG) files can be loaded and saved. The subset
consists of 8 and 16 bits per pixel gray scale and 8 and 16 bits per color images. Images of
other bit lengths (e.g., 1,2,4 bits) can not be loaded or saved. PNG files containing an alpha
channel can be loaded but the transparency (alpha byte) is ignored. If an image contains a
palette, the palette will be discarded after loading and the image will be converted to direct
gray bytes or a true color image depending upon the number of components. Image interlac-
ing is also not supported.

Currently, HyperCube does not generate an optimized compressed file when saving a
PNG image. It uses the standard fixed Huffman tables and the output file will be slightly
larger than an equivalent TIFF file. However, the file is correct and lossless.

Shown below is the result of loading a PNG file after setting menu Edit -> Options ->
Detailed Messages (applicable for any type of file loading) in order to list the PNG header
which in this case has been synopsized.

800 Yosemite.png IHDR
Width: 918
Height: 909
Bit depth: 8

Color type: 2
Compression method: 0
Filter method: 0
Interlace method: 0
CRC: 1920493681

RGB triplets: true
Alpha channel: false
Bytes/pixel: 3
De-filtering interval: 3

Chunks: name size dataStart CRC
iCCP 8482 41 1158558444

pHYs 9 8535 2024095606
Uncompressed blocks: 0 IDAT 8192 8556 3518965669
Fixed blocks: 0 IDAT 8192 16760 3907572812
Dynamic blocks: 74 IDAT 8192 24964 2565274342
Filter types: IDAT 8192 33168 3030120714
none(0): 0 IDAT 8192 41372 3541105835
sub(1): 10
up(2): 0
average(3): 121 The details at the left describe the composition of the
pacth(4): 778 compression used and the above detail (a segment of
the actual list) shows the type of image and some of

the PNG ‘chunks’.
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TIFF Files

TIFF ( Tagged Image File Format) images are loaded via menu File -> Open As....
HyperCube can read 8 bit and higher baseline TIFF 6.0 images plus 16 and 32 bit tiled format
images including LZW compression. Embedded JPEG encoding is not included. JPEG DCT
images can be read by themselves (section JPEG Files). If the image is larger than 2048
(pixels or lines) or the pixel depth is greater than 8 bits (e.g., short, float or 16 bits per color)
you are presented with the dialog shown below. This allows you to load either an overview
of the image (necessary if very large) or the entire image. Overview images are then used to
select full resolution subsets that are subsequently loaded using menu File -> Load Selec-
tion (section Overviews). Saving a 16 or 32 bit image as TIFF saves the data as short or
float in strip format even if the source format was tiled.

If the TIFF image contains Geo tags (i.e., it’s a GeoTIFF) then any coordinates will be
extracted and used as the image reference (section Image to Reference Coordinates). A
single tie-point GeoTIFF can be converted to a referenced image in geographics (lat/long)
with the geometry defined by RPC’s. This also works if the GeoTIFF is in UTM coordi-
nates. Saving an image that contains reference coordinates as TIFF saves it as GeoTIFF and
if saved as NITF with included RPC. If an RPC text file in the same directory has the same
image base name concatenated with _rpc. txt then it will be automatically read and used to
form the geo reference (see Stereo Compilation).

Image description. Load TIFF Data
TIFF image 'San Diego IKONOS.tif is:
What part ofthe image to load. 5073 pixels by 6007 lines by 16 bits (unsigned)

- i ; GeoTIFF, tiepoint: 473505.1 3635819
Initially, set to the image size. x,y scales: 1, 1

NOt usedfor TIFF see NITF Starting Pixel: 1 # of Pixels: |5073

\ Starting Line: 1 # of Lines: 6007
This GeoTIFF image has a single UTM A NfA

- Starting Band: # of Bands:

tie-point and can be converted to lat/long. B Generate lat/long RPC
AZSO, see GeoTIFF, JPEG to NITF. I ™ Remap display using:

. () min & max () median interval, % 980
How to remap the data for display. / —

Overview scale: 7

Also, see section Pixel Exclusion.

( Cancel ) [ Load Overview ) (" Load Image )

For the given size image, the scale
automatically computed to display

the whole image within the monitor. Select either an overview or the full image .
® ) O) San Diego IKONOS.if tags . . © M O San Diego IKONOS.if tags
If menu Edit -> Options ->

Fixels, Lines, Bits: S5S@73, 6067, 16 . . GTCi tationGeokey

SanplesPerfixel: 1 Detailed Messages is checked 2840 34737 9 22

SampleFormat: B {unsighed) Geogli tationGeokey

anarConfiguration: . . flois a 1 32611

Eiientgti;n? 1 t ! then eaC]’L TIFF lmage lOcld Wlll ProjectedCSTypetaokey

Tiled: false . . . 38?6 B 1 Q@1

AR 3 produce a window listing the Brall locaitstegkay.

i [8,1,2,...1: . Weriallni tsGecker
?éTAEf’?S?EE‘,‘?SiE,'..? ] main TIFF tags and any Geo Oodet Tupebackay: Frajaction Coard
StripOffsets[@, 1,2, ...11 . ystem i
R tags (left and right are same FUAC el s o e
Humber of strips: 6087 Al upr =l

N . northern hemisphere zone 11
umber o iles: ModelTi intTag:
L window, scrolled differently). el T
Tile height: @ ModelPixelScale:
TileByteCounts[@,1,2,...]: 8,08,8,... 118
TileOffsets[8,1,2,...]1 8,8,8,... g:gggz?:;Zﬁgzzs.:
Compression: 1 UTH, zome 11 | Meters|uGs &4, |

el
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Raw

The Raw image format permits you to specify the dimensions and format of general im-
age files and the resulting size of what will be loaded into an image window. The only differ-
ence between a Raw format and Multiband format (explained later) is that the Raw format
results in loading a single image plane. Opening a Raw image always results in displaying
an 8 bit image with the underlying source data in memory. You have considerable control on
how this file data is converted to 8 bits for display. The Raw image file to be opened is se-
lected by choosing Open As... from the File menu and then selecting Raw from the Format
popup menu. Since any file can be considered as a Raw image, the open dialog displays all
file types. You must know which files represent meaningful images.

Any operations that process the image (e.g. Fourier, Image Arithmetic, Line Profile
Plots, Mosaic, Warp) always use the actual underlying data instead of the 8 bit display val-
ues. Moving the cursor over a data image displays the data value when the Info window is
open. Histograms and Line Profile Plot operate on the data. See the Applications section
for examples of data usage.

ASCII Lidar
Bands

ERDAS Imagine
ESRI Shape
HDF

JPEC

el The Open As... dialog showing the

Multiband selection of a Raw format file.
NITF

Pict
PNG
SRF
Targa
Text
TIFF

Multiband

A multiband image differs from a raw image in that it consists of 2 or more registered
bands each having the same spatial dimensions. Multiband images are selected from the
same custom open file dialog as Raw shown above but with Multiband chosen from the
Format popup menu when you select Open As... from the File menu. Raw and multiband
images are defined by a format dialog (see below) that appears immediately after the Open
button is clicked. This dialog lists all of the information necessary to correctly read and
interpret the image file and to load the image into a window for display. The initial content
of the dialog is read from a simple ASCII text header file having the same name as the im-
age file but with a .hdr extension (see section Header Files). If this file doesn’t exist (i.c.
has yet to be created) then the dialog fields are empty. In either case you can edit the dialog
fields and save the proper values to create/update the *.hdr file. Subsequent opening of the
image or image.hdr file will display the image definition in the format dialog.
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Load dma_dted
Data length: 524288 bytes.

. . . . Pixels: 512 Header (b Y]
An image format dialog showing the defini- e eader Bytes

tion of an 16 bit 512 by 512 raw image ready
to load the entire image with remapping. The

Lines: 512
Byte order: = Mac,Su... m

Pixel type is unsigned short and Byte order Pixel type: [ 16 bit unsigned %)

indicates big endian. The image will be con- Requested Input Size:

verted to 8 bits for display but will also retain Starting pixel: |1 # of pixels: |512

the 16 bit underlying data that will be used in Starting line: |1 | #oflines: 512 |

all operations. Display remapping:

™ Auto remap %: 100  Overview... )

( Cancel ) (Save hdr...) (Load hdr.. ) { Stats ) Sload )

The upper portion of the dialog window defines the parameters of the image as it appears
on disk. Only the data length is determined by HyperCube, all other information must come
from you or the .hdr file. However, HyperCube does check the input for consistency.

Pixels: The number of pixels (columns) per line (row).
Lines: The number of lines (rows).
Header: The number of bytes, if any, to skip at the beginning of the file.

Pixel type: A popup menu specifying the format of each pixel
8 bit unsigned
16 bit unsigned
16 bit signed
32 bit floating
32 bit signed long

Byte order: A popup that indicates whether the most significant data byte is low order
in memory (little endian) or high order (big endian). Only meaningful for
16 bit and larger data. If gray values seem incorrect, try a different order.
PC (little endian)
Mac,Sun (big endian)
Unknown.

The lower portion of the dialog window is where you specify what rectangular subset of
the image file is to be loaded into memory. There are also options that determine how the
pixels are to be converted to 8 bits for display (the full pixel depth always remains in memo-
ry). Pixel conversion is explained more fully in the later multiband example.
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Specifically, the requested size fields have the following effect:

Starting pixel:

Starting line:

# of pixels:

# of lines:

Auto Remap:

%:

Save hdr...

Load hdr...

Stats:

Cancel:

Load:

Overview:

The first pixel within a line to load and corresponds to the left edge
of the resulting image display window. Pixel numbering begins
with 1, not zero.

The first line of the image file to start loading and corresponds to
the top line in the image display window. Line numbering begins at 1.

How many pixels per line should be loaded.
How many lines of the image are to be loaded.

If this check box is selected then the image pixels are automatically
converted from their pixel type to 8 bits based upon the distribution
of their histogram and upon the percentage popup menu. Generally,
this is meaningful only for 16 bit and wider data.

If Auto Remap is checked then this popup specifies what percentage
of the distribution of the histogram about the median is mapped to the
display interval [0,255]. See the statistical display window shown in
the multiband dialog example.

This button brings up the standard Mac save file dialog and allows
you to save the *.hdr file defining this image. Subsequently, opening
this image will refill the dialog fields from the *.hdr file.

Displays an Open file dialog so that you can load a possibly different
header file. There are no restrictions on the file’s name.

When clicked, this button reads the image file and generates
various statistics within the rectangular area that you want to load.
The results are displayed graphically in a new window. See
section Statistics.

The customary button for aborting the image load.

Loads the image automatically computing statistics as necessary.

This button loads a reduced resolution view of the source

image. The initial scaling is determined by the display screen size and

the Starting pixel, Starting line, # of pixels, and # of lines.
You can select a different scaling. See section Qverviews.
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The image format dialog window for a hyperspectral image is shown below. It includes
all of the raw image fields plus additional to define band depth and the relationship of the file
pixel values to an absolute [0,1] range for comparison with a reflectance library or when clas-
sifying one image cube against a different image cube (see section Classify Function).

Load drll
Data length: 129024000 bytes.

Pixels: _i320 Header (bytes): ©
The cube image format dialog showing the defi- Lines:  |960 Interleave: [ BiL (ine sea) [4)
nition of a 210 band image with 16 bit pixels. Bands: 210 | By order: [ Macsu.. )
Auto remapping of a 95% interval about the Pixel type: 16 bit unsigned  |'3)
median will be used to load bands 60 through Mermalization to convert data te [0,1] interval:
scale; 0.001 offset; 0

69. The pixel values were previously calibrated
to lie between 0 and 1000 will be converted to a
[0,1] range by scale.

Requested Input Size:

Starting pixel: 8 # of pixels: 308
Starting line: 1 # of lines: 960
Starting band: 60 # of bands: 10

Display remapping:
® Remap bands as a group, %: 95

) Remap bands individually, sigma: 2.5

_Use G & O ( Load Gains & Offsets... ) ( Overview... )

( Cancel ) (Save hdr...) (‘Load hdr.. ) ( Stats ) { Load )

The additional fields are defined as:

Bands:

Interleave:

scale & offset:

Starting band:

# of bands:

Load hdr...

Total number of bands in the image.

A popup menu indicating the type of data arrangement:

Band Line 1 through N for band 1, Line 1 through N for band 2,...
Line Line 1 for all bands, Line 2 for all bands,...

Pixel Pixel 1 for all bands, Pixel 2 for all bands,...

These are the transformation coefficients that convert a file pixel to
the range [0,1]. This has nothing to do with display only spectral
library matching and classifications with another cube. In the
example above the file pixels lie between 0 and 1000 so the
transformation is .001 and 0. Also, see Load Gains & Offsets.

Which band from the image will be the first display band. Band
numbering begins at 1.

How many sequential bands beginning at the starting band should
be loaded.

Displays an Open file dialog so that you can load a possibly different
header file. There are no restrictions on the file’s name.
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Remap bands individ: Each band’s statistics is used to rescale it for presentation.
Choosing this option produces a display cube having a
uniform brightness and contrast. This only alters the display
and does not affect any subsequent analytical operations.
Also, see Remap bands as a group which preserves
the relative band to band brightness differences.

... sigma: For each band’s mean and standard deviation, pixels within
[mean - sigma*sd, mean + sigma*sd] are mapped to [0,255].

Remap bands as a group: The composite statistics for all of the bands that are
to be loaded are computed and applied globally. The result
is a display cube that represents the intensity variation of the
image cube file.

Load Gains & Offsets... Allows you to open a text file containing a list of gains and
offset pairs that will be applied every time cube file data is
accessed and affects all analytical operations such as
plots and classifications. The number of gain & offset pairs
must equal the number of cube file bands, not just the number
of bands loaded. After a gains & offsets has been loaded the
the data is internally converted to floating even if the source
file data is integer and the gains and offsets were also integers.
Therefore, subsequent operations will be a little slower than
if no gains and offsets were in effect. The scale and offset
fields that are used in Normalization to convert data to [0,1]
interval are applied after any gains & offsets, so be sure to
change this transformation to match the new range.

After loading a G & O file the Remap Bands check box will
be on. This is necessary due to the new floating point range.
Remap can be checked off but the resultant display image
cube will probably be very unsatisfactory. In any case, this
will not affect the plots or classifications.

See sections Spectral Calibration, Reformatting a File

for more on gains & offsets.

Use G & O: Automatically enabled and checked on after a gains and offsets
file is loaded but may be checked off to discard the gains and
offsets. To determine later whether a G & O file is being used
by a cube open the Info window, (Windows -> Show Info),
and examine the Kind field. It will show Kind: CUBE w/G&O

if one is being used.

The remaining cube file dialog fields are identical to those of the raw format.
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Overviews

The File- > Open As menu items: Multiband, Raw and certain ERDAS Imagine®,
NITF and TIFF dialogs each contain an Overview button. Its purpose is to generate an im-
age of reduced scaling that displays the entire or user specified subset of the image at a scale
so that scrolling is not needed. A dialog is presented showing the nominal scale factor and
the overview band which you may edit.

The Requested Input Size, the bottom portion of the dialog, specifies the area of the im-
age used to generate the overview. The remapping options are used as normal to produce a
decent appearing image. When generating a multiband overview, dialog item Starting band
is the default image for the overview.

Once an overview image has been generated you can draw a rectangle (see section
Selection Rectangle) on it that defines the portion of the source image to load by choosing
menu File -> Load Selection. Doing so brings up the dialog defining the image along with
the Starting pixel, Starting line, # of pixels, and # of lines representing the image subset
delineated by the selection rectangle. If no selection rectangle has been drawn on the over-
view then the fields will be set to the spatial extent of the overview. For multiband images,
the original Starting band and # of bands are not changed. You may edit any value before
clicking the Load button.

Load dma_dted O

dma_dted {1:2)

Data length: 524288 bytes.
Pixels: ..512 . Header (bytes): 0
Lines: 512

Byte order: | MacSu... |[%

Pixel type: 16 bit unsigned |5

Requested Input Size:

Starting pixel: 1 # of pixels: 512

Starting line: |1 # of lines: 512

Display remapping:
™ Auto remap %: 100 [ Overview... |

(" Cancel ) (Save hdr...) (Load hdr.. ) ( Stats ) € Load )

Choosing Overview from the dialog at the
upper left generated a 1:2 scale of the im-
age shown above. A selection rectangle
was drawn and File->Load Selection was
used to display the dialog at the lower left.

Load dma_dted

Data length: 524288 bytes.

Pixels: 1512 Header (bytes): 0 . .
e Note the new values that delineate the im-
Ryta order: [Macsu I age shown below when the Load button was
_ clicked.
Pixel type: | 16 bit unsigned |'§'J
Requested Input Size: 0 tma dted —H 2
Starting pixel: 95 # of pixels: 193
Starting line: 38 # of lines: 150

Display remapping:
@Auto remap %: 100 Owverview..

( Cancel ) (Save hdr...) (Load hdr.. ) (" Stats ) (Sload )
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Saving Overviews

An overview image serves as a convenient method of automatically extracting the source
file and saving it in a possibly different file format. This applies to both a selection rectangle
and the entire image. Specifically, NITF, TIFF and Raw image overviews can be saved in
any of those 3 file types. Cube image overviews can only be saved in cube image format.
Save is always performed on the source image file depth . Any reference coordinates associ-
ated with the source image overview are correctly propagated to the saved image file (see
sections Image to Reference Coordinates and RPC Files). If the overview is color then
the output is restricted to NITF and TIFF.

Shown below is a typical dialog that appears after selecting menu File->Save As when
saving an overview image. In this case the overview has a selection rectangle defined. Also,
see sections: ERDAS Imagine®, NITF Files, TIFF Files and Overviews for detail con-
cerning the generation of overviews.

Do you want to save the image
{selection} at full resolution and
depth from the source file or the
scaled image as displayed?

cancel | [ scaled | [ FullRes ||

O=——nillRes=——-HH

q |z

A true color 1:6 overview image The reloaded image resulting from clicking
with a selection rectangle. the Full Res button in the above dialog.
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Header Files

As stated previously, each image file can have a unique ASCII text header file that con-
tains all the image characteristics needed to load and display it. This file has the same name
as the image but with a .hdr extension and must reside within the same folder as the image
file. The two header files shown here (opened as Text files) correspond to raw and multiband
examples respectively. They consist of key word assignments, one pair per line in no specific
order (see section Keyword Format). A missing assignment defaults to “no” or zero. Any
value can be overridden when brought up in the image format dialog and optionally re-saved.
Although header files can be generated using HyperCube (see section Loading/Saving Text
Files) and saved as “Text”, it’s easier to fill in the dialog fields and click the Save hdr... but-
ton.

HyperCube can read certain ENVI® header files. Not every format is supported. The
program first looks for the beginning ENVI® keyword and if found parses only the informa-
tion necessary to conform to its own header parameters including wavelengths and bad band
definitions. You are alerted if an ENVI® header file is being read. Saving (Save hdr...) in-
formation extracted from an ENVI® file writes a new HyperCube file not an ENVI® header

=

file.
Raw Multiband Raw with Ref Coords
0 18.hdr =—=HIH O =Frames 21-24rhd =B 0 =———dted2zhdr=—HH

samples = 512 samples = 320 f?mgéei ;1312

lines =512 lines = 1280 header offset = @

header offset = O bands = 210 file type = raw

file type = raw header offget = 0 dAtd Rops Fot

data type = 1 file type = multiband ustart = 1

xstart = 1 data type = 3 P fxelsssaole

ystart = 1 interleave = bil byte order = big endian

numpixels = 512 wstart = 9 S::gzﬁ:ll”%; yes

numlines = 512 ystart = 1 sync type = @

Sute arder - big endian rumpixels - 507 C s
numlines = 1280 lower left = OF.30000000 543 .37500000

7 byte order = big endian |lower‘ right = 680.10088008 543 .12500800
bandstart = 60
numbands = 10 Z
autoscaling = yes
percent = 95
normscale = 0001000
normoffset = 0000000 O overviewhdr=—H8
g samples = 251

lines = 533
header offset = @
file tupe = raw

ystart = 1

numpixels = 231

numlines = 333

byte order = big endian

sync type = @

icords = G

upper left = 381152.94 B771947.01
upper right = 281284.94 @771581 .61
lower left = 380354.34 8771022.64
lower right = 326488.3H 77144590

7

Various examples of header files. The last 4 lines of the two right examples list the
corner coords of the source image in an external reference system where each keyword
specifies an X,Y pair (see next section, Keyword Format). Any combination of 1,2,3 or
all 4 keywords may be given. Selecting menu Windows -> Show Info will display the
computed reference coordinate as a function of the window cursor position. Section
Image to Reference Coordinates describes how to edit these values.
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Keyword Format

Keywords used in the header file are defined below. Each keyword is of the form:
keyword = value. None of the words are case sensitive.

Keyword
samples

lines
bands

file type

data type

interleave

xstart
ystart
numpixels
numlines

byteorder

bandstart
numbands
autoscaling

percent

bandnormalize

sigma

Value
number of source image pixels per line

number of source image lines
number of source image bands, if multiband or sync

multiband

raw

1 - unsigned byte

2 - unsigned 16 bit short

3 - signed 16 bit short

4 - 32 bit float

5 - 32 bit signed long

bsq - band sequential

bil - line sequential

bip - pixel sequential

starting pixel within the source image to load
starting line within the source image to load
number of pixels to load beginning at xstart

number of lines to load beginning at ystart

little endian - PC
big endian - Mac, Sun

starting band to load for display purposes

number of bands to display starting at bandstart

yes - remap image for display purposes

% of remapping statistics to use for display purposes
yes - remap each displayed band using its own statistics

number of standard deviations used by bandnormalize
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normScale

normOffset

sync type

icords

upper

upper

Tower

Tower

color

color

color

color

annl, .

left
right
left
right

specific

intervals

equalize

percent

..,annN

scale factor to convert pixel values to [0,1] range
offset to convert pixel values to [0,1] range

tc - true color synthetic cube

% - classify overlay synthetic cube representing percentage
# - classify overlay synthetic cube representing counts

d - classify overlay synthetic cube representing thresholds

G - reference coords represent latitude and longitude
formatted as ddmmss.sZ for latitude (y) where Z is N or S
followed by dddmmss.sZ for longitude(x) where Z is E or W
D - decimal degrees latitude (y) and longitude (x)
Note the order: latitude value followed by the longitude value.
U- UTM coords. Each reference is a triplet defined as:
(Easting, Northing, Zone) in the WGS84 datum.
A negative Zone indicates the Southern hemisphere.
Also, icords is not required to define a reference. If icords is
missing then the reference system is general.

x,y reference coord pair [triplet] corresponding to pixel, line [1,1]
X,y pair [triplet] corresponding to pixel, line [# image pixels,1]

X,y pair [triplet] corresponding to pixel, line [1,# image lines]

X,y pair [triplet] corresponding to ... [# image pixels # image lines]

red, green and blue wavelength values corresponding to those in

menu Image -> Cube Color Composite -> Definitions

red, green,blue wavelength intervals corresponding to those in

menu Image -> Cube Color Composite -> Definitions

0 - use color percent value in Cube Color Composite
1 - use histogram equalization for Cube Color Composite

remapping percentage corresponding to the value in

menu Image -> Cube Color Composite -> Definitions

keyword not present if color equalize = 1

free text annotation associated with each (1,...,N) band that
is displayed in the band scroll area (see Annotation List).
Note: a space instead of ‘=’ 1is used to separate the key word
from the text. For example:

ann26 Band 26 contains vertical striping

Upper case letters are maintained.
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Image to Reference Coordinates

You can specify the relation between image coordinates and a reference coordinate
system by including keywords such as upper left, upper right..., described in sections
Header Files and Keyword Format or at any time an image window is active by choosing
menu Edit -> Options -> Image to Ref Coords. This displays a dialog showing the cur-
rent pairings of the image corner coordinates and the corresponding reference coordinates. If
no relation has been defined then the default mapping is the identity and the reference values
will match the image values. Note that the dialog is completely general and you may specify
other than the given corner coordinate pairings, e.g., a known image interior point and the
matching reference point. From 1 (simple translation) to 4 (rational poly) pairs of coordi-
nates can be specified. The Enable check boxes allow you to exclude any pairings. Saving
an image after defining an image to reference relation saves the equivalent corner coordinates
to reference mapping in the image’s header file. The option for formatted latitude and lon-
gitude is specific: ddmmss.sy where y is either N or S for latitude and dddmmss.sz where z
is E or W for longitude. Some general reference values don’t correspond to geographic or
UTM values and you will get a warning message. Use a negative Zone to indicate the South-
ern Hemisphere. The Verify button checks the validity of the current values against the cho-
sen reference system. Reset restores values to those when the Dialog was opened. Radio
button None will remove any existing image to reference.

Note: Changing the image origin via Edit- > Options- > [0,0] Image Origin will dis-
able all Image to Reference correspondences in effect and will have to be re-established.
Also, some image formats such as NITF and TIFF have reference coordinates in their headers

which will be automatically extracted (see sections NITF Files and TIFF Files).

Image to Reference

Image to Reference

Enter 1 to 4 image and reference coordinate pairs to define a mapping
between the image and reference coordinate systems. Only Enabled
points are used to compute the mapping and type of transformation
(offset, rotation, affine, poly).

Enter 1 to 4 image and reference coordinate pairs to define a mapping
between the image and reference coordinate systems. Only Enabled
points are used to compute the mapping and type of transformation
(offset, rotation, affine, poly).

Define Reference value units as:
(") None, remove any current mapping
O General, any decimal values
() Longitude (x) and Latitude (y), +-ddd.d...
O Long (x), dddmmss.s...[E,W] and Lat (y), ddmmss.s...[N,S]
® UTM: Easting Northing +-Zone in WGS84 Datum

Single point reference x and y pixel scales, meters: |1 1

Enable Image x Y
1™ |1 1

2™
N
4™

Reference x
313986.59

Reference y
429029396

Zone

1058 1 313470.24 4290223.03

gla 31393249 4290679.73

1088 gl6 313418.67 428060971

18
18
18
18
) ( Okay )

( Cancel (

Reset ) (" Verify

Define Reference value units as:
(") None, remove any current mapping
O General, any decimal values
() Longitude (x) and Latitude (y), +-ddd.d...
8 Long (x), dddmmss.s...[E;W] and Lat (y), ddmmss.s...[N,S]
() UTM: Easting Morthing +-Zone in WGS84 Datum

Single point reference x and y pixel scales, meters: 11

Enable Image x ¥ Reference x Reference y Zone
1 E[ “1 1 0770825.07W 354430.30M -
2 ¢ 108 1 0770545350 3E4427 61N [ |
i 1 516 0770827 670 384442 76N [ |
4 M 1088 818 0770348500 384440.100 [ ]
(Cancel ) (" Reset ) ( Verify )  Okay )

The dialog window on the left shows a reference system expressed in UTM coordinates while
the dialog to the right shows how the values have automatically changed after selecting the
Geographic units as the reference. No changes take effect until the Okay button is pressed
and all units are within the expected ranges of the chosen reference system. The type of units
will be displayed in the Info Window as a function of cursor position within the image. The
x and y pixel scales are used when there is only one reference pair, typically, the upper left.

Either scale may be negative but not zero.
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Geo/UTM Reference Grids

Any image that has a geographic reference (either via a geo tif or a corresponding RPC
file) can be displayed with an overlaying Latitude, Longitude or Northing, Easting grid.
Menu Edit -> Options -> Geo/UTM Ref Grids... displays the following dialog.

. . . Geo/UTM Grids
Enable/Disable a grid over all applicable

currently open image windows.
Only the current image.
Overlay grid color. Remains in effect ————————— [ Color(rg.b): [207 ] [255 |

until changed. (_Cancel ) ((Enable )

Apply reference grids to:
() All images
® Only current image

\

—

( Disable )

Image to Reference

Enter 1 to 4 image and reference coordinate pairs to define a mapping
between the image and reference coordinate systems. Only Enabled
points are used to compute the mapping and type of transformation

(offset, rotation, affine, poly).

The Image to Reference dialog shown on

Define Reference value units as:
(") None, remove any current mapping
(") General, any decimal values
O Longitude (x) and Latitude (y), +-ddd.d...

Single point reference x and y pixel scales, meters

Enable

() Long (x), dddmmss.s...[E,W] and Lat (y), ddmmss.s...[N,S]
{® UTM: Easting Northing +-Zone in WGS84 Datum

=11

the left displays the coordinate reference
that was derived from an RPC file corre-
sponding to the image show below.

Image x y Reference x Referencey  Zone
1 ||1 l 1 60493173 345406651 14
2 a g1z 1 604733.80 345790932 T
3 1 512 60855951 345418689 [14 |
4 E 512 51z B05630.45 34575586.61 T
(__Reset ) (Okay )

Mini axes show the direction of
increasing Northing and Easting.

If the geo-reference was derived
Jfrom a RPC file then the direction of
increasing height is also indicated
by the green line segments in each
corner of the image’s window.

8066

’

219rgb.tif (1:15)
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C te G hic Rati | Pl ial Coefficient
Any image that has a geographic reference either in Latitude/Longitude or UTM can

be modified to contain an equivalent set of RPCs. If the image already has RPCs a warn-

ing message will be presented in order to proceed and overwrite the existing one. Selecting

menu Edit -> Options -> Create Geo RPC... with the target image active displays the

dialogs shown below. If the image is unreferenced then menu Edit -> Options -> Image to
Ref Coords... can be used to add one.

Window 'I8.tif' does not have a Geographic A Window 'Dem32bit (1:4).tif is defined
4 or UTM reference system. Use menu Edit “% in UTM coords and can blf
-> Options -> Image to Reference to transformed to Geographic coords
define one. with an included RPC.

)
m Cancel y

( Create RPC )

Window 'Dem32bit (1:4).tif" already
contains Rational Polynomial
Coefficients (RPC). Continuing will
allow you to overwrite the existing
RPC.

A

Cancel ) Continue

Any image that has a geographic reference in Latitude/Longitude can be transformed to
a UTM coordinate system and vice versa (i.e,. UTM to Geographics). If the image contains
Rational Polynomial Coefficients (RPC) these will also be converted as shown in the dialogs
below. If the image has no reference then menu Edit -> Options -> Image to Ref Co-
ords... can be used to add one.

Window 'Dem32bit (1:4).tif' contains Window 'Dem32bit (1:4).tif' contains
A Rational Polynomial Coefficients (RPC) A Rational Polynomial Coefficients (RPC)
defined in UTM coords and can be defined in Geographic coords and can
transformed into a Geographic coord be transformed into a UTM coord
system containing RPC. system containing RPC.
( Cancel ) ¢—==xGeo—) Cancel ) [ —=>UuUT™M )
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Rational Pol al Coefiic RPC) il

When an image file is opened the program automatically searches for a file in the same
directory having the same base name concatenated with ‘_rpc.txt’, e.g., the file ‘terrain.
tif’ and a matching RPC file named ‘terrain_rpc.txt’. In addition, a RPC file can be
manually associated with the current active image via menu Edit -> Options -> Attach RPC

File.

Shown below is one of the RPC text files that was used in section Stereo Compilation to
produce the various outputs. The actual file is one continuous list, not two columns.

lat_off: 3.45599170374970e+006

lat_scale: 2.596810
long_off: 6.066854

12770393e-004
18582732e+005

long_scale: 2.56109265392068e-004
height_off: 1.50000000000000e+002

height_scale: 3.333

33333333333e-003

line_off: 0.00000000000000e+000
line_scale: 2.60416666666667¢-004
samp_off: 0.00000000000000e+000

samp_scale: 2.6041
line_num_coeff _1:
line_num_coeff 2:
line_num_coeff 3:
line_num_coeff_4:
line_num_coeff_5:
line_num_coeff_6:
line_num_coeff _7:
line_num_coeff_8:
line_num_coeff 9:

line_num_coeff_10:
line_num_coeff 11:
line_num_coeff_12:
line_num_coeff_13:
line_num_coeff_14:
line_num_coeff_15:
line_num_coeff_16:

6666666667e-004
-3.41929000000000e-002
1.98476000000000e+000
3.25206000000000e-002
-6.64100000000000e-003
-1.35979000000000e-001
2.28285000000000e-001
4.19479000000000e-003
7.92820000000000e-002
-2.20915000000000e-003
-7.60500000000000e-004
-3.08305000000000e-002
2.38494000000000e-003
8.21080000000000e-003
2.60906000000000e-002
-1.05586000000000e-002
1.26039000000000e-004

line_num_coeff_17: 4.38989000000000e-004
line_num_coeff_18: 1.79415000000000e-002
line_num_coeff 19: -4.82501000000000e-004
line_num_coeff_20: -3.55988000000000e-005
line_den_coeff 1: 1.0

line_den_coeff 2: 1.87610000000000e-002
line_den_coeff 3: -2.76296000000000e-002
line_den_coeff_4: 1.95251000000000e+000
line_den_coeff 5: 1.05762000000000e-002
line_den_coeff_6: 7.99540000000000e-002
line_den_coeff_7: -2.76620000000000e-003
line_den_coeff_8: 2.24295000000000e-001
line_den_coeff 9: -1.14709000000000e-003
line_den_coeff 10: -1.35064000000000e-001
line_den_coeff _11: 1.21464000000000e-003
line_den_coeff 12: 1.79438000000000e-002
line_den_coeff 13: -3.22646000000000e-005
line_den_coeff 14: -1.05638000000000e-002
line_den_coeff 15: -2.96325000000000e-004

line_den_coeff 16: 2.32113000000000e-003
line_den_coeff 17: 8.35030000000000e-003
line_den_coeff 18: 2.54771000000000e-002
line_den_coeff 19: -2.47739000000000e-004
line_den_coeff 20: -3.06604000000000e-002

samp_num_coeff_1:
samp_num_coeff_2:
samp_num_coeff_3:
samp_num_coeff_4:
samp_num_coeff_5:
samp_num_coeff_6:
samp_num_coeff_7:
samp_num_coeff_8:
samp_num_coeff_9:

samp_num_coeff_10:
samp_num_coeff_11:
samp_num_coeff_12:
samp_num_coeff_13:
samp_num_coeff_14:
samp_num_coeff_15:
samp_num_coeff_16:
samp_num_coeff_17:
samp_num_coeff_18:

samp_num_coeff_19
samp_num_coeff_20

1.10369000000000e-004
2.57084000000000e-004
-4.35454000000000e-004
5.74180000000000e-004
1.53128000000000e-004
-1.08740000000000e-004
1.68296000000000e-004
7.38240000000000e-005
-9.20920000000000e-005
-3.72540000000000e-005
1.85246000000000e-003
-3.19758000000000e-005
-5.15168000000000e-004
-1.55547000000000e-003
2.61763000000000e-004
2.56452000000000e-004
2.69936000000000e-003
-4.41552000000000e-004
: -1.50709000000000e-003
: -1.50616000000000e-003

samp_den_coeff_1: 1.0

samp_den_coeff_2:
samp_den_coeff_3:
samp_den_coeff_4:
samp_den_coeff_5:
samp_den_coeff_6:
samp_den_coeff_7:
samp_den_coeff_8:
samp_den_coeff_9:
samp_den_coeff_10
samp_den_coeff_11

samp_den_coeff_12:
samp_den_coeff_13:
samp_den_coeff_14:
samp_den_coeff_15:
samp_den_coeff_16:
samp_den_coeff_17:
samp_den_coeff_18:

samp_den_coeff_19
samp_den_coeff_20

2.97709000000000e-004
-4.25453000000000e-004
6.71890000000000e-004
1.45216000000000e-004
-1.72159000000000e-004
1.32578000000000e-004
-1.90052000000000e-005
-3.41082000000000e-005

: -8.98320000000000e-005
: 1.85153000000000e-003
-2.63163000000000e-005
-5.19085000000000e-004
-1.54901000000000e-003
2.57449000000000e-004
2.60572000000000e-004
2.69862000000000e-003
-4.31742000000000e-004
: -1.51713000000000e-003
: -1.50164000000000e-003
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Wavelength File

In order to perform analytic operations on a multiband image, it is necessary to know the
wavelength associated with each image band. Similar to the *.hdr file there is an ASCII text
file that specifies this information. The wavelength file has the same name as the multiband
image file but with a .wvl extension (previous versions of HyperCube used wav extension
which are still read correctly if the .wvl extension is not found). For an N band image there
are N rows of values. HyperCube can parse 3 different formats: a row consisting of just the
wavelength, a row consisting of a band number and wavelength and a row consisting of band
number, wavelength, band width and status. Each element in a row is separated by a tab
or space with the row terminated by a return or new line. The file can be generated using a
spreadsheet or word processor and is completely editable in HyperCube. Below is the text
*.wvl file for a 210 band image and the way it appears in the program for editing. See section
Band List for a definitions of the various options.

HyperCube can also extract the wavelengths as well as other image parameters from an
RSI ENVI® header file (see section Header Files).

_6(_')@ drll Bands
| ® 0 6 drilwi SR Width  Status  Enabled: 160, Disabled: 50
e 387.0 40 disabld 4] —————

1 307.00908 4,00808 @ ik AGLH 40  disabled et

2 409.PEEER 4.00600 0 3 43,0 730 “dismbled € Disableall )

3 403.00000 400008 O 4 4070 50 disabled __ Disableall

4 407.00000 5.00E00 O 5 4100 5.0 disabled

S 419.50000 5.08808 B 6* 4130 5.0 v Revert

£ 413.00008 500008 1 7 2170 50 o ———

7 417.00005 500008 1 i 200 50 o (" options... )

5 320 .oaon 5. asong | *, B 0 I

: : e 4270 50 o

18 427.00008 5.00000 1 3 G

11 431 .68000 5.00060 1 W hanl oA o (T — 1

12 435.90008 5.0EAGE 1 = ghad g ::

13 435.00060 5.00008 1 " : [ y

14 442.90008 5.89098 | 14r 4420 50 o il

15 446.00000 5.00a00 1 15+ 4460 50 o e

16 456.06886 5.00088 1 167 450.0 5.0 -+ v | [ Edit=> ) |424.0

17 454.p0000 5.00E00 1

15 452.p0000 5.00E00 1

A A

One of the three possible ASCII * .wvl The HyperCube band list after selecting
files defining wavelengths recognized by menu Windows -> Show Band List while
HyperCube. This format also includes cube image drll is active.

the band widths and status of each band.

If the *.wvl (or the older *.wav) file doesn’t exist for the multiband image then band num-
bers will be substituted for wavelength values and you will get a warning message during the
image loading process directing you to menu Windows -> Show Band List where several
options are available for creating/modifying one. See section Band List for more detail.
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Statistics

Shown below and on the following page are the results of clicking the Stats button when
loading a Raw or Multiband image. Two histograms are generated: a basic data plot that can
be resized and magnified and a remapping plot defining how the data is converted for display.
Also, see section Histograms.

866 dma_dted hist e o0 dma_dted remapping stats
Min: 283 Mode: 1021 Rernap low: 823
2021 Max: 1534 Median: 1096 Rernap high: 1534
Mean: 111555 S0 113211 Percent: 100

1515

1010

505

a

883 1045 1207 1389 1524 253 1534
# Pt 262144, Mean: 111555, 5D: 112212, No exclusions dma_dted Histogram —
Mode: 1021, Median: 1096, Skew: 0651, Kurtosis: 287 e e
y No exclusions
The histogram of an image with 16 The yellow highlight covers the entire area
bit unsigned pixels along with vari- to match the 100% remapping specified in
ous statistics. the load dialog. In this case pixel value

883 will be mapped to zero and value 1534
will be mapped to 255 for display.

The numbers shown for Min, Max, and so on are the values for the pixels in the image
file within the rectangular area chosen by the user for subsequent loading. In this case they
are confined to 16 bit unsigned [0,65535] pixels. In the above example the remapping limits
extend over the full range of the input data because the percent default is at 100. Another
example using hyperspectral data appears on the following page.

The statistics window is important for visualization because based upon its values the
image file pixels are remapped to the 8 bit [0,255] display range. Explicitly, the image file
interval:

[pixel_median - %/2, pixel_median + %/2] is mapped to [0,255].
Values < pixel_median - %/2 are set to zero.
Values > pixel_median + %/2 are set to 255.
If the resulting loaded image appears too bland (washed out) then the auto remapping per-

centage should be made lower using the % edit field. If the image appears too contrasty then
the percentage should be made larger.
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eee FTH21_24 hist

4635073

345804

2Z325I6

116268

o
o 209 e 27 227

# Pis: 65231360, Mean: 182,495, S0: 140,819, No exclusions
Mode : 29, Median: 146, Skew: 0.714, Kurtosis: 2.59

]
The complete histogram and sta-
tistics of a 210 band hyperspectral
image having 16 bit unsigned
pixel values.

e o0 FTH21_24 remapping stats

Min: 0 Maode: 29 Remap low: 16
Mazx: 827 Median: 146 Remap high: 490
Mean: 182 492 S0: 140219 Percent: 95

a 837
FTH21_24 Histogram
coords: (9,1) - (315,1250) of enabled bands within 1-210
Mo exclusions

The yellow highlighting delineates
the 95% area that will be remapped
to [0,255] for display. Pixel values
below 16 will be black and those

above 490 will be white.

Below are display snippets of the example multiband data after being loaded with 3 dif-

ferent auto remapping percentages.

100% Interval 95% Interval

Regardless of how the imagery is remapped for display purposes, all analytic operations
such as plotting, spectral classification and image arithmetic can operate upon the image file
as well as the converted display values. So although saturation and underflow typically oc-
curs when displaying multiband images all of the arithmetic is performed on the full range of

the file data.

If Remap Bands Individually is chosen in the image format dialog then each band
will be correctly gray mapped but at the expense of maintaining their relative brightnesses.
Again, this will not affect any classifications or plotting. If menu Edit -> Options -> De-

tailed Messages is checked on then two scrollable lists will be output showing the individu-
al statistics and remapping coefficients for each band.
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Image Operations

Zoom

Image zooming is selected via menu Image -> Zoom. It is automatically enabled when-
ever the active window is an image window. Each Zoom In magnifies an image by 2 until
it reaches 16 times (or less for very large images) then it is disabled. Each Zoom Out de-
magnifies by 2 until the magnification is unity. The current zoom factor is displayed in each
window’s title bar. Zooming is performed by pixel replication and is a “virtual” image in that
a saved zoomed image is still un-zoomed. To generate a “real” magnified image use Magnify
in the Image menu. Printing or copying a zoomed window does produce a zoomed output.
The keyboard equivalents for Zoom In and Zoom Out are command + and - respectively.

Many image operations can be constrained to a
subset of an image by drawing a selection rectangle
within the image window. This is done by position-
ing the cursor to one corner of the area, pressing the
mouse button and dragging to the opposite corner
and releasing the mouse button. When completed

L the area will be delineated by a rotating marquee at
© 1935 Paramont the boundary as shown here. A single mouse click
(double click in the Windows version) anywhere within the image window or pressing the
delete key or choosing Clear from the Edit menu will deselect the rectangle. The rectangle
may be repositioned by pressing and holding down the mouse while the cursor is within the
selection boundary and dragging to a new position and then releasing the mouse. The cur-
sor changes to a multiple arrow while dragging. Each image window can have at most one
selection rectangle. It’s possible to unintentionally hide a selection if a window is re-sized.
Scrolling a window will bring the selection area back into view.

Copy, Paste & Duplicate

HyperCube allows copying and pasting entire images or selection rectangles between the
Mac clipboard and its own image windows as well as other application’s windows. Only Pict
type data is recognized. This is a standard clipboard data type used by every application. In
order to perform a copy draw a selection rectangle about the image area to be copied, then
choose Copy from the Edit menu or the keyboard equivalent, command C. If there is no
selection rectangle active or the window contains a plot or list or some other non-image then
the entire window is copied to the clipboard. To paste something already in the clipboard,
click anywhere within the destination window to activate it and choose Paste from the Edit
menu or its keyboard equivalent, command V. Paste will not be enabled unless there is Pict
data or color pixel value in the clipboard. The pasted data appears in the center of the view-
able area of the front most image window with a selection rectangle around it. It does not
paste into an existing selection and if there was one it just disappears. If the target image is
too small to hold the paste then the clipboard data is re-sized to fit within the image boundar-
ies. The pasted data can be moved by clicking and holding down the mouse within the selec-
tion rectangle and dragging it to a new position. The cursor changes to a hand during the

HyperCube Pictorial User’s Guide  09/06/12 39



repositioning. A single click anywhere within the image window embeds the paste. Pressing
the delete key or choosing menu Edit->Clear erases the selection without pasting it.

If File -> New... is chosen and there is something in the clipboard to paste then the
default size of the new window will be set equal to the size of the image in the clipboard.
Performing a paste will copy the clipboard to the new window.

A copy of the currently active image window or selection rectangle can be made by
choosing the Edit -> Duplicate menu. This option is available for almost every type of
window. The duplicated image will have the same name as the original followed by the word
“Copy”. Some HyperCube operations, such as constructing a cube, automatically make im-
age duplicates. Also, see section Saving and Copying Scrollable List.

Any time that the cursor is over an image window, regardless if the window is front most,
the current pixel value may be copied to the clipboard by also pressing the option key, e.g.
command+option+C combination (Ctrl+Alt+C in Windows version). This value may subse-
quently be used as the selected color in many HyperCube functions, (see sections Image to
Mask, Adjacency, Selection Point Colors and Class Map Editor).

Gray Mapping

The contrast and brightness of the active gray scale or color image window may be inter-
actively changed by selecting menu Image -> Gray Map. This opens a window containing
controls to modify the pixels in the image and a graphical plot of the current transformation
and resulting histogram. The GrayMap window applies only to the image window that

® O ) CrayMap->I18.tif
® Linear
) Rubberband

e

1.0
—_—
Contrast

-11
E——

Brightness

[__Reset ( Apply )

The effect of modifying the brightness within a selection rectangle.

was active (front most) when Gray Map... was selected. However, every image window

can have its own gray mapping operator. For Linear mapping the Contrast and Brightness
sliders control the slope and y intercept of the graphical plot respectively. The horizontal plot
axis represents the input pixels [0,255] and the vertical axis represents the remapped pixel
values, also in the [0,255] range. Initially, the slope is 1 and the intercept is O signifying that
the input is identically mapped to the output. The contrast range is [-9,9] and the brightness
range is [-56,56]. Negative slopes produce complementary pixels. Above is an example of
gray mapping applied to just a selection rectangle within an image. If there is no selection
rectangle then the entire image is gray mapped. Clicking the Apply button embeds the gray
mapping into the selection area, or the entire image if no selection.
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There is one exception: an 8 bit color indexed image is remapped entirely regardless of any
selection rectangle. If a GrayMap window becomes hidden behind another window you
can bring it to the front by selecting its name from the Windows menu. The original image
and the identity gray mapping can be recovered by clicking the Reset button. A histogram
dynamically displays the entire image’s histogram as a function of the current transformation
starting with the unmapped histogram of the image (also, see section Data Mapping).

Rubberband gray mapping doesn’t use the slider controls. It allows you to position the
cursor within the plot area while holding down the mouse button. The graph then tracks the
cursor and consists of two slopes with the cursor at their break point. Rubberband mapping
is very useful in bringing out shadow detail without completely washing-out the surrounding
area. An example of this is shown below.

& O 7 GrayMap->I18.tif
O Linear —

@ Rubberband

.-—O—.

Contrast

.—O—

Brightness

Rubberband gray mapping being applied to a selection
area. The sliders are not used and are grayed out.
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Color Mapping

You can modify the color balance of an image by selecting menu Image -> Color Map.
It is similar to gray level mapping (Gray Map). Sliders are used to independently modify
the red, green and blue brightness and contrast of an image and its hue (color tint), satura-
tion (purity) and intensity (overall brightness) while showing the effect on the 3 histograms.
Note that subtracting a color is the same as adding its complement and vice versa: adding is
subtracting the complement. The controls and buttons perform the same as gray mapping
with the same exception: Apply modifies an entire 8 bit indexed color image regardless of
any selection rectangle. The Reset button restores the original image and sets the controls to

their null positions.

An image may have only one operator attached to it at a time. Specifically, Color Map,
Gray Map, Data Map, Static and Dynamic filtering, Fourier and the Class Map Editor

are all mutually exclusive

Also, see section Info Window which describes displaying the red, green, blue, hue, satu-
ration and intensity values associated with the cursor position.

Color balance emphasizing green
within a selection rectangle.

Effect of modifying the hue, saturation
and intensity within a selection rectangle.

86806

ColorMap->Tulips.tif

Brightness

Contrast

Saturation I ntensity

| bl
B

[ Reset | | Apply )
8N ColorMap->Tulips.tif

Erightness

Contrast

&
-

&
-

Saturation I ntensity
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Data Mapping

Windows containing images that represent more than 8 bit pixels are automatically
mapped from their full pixel depth (e.g., 16 bit signed and unsigned, 32 bit float and signed
long) to 8 bits for display when they are loaded or created (the underlying data is kept in
memory at full pixel depth, see section Files. Data, Images and Display). Menu item Image
-> Data Mapping... allows you to interactively remap the source data (in memory) to 8 bits.
It does not change the actual underlying data, only the way it is displayed. This menu item is
only enabled for gray scale images. It does apply any pixel exclusion that may have been set
via menu Edit -> Options -> Pixel Exclusion.

If the source image contains a selection rectangle then the remapping is restricted to that
spatial region. A selection rectangle can also be drawn within the Data Histogram area of
the dialog to limit the mapping to a range of pixel values, see examples below.

8eee DataMap->Overview DEM 8eee Overview DEM
Data Histogram Window Histogram
1681.74 1738.99 u] 233

Mo source pisels exeluded
— Remap display using:

@ linear C hist equal C log C exp : sqrt
e o ~ I

() median interval: _|NIA percent

= E e

) mean interval: N/A standard dewv

: Limit data range to Data Histogram selection rectangle

. Reset

Linear remapping using full histogram.

O DataMap->Overview DEM ®O6 Overview DEM

Data Histogram Window Histogram

21.74 173899 o
No source pixels excluded Saturation at 255

— Remap display using:

@ linear C hist equal C log C exp : sqrt
i

e & 3

() median interval: |NIA percent
v

' . 5

_) mean interval: M/A standard dev

a Limit data range to Data Histogram selection rectangle

| Reset

The linear remap applied to an image selection in combination with a selection drawn
over the Data Histogram dialog that further limits the linear remapping to pixel values
within the green shaded histogram area. The red vertical line in the Window Histogram
plot indicates the resulting saturated values (pure white) in the displayed image.
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8eee DataMap->Overview DEM 8eee Overview DEM

Data Histogram Window Histogram

S1.74 173599
Mo source pisels exeluded Saturation at 0,255
— Remap display using:
X m N ™ Y £
. linear ) hist equal ) log ) exp (J sqrt
.
) median interval: 1 |?0 percent
-
5 . r
) mean interval: MNJA standard dewv

: Limit data range to Data Histogram selection rectangle

. Reset

Same image area as the previous examples using median interval. The median of the pixel
values within the image selection is computed and an interval about the median from 35%
below to 35% above it forms the remapping interval. Pixels below the interval are set to zero
and those above the interval are set to 255. This causes saturation at both ends of the dis-
played image and the resulting pair of red lines in the Window Histogram plot.

8eee DataMap->Overview DEM 8eee Overview DEM

Data Histogram Window Histogram
T

-
1
I
1
1
1
1
[

1738.99 233
Mo source pisels exeluded Saturation at 0,255
— Remap display using:
. linear hist equal ) log ) exp (J sqrt
e B i .‘
() median interval: M/A percent
5 . r
) mean interval: MNJA standard dewv

a Limit data range to Data Histogram selection rectangle

. Reset

As above with histogram equalization remapping along with a Data Histogram selection.
This mapping also stretches out the pixel range and produces saturated display values.
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Flips & Rotations

Each loaded image can be flipped and rotated in orientation. As shown below there are 3
kinds of flips and 3 rotations. The Left->Right flip changes the order of the pixels within a
line and the Top -> Bottom flip changes the order of the lines. Band Order is only enabled
for multiband images and re-sequences loaded bands but not their wavelengths. Therefore,
the last band becomes the first band and the first band becomes the last band. Flips and rota-
tions are global operations and ignore any selection rectangles.

Functions Utilities Windows
Convert Image >

Add to Cube..

A N
Attach Data

Zoom In ®+

Zoom Out -

Flip > Left -> Right
Rotate > Top -> Bottom
Shift » Band Order

Flip, Rotate and Shift appear in the Image menu.

The Rotate menu item is similar to Flip. Rotations
may be 90, 180 or an arbitrary number of degrees. 90

Rotate 90 cw

and 180 operate on an entire image (including multi- Shift P 90 cew
band) while General can rotate a selection rectangle as G éig::z
well as the whole image and uses the currently selected | Gray Map...

interpolation method (see section Magnify). Note that
rotating a non-square image results in interchanging the number of pixels and lines. Also,
flips and rotations disassociate the new image geometry from the original image file geom-
etry. Therefore, library matches and classifications of multiband images will be erroneous as
well as spectral plots of their files.

The Reformat Cube File function in the Utilities menu is used to change the internal
structure of the multiband image file itself not just what is loaded in memory. It also regener-
ates the *.hdr and *.wav files as necessary.
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Shifts

The Image -> Shift menu item operates
on whole images and allows both integral and
fractional shifts. All of the integral shifts are
cyclic so that pixels shifted off one end appear
on the opposite end so they are invertible. The
fractional part of a shift is not invertible. It is
done in the frequency domain by applying a

Flip >
Rotate >
Shift 1

Color Mapping...
Gray Mapping...
Data Mapping...

Overwrite

Filter ® | Enter Shift...

linear phase shift to the Fourier transform of the line or column. Therefore, a 1.6 pixel left
shift followed by a 1.6 pixel right shift will not exactly reproduce the original image. Left
and Right shifts can be applied to All lines or just the Even lines. They are useful in cor-
recting interleaving errors in captured video images. Below is an example of such an image
before and after shifting only the even lines. Shifts applied to a cube only affect the currently
displayed band. Overwrite is a toggled flag. If checked (on) then the shift overwrites the
source image or cube band, else the result of the shift generates a new separate image. A

warning is given when overwriting.

Magnified captured video frame before and after Shift Right Even lines.
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Eiltering (Spatial Domain)

HyperCube provides several methods for filter- Static 5x5...
ing an image in both the spatial (pixel) domain Magnify Image | Oynamiicont
and the frequency (Fourier) domain. The later
is described in the Image Functions section. Spatial filtering convolves the image pixels
with various user selected kernels and the software provides two methods: a 5x5 interactive
kernel and a 5x35 static kernel. The interactive filter contains a slider for altering the kernel
elements while the static filter uses edit fields and operates as a one-shot. You can save the
5x3 static coefficients and read saved 5x5 coefficients including those saved by Photoshop™ .

Each type of convolver is an operator to the specific image window that was active when
menu Image -> Filter was selected. Closing the image also closes the filter. If a selection
rectangle is present then the filter is constrained to that area. The filtering does not become
permanent until the Apply button is clicked. However, the original image can still be re-
stored with the Reset button as long as the filter is still active.

Filtering is an image operator and an image may have at most one operator at a time, €.g.
if Gray Map is active on an image then it must be closed before any filtering can be applied
Both the dynamic and static filters respond to Pixel Exclusion when it is specifically set to
exclude zero.

Below is an example using the Static filter. The Blur <--> Sharp slider generates a con-
tinuous low pass Gaussian through high pass Laplacian filter effect as it is moved from the
far left to the far right.

M O 7 5X5->g2.tif

B.688 -8.833 -A.833 -8.033 B.608
-8.833 8.867 -0.133 B8.867 -B.833
-0.833 -A.133 1.888 -8.133 -B.833
-8.833 A.867 -B.133 B.867 -B.833
B.688 -8.633 -A.833 -8.033 0.608

Eernel

Y
wr

Blur <--»Sharp

Reset Apply

The static convolver displaying the
sharpening kernel that was applied to
the right portion of the example im-
age. The left portion is the result of a
previously applied Blur. Each region
was done by using a selection rectangle
followed by the Apply button.

© 1935 Paramont

Blurred area Sharpened area.

HyperCube Pictorial User’s Guide  09/06/12 47



The 5x35 static convolver, shown below, allows 25 separate coefficients. All of the coef-
ficients must be integers. The Scale value is divided into the coefficients and the Offset
value is added to the final resultant pixel. The popup menu contains several predefined
kernels which may be modified. The Preview button shows the effect of the filtering with-
out embedding the result into the image. However, just like the 5x5 dynamic convolver, the
Reset button restores the image and sets the kernel to the identity as long a it’s still ac-
tive. Since there are so many degrees of freedom it’s easy to generate meaningless pixels
and experimentation helps. Any set of coefficients may be saved via the Save... button and
retrieved with the Load... button. The coefficients are compatible with those produced by
Photoshop™ and HyperCube will recognize the later. A newly loaded or saved kernel will
occupy the User menu position. The Sobel XY Gradient operation actually involves two
separate convolutions, an x gradient and a y gradient that are combined. Therefore, when
the combined xy Sobel is selected the kernel elements shown are not representative although
the combined gradient is correctly executed. Also, the Sobel 3 operations produce a finer
result whereas the Sobel 5 operations average over additional pixels. Experiment to find the
desired result.

Scale: 1 Offset: 0

(Load... ) ( Save... ) (" Preview )

Reset ) [Sobel 5Y... ﬁ (Apply )

Identity

User

Laplacian 1

Laplacian 2

Laplacian 3

Gaussian 1

Caussian 2

Gaussian 3

Sobel 5 X Cradient
v Sobel 5 Y Gradient

The image displays the result of apply the Sobel 3 XY Sobel 3 X Gradient
. . . Sobel 3 Y Gradient
Gradient operation upon a selection rectange. Each of the Sobel 3 XY Gradient

red, green, and blue components is done separately and
recombined as a true color image.
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Magnify

A entire image or a selection rect-

Applications Image Functions Utilities Windows

angle subset can be magnified produc- [ ..

ing a new independent image. The — =
magnification range is mostly unlim- Copy #C
. . . Paste EAY
ited as long as the resultant image isat | -

least 32 by 32 in size and there exists Select All A
enough RAM. The type of interpo- Duplicate %D
lation can be replication, bilinear or Send to Back 3B

cubic resampling. Menu Image -> Options
Magnify toggles between Image and
Selection depending on whether or
not a the image has a selection rect-
angle. A submenu, shown below, lists Mag/Rotate Interp > E@ULILERELLE
several magnifications and permits Choy e actnts E‘L‘{,‘ﬁff
entering an arbitrary factor that is

initially set to .75x. Menu, Edit -> Options -> Mag/Rotate Interp determines the type of
interpolation. It is initially set to Replicate. Included below are examples of a 4x magni-
fication using each type of interpolation. Replication is best for viewing the actual pixels
while bilinear and cubic produce photographic like enlargements. Also, see Warp.

Detailed Messages
List Allocation

[0,0] Image Origin
Labels

List Clipboard Contents

A 4x magnification applied to
an image subset utilizing all
three interpolators. The origi-
nal is shown at 2x for clarity.

Replicate
Bilinear
Delete Band...
Disconnect Cube from File... .1)(
Embed Wavelength 2%
Cube Color Composite
Other (.75 .
ikl Cubic
Enter Other...

Function Magnify popup submenu.
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Info Window

HyperCube contains one floating window, Info, that is always available and dynamically
displays information about any of the other HyperCube windows. The kinds of information
depend upon which window the cursor is in. When the program starts, Info is hidden and can
be shown at anytime by selecting menu Windows -> Show Info. To hide it click its close
box. To print it, use the keyboard equivalent command P instead of the mouse so that the
cursor doesn’t move off its current position and change the Info values.

The information displayed include the type of window, and the position and current gray
or color values of the pixel beneath the cursor as well as image reference coordinates in vari-
ous systems. The origin of all windows is [1,1] at the upper left unless [0,0] Image Origin is
selected from menu Edit -> Options. And when placed on a histogram plot the cursor shows
the bin number. Placing the cursor on a contour line (see Applications) displays the contour
value. Various Info window examples appear below.

(&) Info

Plot->drl |

Class i0perator
4{PLOT,d,8,8,bytal
wavelengthi 748 nm
reflectance: B.112
band #: £@

Cursor over a spectral
plot window.

B Info

182_pict

Class:lmage S12x512
{SMGL, 8,8, 8, us}
pizel,line: 288 222
depth: 8 indexi 175
ryg,b: 173 173 175

hys,it a a8 175
O:-AE N
Oata: 175

Cursor over a gray
scale image. Data

value matches pixel
value.

&) Info

Dem32bit.tif {1:5) da...
Clas=s:iProfile
{FROF,8,5,8, bytel

wi pdowm

pixel, line 177 111
image:

pixel, line 281 551
nio467883. 734448
Yio4487228.841494
21 1963 .685225

Cursor over a profile plot
showing the correspond-
ing x,y,z image values for

a point on the profile line.

&) Info
shirley.tif

Clas=s:lmage S12x512
{5MGL, 8,5, 8, bytel
pixel, line: 297 279

depth: 32
ryg,bl 218 177 153
hy=,it 15 41 18z

[]: .

A true color image pixel
with the red, green and
blue color components.

&) Info

Flicker drll. 868

Class: Image 283068
{IFLK,8,8,8,bytal
pixel, linz: 126 489
depth: 2 index! 5}
rygebs 171 171 171

hy=s,i: 5] A 1M
O:-HE N
Data: 3605

Wy offsetsl -2 -3

The cursor is positioned over a
flicker window. Values change
according to the flicker rate.
Image 1 has been offset using
the arrow keys.

8 Info
18883 {1:1S).ntf
Clas=s:ilmage 1838x216
{SMGL, 8,8,V IEL, to16)
pixel, lin=: 612 454
#,y coords! 3E56 2316

depth: 32
ryg,bi 254 255 255
hy=s,it 128 1 233

[1: Ol
Lat: 38 44 3235.02H
38.743318
Lon: 3% 8 322.56H
=77 . 144827
E: 213666.52 Zone:l 18
M: 4298474 .49
Oota: 28674 200282 26486

Over an NITF image with
reference coords.
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Image Conversions

Components to Color

A composite true color image can be
formed by selecting Image -> Convert
Image -> R,G,B to Color or H,S,| to
Color (Hue, Saturation and Intensity to
color). Any three gray scale images can
be used, including bands of a multiband
cube image, HyperCube displays a dialog
window asking you to specify which im-
age represents which of the three colors.
The three components do not have to be
the same size, the true color result will
be their minimum size. If all three im-
ages are bands from the same image cube
the Link to Cube check box is enabled
and if selected the resultant color image
will be logically connected to the parent

Convert Image

Add to Cube...

Zoom In B+
Zoom Out £
Flip >
Rotate »
Shift 1 >

Color Mapping...
Cray Mapping...

Data Mapping...

Filter >

Magnify Selection »

Cube Color Composite >

Functions _ Utilities Windows

R,G,B to Color...
H,S,1 to Color...
ndexed to Color
Complement
Color to R,G,B
Color to H,5,1
Color to Indexed...
Color to Class Map

Replace Color...
Image to Mask...

Cray »
Histogram Equalize P
Principal Components >

Color to Cube...

cube image. This image can then be used to select points for subsequent spectral plotting and
classification (see section Classify). If red, green and blue are all cube bands (not necessar-
ily from the same cube) then Entire Cube may be selected and a synthetic color cube will

be automatically generated in which each band consists of the corresponding components
(bands) from the cubes. The number of bands in this cube will be the minimum of the num-
ber of bands currently loaded from the source cubes.

R,G,B to Color

Select the red, green and blue components. The
resultant size will be the minimum size of the three
images. If all 2colors are from the same cube then
the output may be linked to a cube.

Red: dataga.001 5
Green: | data8a.002 s
Blue: datafa.003 5

b4 Link to Cube
[] Entire Cube
B Permutations

H,5,1 to Color

Select the corresponding hue, saturation and
intensity image components. The resultant size
will be the minimum size of the three images.

Hue:

Intensity:

B4 Permutations

data8a.003 ¥
Saturation: | data8a.007 >

dataB8a.009 >

The left dialog shows the selection of three bands to be composited to form a true color
image. The right dialog similarly forms a true color image treating the components as
if they represented hue, saturation and intensity (also see Applications->Stereo Mates).
Checking Permutations produces 6 color output images.

Image to Various Components

These are inverses of the previous functions. Any true color image window, i.e. those
that show a depth of 24 or 32 in the Info window, can be separated into 3 same size gray
scale images representing the red, green and blue or hue, saturation and intensity, compo-
nents respectively. The original image is not affected. To perform the conversion activate
the color image window and choose Image -> Convert Image -> Color to R,G,B or Color

to H,S,I . Also, see Attach/Remove Data to reduce the color depth of an image.
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Image to Principal Components

Image -> Convert Image -> Principal Components uses the Hotelling transform to
convert a color or cube image into its principal components. Either the covariance or cor-
relation matrix statistics can be used as the basis for the transform (and optionally saved).
If the source is a cube then you will be presented with the following dialog allowing you to
transform either only the enabled bands that are currently loaded into memory or the actual
cube file enabled bands (if a file currently exists). The result of the transformation is an im-
age cube. Selecting “File” produces a file as the output; selecting “Window” generates an
in-memory image cube.

Window vs File Selecting Window transforms only those enabled bands
This window represents a cube image file. Selecting / /
Window uses only the data and enabled bands (20) presen.tly ln‘ memory and produces a Cube In memory.
in memory. Selecting File uses all of the enabled Selecting File transforms the enabled bands of the
bands (172) in the image file. Options allow .
overriding selection rectangle. image cube file and produces a new cube file. The
) Use enabled Window bands (20 bands, 16 bisy | 11€W cube bands are the principal components and are
@ Use enabled File bands (172 bands, 16 bits) ordered in decreasing eigenvalues. The Save... check
¥ Use selection rectangle for output size box writes the various matrices to an ASCII file. See

E Use selection rectangle for statistics

section Apply Transformation for format details. The
two Use selection... options allow ignoring any selec-
tion rectangle.

["] Save eigen and stats matrices (*.ev,*.cov,*.cvi).

(Cancel ) o

0 =————Figenvalues=——HH [0 ==—=—nDpatal

Eigenvaluss

HE

T40652 62

555489.50

27032631

18516212

[Tl e s ) B S PV I R
+

0,00
1 42 83 124 166

Eigenvalues

%

Shown at the top are the first 3 principal components generated from 166 enabled bands of a
210 band image. The plot and listing of the eigenvalues are also output as well as an image
representation of the eigenvectors. The later may be examined via a line profile plot, histo-
gram or using the cursor with the Info window (see section Apply Transformation for format
details).
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Indexed to Color

An indexed, or pseudo, image is an 8 bit image similar to gray scale but one in which
the pixel value is an index into a color table. Therefore it has at most 256 distinct colors. A
gray scale image is a special case of an indexed image in that its color table has the same
red, green and blue intensity for each of its indices and is the actual pixel value (HyperCube
checks all indexed images to see if they are actually gray because this greatly simplifies a lot
of arithmetic). If the currently active window contains an indexed image then you can select
Image -> Convert Image -> Indexed to Color. This will generate a new true color image.
If the original image was gray then the new image will also be gray with equal red, green and
blue components at each pixel. Note that on the Macintosh a full true color image is 32 bits
in depth, not 24 as might be expected. The extra byte is for special effects. HyperCube also
handles the Macintosh 16 bit (thousands) color image: three 5 bit color components plus a
special effect bit.

Special note, Mac OS X only: Eight bit pseudo color Pict images are converted to true
color when loaded. This does not apply to Pict 8 bit gray images or any other file types.

Color to Indexed

This is the most difficult type of color image conversion because there is no one to one
transformation. A typical 512 by 512 true color image could have over a quarter million
colors which must be reduced to only 256 colors. HyperCube tries to find the best 256 but
sometimes the results are not acceptable. Normally, true color to index should only be used
when the source image has very few distinct colors or to save storage as in making a true
color image fit on a floppy disk. Its necessity has become less valid with JPEG compression
(see section JPEG Files). You can select the Image -> Convert Image -> Color to In-
dexed menu when the front most window contains a true color image.

Gray Scale/Color Tables

The active color image window can be converted to a new 8 or 16 bit gray scale image
by selecting the Image -> Convert Image -> Gray -> Equal/NTSC submenus. The three
color components are combined together with either equal or NTSC (National Television
Standards Committee) weights to form a new image defined by:

gray equal .33*red + .33*green + .33*blue
gray NTSC = .30*red + .59*green + .l1l*blue

Menu Functions -> Arithmetic can be used with arbitrary weighting.
Menu Image -> Convert -> Color Table shows several col-
or mappings that may be applied to an 8 bit indexed image. The
top one overwrites the image’s color table with a linear gray ramp
forcing an indexed color image into some gray appearing image.
The second strip complements the existing table so that selecting
it twice restores the original table. The remaining 3 menu op-
tions overwrite the existing color table and color code the image
pixels so that pixel (index) zero represents the left most color
and pixel 255 the right most color. Also see the Classify section
describing output products.

New Cube Link...

Color Table »
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Replace Color

Any specific color or gray value within an image may be substituted with another value.
The result is a same sized image with only that modification. If the image is a cube then a
copy of the band face is used as the source. Choosing Image -> Convert Image -> Re-
place Color... brings up the following dialog with the last two colors or gray values, if any,
that have been first selected by the command+option+C key combination or Ctrl+Alt+C in
Windows version (also see section Copy, Paste & Duplicate). The first selected value will
be Color 1, the color to search for, and the second as Color 2, the replacement color.

If Replace all gray... is checked then Color 1 is ignored and every gray value (non-
color) is replaced with Color 2. This is useful for converting a color overlay to a mask.

The Limit replacement to selection rectangle is an available option when the source
image has a selection rectangle. If checked then changes are confined to the rectangle.
Overwrite source modifies the source image, it does not generate a new output.

Replace Color

The Replace Color dialog was used twice to convert

Enter two colors. The second color will replace

every occurrence of the first color within a new the image at below left, a classiﬁcation mask, to the

Ef,zt,alélé},;”;pi:ti'g':;?:‘; ;f,;":f;i‘;ec‘i;:‘}’,,';,,‘23.‘;‘;‘*' image at its right. The dialog shows the first conver-

Nekp i fpnlprp waith Duige sion, red to yellow. A second conversion using the
Color 1 (rg,b): 255 | 0 0 output from the first replaced the black background
Color 2 (rg.b): 255 [{255 _}[0 with gray [128,128,128]. The intermediate yellow
JReplaze 2l gray valics with Color 2 and black image is not shown. Replace all gray... can

Limit replacement to selection rectangle

be used to convert a color overlay to a color mask.
See section Image Products.

["] Overwrite source (no output)

oK

YAl 012

Original spectral classification After two successive uses of
mask as output from Classify. Replace Color.
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Image to Mask

An image can be converted to another image that corresponds to a specific gray level or
color within the image. Two types of output are possible. The first (Binary) produces a same
size image (mask) that consists of white (255) everywhere that specific color (gray level)
appeared in the source image and black (0) everywhere else. The second type (Color sepa-
ration) consists of the chosen color in place of white and black everywhere else, i.e. only the
color selection itself remains. This is most useful where the source image does not contain
numerous colors (gray levels) such as when separating a specific classification color from
a color composite produced with the Classify function. The initial color (gray level) to be
extracted is automatically preset to the last comnand-option C key combination used to copy
a pixel color to the clipboard (see section Copy, Paste & Duplicate).

When an image is frontmost, choose Image -> Convert Image -> Image to Mask.
This will bring up the following dialog window:

Color Mask

Enter the red, green and blue
color components [0,255] of the
mask to be extracted.

Red: (241
167
Blue: 183
Mask Type:
@ Binary

() Color separation

el R

The respective red, green and blue components of
the color to be extracted in generating the mask
images in the examples below. Mask Type Binary
produces white wherever the rgb pixel value is
[241,167,185] while Color Separation outputs the
actual pixel value. If the image to be converted
is a gray level image then the dialog will instead
solicit a single gray level with the same options.

A source true color image that was derived from a
spectral classification. The cursor was positioned
over a road and the command-option-C key combina-
tion pressed to store the pixel color into the clipboard
prior to choosing Image->Convert->Image to Mask...
from the menu.

Binary Mask Type consisting only of Color separation Mask Type consist-

black (0) and white (255) values.

ing of black and the extracted color.
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Histogram Equalization

Three functions within menu Image -> Convert Image -> Histogram Equalize are
used to perform histogram equalizations of an image. In each case a new image is generated

leaving the source image intact. Any gray or true
color image may be the source. Each function
attempts to construct an image whose histogram

Histogram Equalize
Principal Components
Color to Cube...

>
>

Uniform
Uniform (ea. color)
Match Image...

matches a particular distribution. Generally, this can not be done exactly. For example, a
non-uniform 256 bin histogram (8 bit gray or a color component) can’t be mapped to a uni-
form 256 bin histogram, there will be “holes”. The methods used by the three techniques are
as follows: Uniform attempts to remap the pixel values to produce an equal number of pixels
in each of the histogram bins. If the source image is 8 bits/color then the red, green and blue
pixels are treated as a truncated 18 bit pixel (the low order 2 bits of each color is ignored)
whose histogram is used to remap the 24 bits uniformly. The second method, Uniform (ea.
color), performs the uniform equalization independently on each color (8 bit red, green and
blue components) and then combines the results. The last method, Match Image..., is
described on the following page. Note, if the source image has a selection rectangle then

the equalization is based only on the selection rectangle statistics but is applied to the entire

output image.

Shown below are examples using the first two methods.

866

Tulips

v
Original true color image.

Resulting image after
Uniform histogram.

Left and right are the
original and histogram
equalized image along with
their corresponding 8 bit
histograms. Note that the
resulting histogram cannot
be made uniform.

WDC gray hist

® @ @ Tulips Hist Equal ea.
T e

A
Result after Uniform
(ea. color).

WDC Hist eq

e g

EZ

126
#* Pts: 56295, Mean: 152,155, 5D: 27.0561 , Mo exclusions
Mode: 157, Median: 152, Skew: 0.0362, Kurtosis: 3.52

189 235

A

(alala) WDC Hist eq gray hist

1671 T
1251
834
417
0
a 63 126 129 255

# Pts: 56296, Mean: 124.058, SD: 55.0325, No exclusions
Mode : 135, Median: 123, Skew : 0.0538, Kurtosiz: 2 .64

A
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The third method, Histogram Equalize -> Match Image, uses the histogram of a
second image as the target histogram distribution, i.e., each color component of the source
image is remapped so that its histogram matches the corresponding component histogram of
the Match Image in the selected Color domain.

866

red table

233

&3

126
red table

189

235

A

Shown at the right is the

corresponding Dialog. The
current active (front most)

image is the Remap im-
age to be equalized. Both
the Color domain and the
components to remap are
selectable.

Select Histogram Match

The red remapping table generated
in Christmas Cactus -> Mantis with
Plot transform checked.

Above and to the right are two original
images. Each image has been alternately
histogram matched to the other in the RGB
Color domain with the resulting images
shown below.

(el Mantis -> Christmas Cactus

Remap image:
'"Mantis.tif"
To match histogram of image:

Match: | Christmas Cactus l'ﬂ
Color domain:
%) RCB () HSI
E Red EHUE
@ Green ESaturation

EBIUE glntensit‘.«r
@ Plot transform
| Cancel )

ok

Christmas Cactus

4
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Cube Color | inked Image
The current, if any, linked color composite image can be switched to another existing
color image as long as it is the same spatial size by selecting Image -> Convert Image ->
New Cube Link. The following dialog then appears listing candidate images. Any previous
link will be disconnected and any current selection points will be transferred to the new link.

Cet New Cube Link

Select an image from the list to be the new
(or replacement) image cube color link.
The list contains only those color images
having the same size as the cube window.

New link:

("Cancel

Color to Classmap

A true color image can be transformed into a classmap in which the first 1024 colors
(gray shades are excluded) are assigned classes 1 thru 1024 by selecting menu Image ->
Convert Image -> Color to Classmap. The classmap can then be modified using all of
the features in menu Utilities -> Classmap Editor (see section Class Map Editor) If the
source image is pseudo color you will be prompted to first convert it to a true color image. In
this case, there will be at most 256 classes. Since a typical color image usually contains far
more than 1024 colors this conversion is most useful after masking and/or image arithmetic
functions to reduce the number of colors.

Attach/BRemove Data

Two disparate types of images can be combined.
For example: a classmap (color coded features) and
a matching elevation image (data values). This is
accomplished by selecting the data image window to
make it active and then choosing menu Image -> At-
tach -> Data . This brings up a dialog listing all of the candidate images (same spatial size).
After data has been attached to an image the Info window will show the image color/gray
values and the corresponding data value as the cursor is moved over the image (see section
Info Window). When saving a merged image you are presented with a dialog stating that the
source image has attached data and asking you if you want the data saved as well. If your
answer is affirmative then the data is saved separately in Raw format (see section Raw) so
that it and the source image can be reloaded and merged together again.

An image, including an entire cube, can be stripped of attached data by menu Image ->
Attach -> Remove Data. This method can also be used to convert a 16 bits/color image to
an 8 bits/color image (i.e., 48 bit color to 24 bit color)

Functions Utilities Windows

Convert Image >

Attach » Data...

Zoom In ®+ Remove Data...

Auach Daip . Window image '10008 (1:5).tif will be
Image: 'FTH5_8 750 nm' data will be copied to the The AttaCh Data dla' A converted in place to an 8 bits/color
selected image or cube. Only images with the same lOg is S]’lOWl’l to the image. Any 16 or 32 bit attached

spatial size are listed. data in memory will be discarded.
left and the Remove

Data warning to the
(Cancel) }"ight. [ Cancel ) ( Convert )

Images: ' FTH5_8.060s Ovly VA 0.08 I
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Image Functions

Statistical Measures

Functions -> Statistics contains two methods
for computing the linear correlation between 2 or
more gray scale images. The first of these, Pair
Correlations..., allows you to select any two non-
color images from popup menus and then calculates
their correlation or covariance as a function of pixel
and line offsets. The results are listed in a 7 by 7
matrix showing the computed values for each given offset. The Options... button permits
changing the initial offset between the 2 images and the pixel and line shifts per iteration. If
image 1 has a selection rectangle then the computation can be confined to the selection by
checking the Use Image 1 Selection Box. The check box will only be enabled if there is a

selection rectangle on image 1.

Utilities  Windows
Flicker Cube
Flicker/Superimpose...

Pair Correlations...
Band Correlations...

Pairs Correlations can be used to determine how good the

registration is between various bands of a multiband image (use menu Image -> Convert ->
Color ->R,G,B to separate color components followed by Pairs Correlations). The Image
Shift checkbox is used to compute where the maximum correlation occurs and via interpo-
lation, what the fractional shift is. Each computation is generated by selecting the Update

The linear cross_correlation between
two bands of a multiband data set
using the default values for offset and
delta is shown at the right. The corre-
sponding_covariance between the two
bands is shown below it.

Image Shift

Images !
B33 _=oilpanels: band 1
B33 _=oilpanels: band 128

Second image relative to firstd
Fixel shift: -8.772087 {left)
Line shift: B8.83037682 {(down}

The computed pixel shift (shown above)
between the images after checking Im-
age Shift. This is in accordance with
the position of where the maximum
correlation value appears (i.e., between

e 0 Pair Correlations
Image 1: 053_soilpanels.001 I:] @Corr ! Image 1 Selection
Image 2: 053_soilpanels.128 | ;] — Cov List Shift [} Cube
Pixel Offset
=< =2 -1 +0 +1 +2 +Z
= 0z |19.6137 +0.6415 +A.6742 +B.7125 +B.7279 +B.7061 +0.6754
i : -2 | +8.6368 +8.6716 +8.7149 +8.7783 +0.7939 +8.7611 +8.7198
nog -1 | +B.6683 +8.7832 +0.7661 +0.0546 +0.5870 +8.8233 +0.7545
e 0 +8.6782  +B.7279 +B.8054 4+B.9233 +B.9649 40,5573 +B.7714
£+t +8.6739  +B.7168 +B8.7789 +B.85877 +0.5784 +B.5034 +8.7364
+2 [ +8.6513 +0.6813 +8.7232 +0.7702 +B.7785 +8.7343 +0.6918
+3 [ +8.6176 +0.6489 +0.6699 +A.7A52 +08.7117 +8.6529 +0.6524
—\ Crozs Correlation —
_ Options... . Update
e o0 Pair Correlations
Image 1: 053_soilpanels.001 I:] : Caorr | Image 1 Selection
Image 2: 053_soilpanels.128 | :] ® cov L ListShift | Cube
Fixel Offset
=2 —2 -1 +0 +1 +2 +Z
= 0 3 +285 +296 +389 +325 +3368 +3158 +384
i : -2 +295 +312 +329 +383 +362 +345 +324
Fiog -1 +311 +329 +355 +394 +487 +375 +344
e, 0 +322 +343 +376 +429 +445 +393 +362
 H +322 +348 +367 +461 +465 +371 +338
+2 +313 +325 +342 +362 +364 +341 +328
+3 +295 +387 +319 +332 +334 +319 +383

Covariance

'_{Dprions._. \ . Update

0 and +1 pixel offset to compensate for

the negative Shl:ft Value), Pairs Correlation Options

The options dialog window specifies the Piekaitves—{o | —Prekdeita— !

e . . Line offset: 0 Line delta: 1

initial pixel and line offset as well as

their respective steps for each iteration. s o
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If the Image 1 popup menu displays a band from a cube image then you can generate all
of the relative shifts between that band and every band within the same cube. This is done by
selecting the List Shift and Cube checkboxes which will ignore the Image 2 popup menu.
Shown below is the Dialog and the 3 resulting outputs after the Update button is pressed.

8o

Pair Correlations

Image 1:

053_scilpanels.001

.:] @ corr

Image 2:

Ta Cov

Pixel Offset

= +0 +1

M Listshife ™ cube

+2

R

+2.6137
+A.6363
+ . 6EAG
+8.6752
+A.6739
+A.6513
+2.6176

f = R
4D O

+A.
+8.

+2.6742
+2.7149
+2. 7861
+A. G854
+8.7759
+2.7232
+A.6699

+A.7128
+8.7783
+0.8546
+0.9255
+A.5RT7
+8. 7782
+8. 7832

+2.7279
+2.7939
+2.5576
+8.9649
+A. 5754
+2.7786
+2.7117

+8.
+A.
+8.
+8.

+A.
+8.

+8.
+A.
+8.
+8.

L6233

a6
7611

+2.6754
+2.7198
+2. 7585
+8.7714
+2.7364
+A.65918
+A.6524

873
da34
7343
6529

{ Options... ?

Cross Correlation

f Update b

A band from an image cube is selected in Image 1 along with
List Shift and Cube to produce the outputs shown below.

eese Pixel Shifts
0.00
=013
-0z
-0.58
-0.77
1 3z 63 9 128
053 _=zoilpanels: Band 1 ws Cube
A

The relative pixel (horizontal) shift

between band 1 and each band.

eee Line Shifts
0127
0.095
0.0s2
0.030
-0.002
1 3z 53 ad 128
05Z_soilpanels: Band 1 vz Cube
A

The relative line (vertical) shift
between band 1 and each band.

eoce

Band Shifts

852 _=oilpanels: Band 1 ws Cube
Pixel offset Line of fset
{negatives are left and up}

1 0.863232 -0.601917
2 -8.682027  B9.6807645
3 -6 .62964 8.61581
4 —8.6283 @.61891
a3 -8.83821 B.82783
[} -B8.83736 a.81224
T, -8.84973 8825360
g —8.83661 B.83044
9 86874332 @.85315
18 —8.82271 B.862600
1 —8.00844 B.B6631
12 —8.89756 a8.67132
13 -8.1662 887532
14 -8.1819 B.87365
15 —8.185 887711
16 -B. 1867 B.87565
17 -8, 1891 B.87314
15 -8.1183 B.87393
19 -8.1179 B.87992
28 —8.126 B .89874
21 -8.1215 a.6277
22 -8.1322 8.89614
23 —8.1434 @.89404
24 -8.1477 8.89403
25 -8.1529 G.89401

A partial list of each band.’s
offset relative to band 1.
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The second type of correlation in HyperCube, Window vs File

i - icti o i : This window represents a cube image file.
Functions -> Statistics -> Band Correlations, is Sl Wt e et i et and tands
restricted to multiband images. It calculates various (10) in the window. Selecting File uses all of the

. . . . ) . bands (210) in the image file. Option allows
combinations of linear correlation coefficient, covari- overriding selection rectangle.

ance, variance, mean and histogram. The dialog at the | O use window (10 bands, 16 bits)

right gives you the choice of using either the window B U BT bac e Sinds o R
image data already in memory or the file image data
(if a file currently exists). The result is shown graphi- e e e ol
cally with a scrollable list window. Clicking on an i ol
item in the scrolled list highlights it on the graph. The
radio buttons determine the type of comparison and the
statistics. Sequential correlates each band with the next band, i.e. band 1 to band 2, band 2
to band 3 and so on. Specific allows you to select any band from the Band popup menu and
compare it with all of the others. Shown here are the results of correlation applied to a 210
band image. The vertical marker in each graph corresponds to the highlighted values in the
lists. The list values may be saved as text by choosing File Menu -> Save when the dialog
window is front most or copied, (Edit -> Copy), to the clipboard and subsequently pasted as
columnar data into a spreadsheet application such as Excel™ . The correlation and covari-
ance matrices may be saved to a file in ASCII format which can subsequently be opened in

Excel™ (see Apply Transformation for details).

__ Use selection rectangle for output size
@ Use selection rectangle for statistics

[SNaNa] drll Stats 8O6 drll Stats
@ Band : band+1 @ Cor () Cov () Mean,Min,Max () Band :band+1 @) Cor () Cow Mean,Min,Max
C Band : bands C Var : Hist: Mean,Mode Median 8 Band : bands ) War 3 Hist: Mean,Mode,Median
= [1:z 0840968 |4 26 0.954946 A
Band:  dril.ool . 2:3 0.921056 Band: | dril.031 3] 27 0.995439 -
34 0.82%361 m 28 0.996580
Pair Correlations 4:5 0.943108 Band 31 Correlations 29 0.995879
+0.9997 = 5:6 0.852493 +1.0000 30 0997542
6:7 0.363271 (— 31 1.000000
e ;g gg?;gg; = 32 0.997580
%10 0.875376 v 33 gg?jﬁ?g .
-02156 o i -0.3006 - 1
] Bands 209:210 | i Bands 210
#7) //"
The sequential band to band correlation Same multiband data with band 31
plot showing the absence of correlation compared with all of the bands within the
within the water absorption portion of the cube including itself. Clicking a list item
spectrum. Generated from file data. highlights its position within the graph.

If 32 or more bands are used then both the covariance and correlation matrices generated
in the statistics are converted into (savable) images that can be further analyzed by perform-
ing profile plots, histograms and examining values via the cursor and Info window.

O

=
[

Correlation

Covariance

B8| The matching Covariance and Cor- O
2 relation images corresponding to the
statistics plots shown above. The im-
age size is the number of bands and
pixels represent floating point data,
large values for Covariance and -1 to
+1 values for Correlation.

4 P |z
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806 drll Stats

® Band : band+1 () Cor () Cov (®) Mean Min,Max

S Band : bands C Var S Hist: Mean,Mode, Median
— 26 139.0883 10 316 I
Band:  dril.031 = 27 141.5551 12 3}]7 -
28 1440133 12 319
Band Means 29 1463289 12 319
ST - 30 1493431 15 321 m

31 151.%473 13 326
32 1562366 13 328
33 1614815 16 330
34 165.1414 16 332
35 168.6360 17 333
36 173.09%3 15 338
mean 37 1780726 16 338
38 183.0386 17 338
39 1887914 16 347

40 1956474 11 385

41 202.2706 20 392

42 207.53974 17 415 -
" 43 2126724 17 434 )

1 Bands 210

+33.1941

A

The plot above displays the mean pixel value for each of 210 bands.
The list shows the mean, minimum and maximum value for each
band. Band 31 is selected in the list and the corresponding position
within the plot is indicated by the blue vertical line

®O6 drll Stats
® Band : band+1 () Cor () Cov () Mean Min,Max
S Band : bands C Var @ Hist: Mean,Mode, Median

_ 26 130.0883 137.8608 142.8040 i
Band:  dri.o31 . 27 141.5551 144.8067 144.9067 -
28 1440133 143.8785 147.8779
Band 31 Histagram 29 1463289 146.9780 149.9775
1633 30 148.3431 151.8301 132.9766 m

31 1519473 149.8515 155.967B
32 156.2366 155.9580 159.9580
33 1614815 160.9585 164.9468
34 165.1414 185.8954 168.9829
35 168B.6360 168.8023 1729160
36 173.0999 172.8487 176.B945
counts 37 178.0726 176.9213 181.9550
38 1B3.0986 181.3632 186.9873
39 1B8.7914 187.8871 182.B999
40 1956474 194.8310 199.8467
41 202.2706 Z00.8207 206.99895
42 207.5974 207.9311 211.B1597 -
43 2126724 214.8051 216.B422 v

The pixel histogram for any of the 210 bands is displayed by select-
ing that option (Hist...) within the radio buttons and clicking on a
list item which shows the mean, mode and median for that band.
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Histograms

A histogram of the distribution
of the pixel values for any single or Flicker Cube

multiband image can be generated
for the front window by select-
ing menu Functions -> Plots ->
Histogram -> Data, Window or
Masked. The later is described

Imm Utilities Windows

Flicker/Superimpose...

Statistics

Arithmetic...

Musrlavw Calae

Histogram Data (16 bits)
Spectra (Selected Points) Window (gray)
Spectra {(Dynamic)

Masked...

on the following page. If a selection rectangle is present the histogram is confined to those
pixels within the rectangle. If the band list for a multiband image has any bands disabled
then those bands are ignored in computing the histogram. If the window is a cube then you
will be presented with the dialog shown below allowing you to choose either a specific band
in memory or the file data. Also, see section Pixel Exclusion which describes excluding

certain pixel values.

A true color image produces three separate histograms:, one for each of the three color
components: red, green and blue. If the window is a color map overlay then the output is a
list of the frequency count of the classes (see section Image Products).

Data generates the histogram of the underlying data and Window show the histogram of
the remapped display gray values. The menu changes automatically depending upon the im-
age content (e.g., pixel depth). To view a text summary with a cumulative distribution plot of
the statistics, toggle Detailed Messages in menu Edit -> Options before histogramming.

Band vs File

This window represents a cube image file.
Selecting Band uses only the data in the currently
displayed band (60). Selecting File uses all of the
enabled bands (160) in the image file. Option
allows overriding selection rectangle.

@ Use Band: 60 (16 bits)
() Use enabled File bands (160 bands, 16 bits)

| Use selection rectangle for output size
E Use selection rectangle for statistics

( Cancel ) ¢ Okay )

Cube source selection dialog.

eoe dril data hist

228254

171189

114126

ST06S

a

u] 250 500 730 1000

# Ptz: 47308800, Mean: 256 553, 50 93.4809, Mo exclusions
Mode: 294 987, Median: 268.986, Skew: -0.148, Kurtasiz: 2.78

The total file histogram of all
160 enabled bands.

®O6 drll band 60 data hist

® © © drll data hist stats

8O6 drll band 60 gray hist

2339

1902

1268

&34

o
a 230 S00 T30 1000

# Ptz 295650, Mean: 272 683, S0 61 8054, No exclusions
Mode : 237, Median: 275, Skew: -0.101, Kurtosis: 7.11

P

The underlying Data histogram
of just band 60 with a cumulative
distribution overlay.

Source! drll data hist

Somples: 47383324

Minz a
Max 2 1868
Mean: 256 .56

Mode: 295
Hedian: 269

Std Dev: 93.4280
Variance: 2738.68
Skewness: -B.1433
IKur"tosis: 2.770

A

This summary window
is displayed if Edit
-> Options -> Detailed

Messages is toggled on.

10485
TEET
5242
2621

u}
o 63 126 189 233

# Pts: 295680, Mean: 136,855, S0 59,8006, No exclusions
Mode: O, Median: 139, Skew: -0.334, Kurtosis: 2.79

A

The display remapped gray shade
histogram of band 60 also show-
ing a cumulative distribution.
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Menu Functions -> Plots -> Histogram -> Masked also generates a histogram but uses
an intermediary image mask that defines the region(s) of pixels to include. The mask image
must be the same spatial size as the target image, i.e., same number of pixels and lines, depth
doesn’t matter. Class map masks generate a histogram for each class.

Histogram Masked Region

Define the masked image area(s) to be used
to generate the histogram. If Classmap is
chosen then a histogram will be output for Choose a spatially matching class map

each class region. image containing one or more regions to be
used in computing multiple histograms.

Select Histogram Mask

) Two states: zero(0) and non-zero(1)
() Two states: gray(0) and color(1)
® Class map: not class(0) and class

( Select Image Mask..” Image mask: | A 4 class map @
(_Cancel ] ok (Cancel ) oK
A dialog allowing the choice between The resulting mask selection dialog for
3 types of mask images. choice number 3 shown at left.
806 A 4 class map & O © dril class 1 data hist masked

.. M 156841 T
117630
Te4z20
9210
a
22 179 e 493 E5Z

# Ptz: 26899040, Mean: 283.047, 50 : 86.9804, Mo exclusions
Mode: 316.996, Median: 298,991, Skew : -0.401 , Kurtosis: 2.4

Image cube class 1 statistics.

B © 6 drli class 2 data hist masked

4542

ks 3405
A4
| 2270
A four class overlay mask (partially shown) 1138
generated by a vector angle classification and a
d h hi . £ 256 476 696 a1s
used to generate t. efour Istograms (See section * Pi=: 668160, Mean: 194,537, S0: 71,7112, No exclusions
ClaSSlfj[fOV a description ofoverlays and S€Cti07l Mode : 239,99, Median: 203,988, Skew: -0.0453, Kurtosis: 2.65
Specific Algorithms for creating masks). Image cube class 2 statistics.
B O © drilclass 3 data hist masked & O © dril class 4 data hist masked
1312 74548
954 55911
656 #7274
328 18637
o o
21 166 TR 456 &01 28 206 204 552 742
# Ptz 217760, Mean: 165402, 5D 75.2466, Mo exclusions # Ptz 9804960, Mean: 239 836, 50 : TO.6T18, No exclusions
Mode: 107.998, Median: 153,992, Skew : 067, Kurtosis: .06 Muode: 259.997, Median: 258,994, Skew: -0.411 , Kurtosis: 2.52

Image cube class 3 statistics. Image cube class 4 statistics.
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Pixel Exclusion

For display purposes and to yield better histo-
gram plots you can select a value or range of values R .
to be ignored (excluded from computation) when i
generating certain statistics. This option permits E;::w :é
image pixels to be better mapped for display or to Paste 8V
see details in a histogram that would be overshad- ;‘;Te‘crt v
owed by a too populous bin (e.g. a lot of zeros). All
dialogs that contain a Remap checkbox obey the
current global Pixel Exclusion definitions. Menu
Applications -> Shaded Relief and Contour both
contain a local option for convenience to specifically
exclude zero which temporarily overrides global
settings (see section Applications). Menu Image
-> Filter (3x3 and 5x5) responds only to global pixel
exclusion equal to zero. Excluded values do not af-
fect analytical operations such as Principal Compo-
nents, Classifications and Image Arithmetic, only
what is displayed.

The following dialog is presented by selecting menu Edit -> Options -> Pixel Exclu-
sion. Enabled exclusions are global, i.c., they are in effect until they are disabled.

Utilities

Duplicate #®D

Send to Back

Options

Detailed Messages
List Allocation
[0,0] Image Origin
Labels >

Mag/Rotate Interp >
Color Selector...

List Clipboard Contents
Pixel Exclusion...

Pixel Exclusion

Data values may be statistically excluded

The dialog shown at right will cause all negative pixels £ rclice butti imaas haulavs or

to be excluded when generating Histograms and deter- Lepbl sl ol D
mining the display remapping necessary when loading e el
an image cube. This will also apply to the initial slope Exclude:

estimates in menu Applications -> Shaded Relief and O None

to all dialogs containing a Remap checkbox. It has no O values: (< 1 |

. . e OR - o to: [0
effect on menu Functions -> Statistics. g o

* Exclude range values
_ Include range values

[ Cancel ) @
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Scatter Plot

Choosing Scatter... from the Functions -> Plot submenu brings up the image selection
dialog window shown below. After selecting two 8 bit images, which may differ in size, a
two dimensional scatter plot is generated with the origin, point [0,0], at the lower left. A plot
point is derived by using image one’s 8 bit pixel value as the y coordinate and image two’s
pixel value as the x coordinate as the images are scanned in unison. Therefore the output
image will always be 256 by 256 and mostly black. Each time there is a multiple hit, i.e.
the inputs generate an x,y already plotted, the color (or gray value) for that point is modified
from blue (black) towards red (white). If both selections are the same image then the output
image consists of a 45 degree broken line of colored dots from the lower left to the upper
right. After the output image is generated you may select other color tables from the menu
string Image -> Convert Image -> Color Table to view different encoding schemes.

By selecting the scatter plot and moving the cursor over it the corresponding pixels in the
two input images will be overlaid with red dots. To force their gray scale restoration choose
the first color table (linear ramp) as described in the previous paragraph.

Select Scatter Plot Images
The lnltlal COdil’lg Select two images to generate the scatter
diagram. Image 1 pixels are the vertical position All currently open 8
method iS determined by and image 2 pixels are the horizontal. . .
o bit gray windows, re-
these check boxes and ~——Fot O Gray .
. @ Color gardless of size, are
can be later modlﬁed [] Also save as a 256 by 256 Contingency Tahle . .
. . _ : = listed in the popup
by choosing a different window 1: |Tulips Red s
menus.
color table. Window 2: (Tulips Green | 3]
=

—| Points in this region
correspond to picture
elements where red is
the dominant color.

The diagonal band
maps to values of
similar intensity in
the two images.

Red Tulips component.

WL The red and green component images of a true color

image were used to generate this scatter plot image.
The red image pixels are the vertical coordinate and
the green pixels the horizontal coordinate. The red
tulip flower tops form the cluster in the upper left. As
the cursor is moved over the plot the inverse trans-
Jormation shows which pixels in the source images
contributed to this point.

Green Tulips component.
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Line Profile Plot

A linear plot of image values can be generat- | Histogram >
. . . : . Spectra (Selected Points)
ed by ﬁrst drawing a line a.lnd then splegtlng menu | Arithmetic... Spectss OVRAMIO
Function -> Plot -> Profile. The line is speci- g:}‘;.';‘ﬂ;;""’f--- Scatter...

fied by positioning the cursor on one endpoint,
depressing the control key (previous versions
used the shift key) and clicking and dragging the mouse to the other endpoint. Upon releas-
ing the mouse a marque-like line will remain. Repeat the procedure to select a different line.
Control-click (control-double-click in the Windows version) the mouse without moving it to
clear the line or choose menu Edit -> Clear.

If an image is color, including pseudo color, then three separate profile plots will be gen-
erated for the red, green and blue components respectively. Plots are resizeable and include
the coordinates of the endpoints and the image scale in meters per pixel if the image is geo
referenced. Overviews show properly scaled coordinates. Vertical coordinates are expressed
as either gray values ([0,255]) or in data values ranging from the minimum to the maximum
data within the profile line (see section Plot Scaling/Selection).

The profile window is an independent window that can be printed or copied to the clip-
board, and saved. To save a profile as an image activate its window and select menu Edit
-> Duplicate. Then save the duplicate as a normal image. The actual profile values can be
saved as a text file via menu File -> Save. The file will consist of 1024 X,y,z triplets regard-
less of the length of the profile line. The X,Y,z triplets are also copied to the_clipboard when
performing Edit -> Copy. Moving the cursor over a profile plot line will display the corre-
sponding image X,y,z values in the Info window if it’s enabled (see section Info Window).

- N O bil band 60 data_profile
; bil band 60 data

Band 60 of 210: 744 nm 0
o
-
-

Classify... Scaling...

(112.75,387.25) < Profile Endpts -» (172,387.25)
Lengths: 79 pixels, 59.25 mtrs A

2330
2240
192.0
160.0
128.0
960
4.0
320

oo
(118.75,387.25) < Profile Endpts - (178,387.25)
Lengths : 79 pixels, 59.25 mtrs A

Resulting plots displaying
the underlying 16 bit data
and the remapped 8 bit dis-
play data. The length of the
profile line is also displayed
(see Reference).
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Image Arithmetic
HyperCube allows you to enter general “C” type arithmetic expres- [ Functions [IVETTZITY:

sions where the operands are images and constants. The result is an Flicker Cube

image whose size equals the minimum spatial size and maximum pixel Flicker/Superimpose...
depth of the individual image operands. Since the arithmetic generally Statistics >
produces values outside of [0,255] you can specify how to remap the Plot -
resultant display image. All arithmetic is performed to floating point

precision and remains attached to the resultant image. If an expres- g;f;'c:‘-:‘fv"'““" .

sion contains a color image the output will be a color image limited to

the display depth of 8 bits per color without the attached floating point

values (see examples). ST
Menu Functions -> Arithmetic... opens the dialog window shown Fourier...

below. The scrollable area contains a list of all of the current images Mosaic >

that you can use to form an expression and is in order of creation. Warp...

Each image name is preceded by the letter “s” and a number. These

become the symbols used to form the expression instead of using the explicit image name.

The expression itself will be used as the resultant image name and it too will be added to

the image list. The expression is typed into the upper edit box and must conform to the “C”

syntax. Listed below and on the next page are the operators and functions recognized by

HyperCube where s1 and s2 may be images or constants. The result is always an image of

the minimum spatial size of the image operands with possibly underlying floating point at-

Classify...

tached data.
(,) left and right parenthesis == equality
+, - %/ arithmetic operators = inequality
% modulo >= greater than or equal
&, bit-wise and, or <= less than or equal
A bit-wise exclusive or > greater than
<<,>> bit-wise shift left, right < less than
+,- unary signs pi constant (3.14159...)

fabs(sl), sqrt(sl), pow(sl,s2), exp(sl), log(sl), logl@(sl)
sin(sl), cos(sl), tan(sl), asin(sl), acos(sl), atan(sl), atan2(sl,s2)

® O M  Image Arithmetic

Arithmetic Expression:

{{fabs{slopex{=s1,1}} > 1} &
(fabs{slopeuist,13) > 13) * 259

The Image Arithmetic dialog window displaying a list
of images that you can use as ope;.’ands in an expres- =
sion. The example shown at the right generates an R,

image mask of 0 and 255 representing the areas that e i et
have an x and y slope magnitude greater than 1.

I Options... Y I Help... I .,_" Execute "/.

4
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Additionally, the following non-C functions are available where n is a constant. As is the
case with the C type functions each result is an image (see hist() for additional outputs).

shift_left(sl,n)
shift_right(sl,n)
shift_up(sl,n)
shift_down(sl,n)

Shift image s1 a distance of n pixels (n may be fractional)
in the specified direction.

slopex(sl,n)
slopey(sl,n)
slopexy(sl,n)

int(sl)

min(sl)
max(sl)
mean(sl)
mode(sl)
median(sl)
sd(sl)
cov(sl,s2)

norm2(sl,s2)

red(sl)
green(sl)
blue(sl)
hue(sl)
saturation(sl)
intensity(sl)

gray(sl)

rgb(sl,s2,s3)

hsi(sl,s2,s3)

ternary(sl,s2,s3)

Generate the slope of image s1 over a distance of n pixels,
in the x, y or combined xy direction (n may be fractional).

Truncate the fractional value of image sl to integer.

These 6 functions create an image with constant values
equal to the specified statistic of image s1.

Standard deviation of s1.
Generate the covariance between images s1 and s2.

Generate the normalized distance, (lIs1 - s2ll)/(lls1ll),
between images sl and s2.

Extract the red, green or blue plane of a true color image.
If s1 is gray then the function output is s1.

Extract the hue, saturation or intensity plane of
a true color image. If sl is gray then the output is sl1.

If s1 is true color then return a gray image weighted as
33*red + .33*green + .33*blue (equal weights).

If expression sl is not true color then it is remapped

to [0,255] using a 98% interval about the median.

Form a true color image from 3 arguments where s1, s2
and s3 represent red, green and blue respectively.

Equivalent to Image -> Convert -> R,G,B to Color.

Form a true color image from 3 arguments where s1, s2
and s3 represent hue, saturation and intensity respectively.
Equivalent to Image -> Convert -> H,S,| to Color.

Similar to the C ternary operator, (s1)? s2:s3. Use image s2
if s1 is not zero and image s3 if sl is zero, pixel by pixel.
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conv(sl,s2) Perform the convolution of s1 and s2 (frequency domain).

corr(sl,s2) Perform the cross correlation of s1 and s2.
dft_power(s10) Generate the Fourier frequency power spectrum of s10.
dft_phase(s10) Generate the Fourier frequency phase spectrum of s10.
dft_nterms(sl,nl) Fourier transform s1, keep largest nl % terms, invert result.

Demonstrates how few Fourier coefficients are needed.

class(sl,n) Extract, as a color mask image, the n’th class from class map
image sl.

band(s1,n) Retrieve the n’th band from cube image file s1,
1.e., access the cube file itself.

band_sum(s1l,n1,n2)  Form the simple summation of bands nl through n2 from
cube file s1. Ignore disabled bands.

hist(sl) Produce, as a separate output,the histogram(s) of s1.
Also, outputs s1.

hist_masked(sl,s2)  Similar to hist() but uses image s2 as a [0,!0] mask
to define the areas of s1 to use in the histogram.

save_file(sl) Save image sl as a TIFF file. If sl is a cube
file (not a specific band) save its corresponding window.

The following 8 functions compute and use the discrete wavelet transform (dwt or its
inverse) of argument s1. If the spatial size of sl is not a power of 2 then it is automatically
zero filled to the next power of 2 size (also making a square image) and the transform taken.
Arg nl is the number of Haar or Daubechies coefficients to use, either 2 (Haar), or 4....,20
(Daubechies). Argument n2 is the multiresolution analysis level and may range from 1 to
log2 of the image size (e.g., 9 for 512 by 512). A special case of n2 =0 generates the maxi-
mum level. Because of the power of 2 requirement, functions dwt() and dwt_inv() should
first be used by themselves and the resulting power of 2 size wavelet or inverse then used

freely in subsequent expressions.

The remaining 6 functions can be used directly within any

expression since their image argument, s1, is zero filled as necessary, processed and extracted

back to original size.

dwt(sl,nl,n2) Compute the forward discrete wavelet transform (dwt) of s1.

dwt_inv(sl,nl,n2) Compute the inverse discrete wavelet transform.

dwt_low(sl,nl,n2,n3)

dwt_high(sl,n1,n2,n3)

Compute the forward dwt of image s1. Keep all transform
values with magnitude < n3, zero the rest and perform the
inverse transform to produce a filtered image.

As above, keep values with magnitude >= n3, zero the rest.

HyperCube Pictorial User’s Guide

09/06/12 70



dwt_energy(sl,nl,n2,n3) Compute the forward dwt of image s1. Rearrange the dwt
in decreasing energy order. Normalize and form summation
until energy sum >= n3 where arg n3 is a percentile [0,100]
of the total dwt energy. Zero transform terms less than last
energy addition and invert to form an image.

dwt_nterms(sl,nl,n2,n3) Compute the forward dwt of image s1. Rearrange the dwt
in decreasing energy order. Keep the greatest n3 terms
where arg n3 is a percentile [0,100] of the total number of
dwt terms. Zero the remaining terms and invert
to form an image. For example, if s1 is 512x512 then the
expression dwt_nterms(s1,4,0,10) transforms s1 to the highest
level (9) using Daub4 coefficients, keeping the greatest
26214 = (262144%*.1) energy terms and zeroing the rest.
The remainder is inverted to form an output image.

dwt_avg(sl,nl,n2) Compute the forward dwt of image s1 to level n2 using
nl coefficients. Zero all detail (fluctuation) terms,
1.e., just keep the level n2 trend terms. Invert the result to
produce an averaged image.

dwt_detail(sl,nl,n2) Compute the forward dwt of image sl to level n2 using
nl coefficients. Keep only the level n2 fluctuation terms.
Zero the trend and level 1 thru n2-1 fluctuation terms.
Invert the result to form a detail level n2 image.

Note: For example, if image s1 is 512x512 and nl = 4 then the following are true:

sl =dwt_avg(sl,4,n2) + dwt_detail(s1,4,1) + dwt_detail(s1,4,2) +
dwt_detail(s1,4,3) +...+ dwt_detail(s1,4,n2).

i.e., an image is the sum of inverted dwt trend and fluctuation terms.
and:

sl =dwt_high(s1,n1,n2,n3) + dwt_low(s1,n1,n2,n3)

s1 = dwt_energy(sl,n1,n2,100)

sl = dwt_nterms(s1,n1,n2,100)

for any valid n1, n2, n3 values.
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The relational operators (e.g., <,>,==) produce a mask image consisting of 1’s where the
pixel by pixel relation is true and 0’s where it is false. For example: the expression s1l==s2
creates a mask with 1 for each pixel of s1 and s2 being equal and zero otherwise. The
expression: (sl==s2)*s1 shows those pixels of s1 that match s2, whereas (s1!=s2)*s2
shows those pixels of s2 that differ from sl .

The expression: ((red(s3)>=green(s3))&(red(s3)>=blue(s3)))*s3 displays all
areas of the true color image s3 in which the red intensity is greater than or equal to both the
green and blue intensities; black elsewhere. See more examples later.

In addition, a new constant type operand is available that consists of a triplet set of num-
bers represented as {n1,n2,n3}. When used in an expression such as s1*{.95,1.3,.6} the
red component of s1 is multiplied by .95, the green component by 1.3 and the blue compo-
nent by .6. You can use the triplet constant anywhere that a single constant is valid. It will
force the pixel depth to true color.

All image operands are converted to floating point before arithmetic is performed. The
result of the expression must then be converted back to 8 bits/plane to display an image (the
underlying data remains the results of the expression and is left attached to the image).

The Image Arithmetic Options... button allows you to determine how the display pixels
generated by the expression are remapped back to the

Arithmetic Options

[0,255] range. If the Remap check box is unchecked
then the expression is truncated (but not the underly-
ing data) such that values above 255 are set to 255 and
values less than 0 are set to 0. This is useful when the
expression only contains bit-wise operators. Generally,
expressions produce pixels well out-of-range. In this
case select the Remap check box and choose the min &

@ Remap display result between:
) min & max ) median interval, % 98.0

"I Colors, separately

Set divide by zero quotient to:
@ zero (Jone (255

"1 Generate a sequence and accumulate
Enter # of outputs: |N/A

and range for variable ‘t":

max radio button, then the expression range [min,max] i o il

will be linearly remapped to [0,255]. For expressions
that produce a wide non uniform range of values choose
the median radio button. Then, the value of the expres-
sion is remapped so that values in the range [median -
%/2, median + %/2] are linearly transformed to [0,255].
Values outside of this range are set to 0 and 255 re-

| If save_file() function, skip accumulate

I Save File Name... ',I

(none current)

@ List constant function rasults

{ Cancel )

€ Okay )

spectively. The Do each color separately checkbox
specifies whether one set of statistics is applied globally for all three colors or whether three
sets of statistics are separately used to remap each color independently of the others. Set
divide... defines the result of any zero divisors that may occur (almost a certain consequence
of using the divide operator). The 3 possibilities set the resultant pixel to zero, one or 255.

Expressions are evaluated from left to right unless parentheses force the order of execu-
tion. An expression can consist only of constants in which case the output image is a uni-
form color. All 8 bit pseudo color images are converted to their respective true color values
during computation. The result remains true color, it is not reconverted to pseudo color. Any
expression containing only gray results in a gray output image at full precision. Any expres-
sion containing color produces a color output image at 8 or 16 bits per color.
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The Arithmetic Options dialog allows you to generate a sequence of outputs that are
assembled into a “synthetic” cube where each plane is the result of one evaluation of the
sequence. To use this option check Generate a sequence, and enter the number of outputs
and range that will be linearly substituted for the variable ‘t’ in the expression. For example:
the arithmetic expression slopex(sl,t) with the options shown will generate a cube consist-
ing of 10 planes where each plane is the slope in the x direction over an interval of ‘t’ pix-
els,ie., 1,2,3,...,10. The variable ‘t’ is not limited to integer values and may be substituted
anywhere in the expression that the substitution produces correct syntax. Another example:
((s4>=mean(s4)-t*sd(s4))&(s4<=mean(s4)+t*sd(s4)))*s4 sequentially displays the
values of image s4 lying within the expanding interval [mean-t*sd,mean+t*sd] with ‘t’ set to
range from O to 3.

The Save File Name button is used to designate base name for the save_file() func-
tion. Each file name will be the ‘base name’ concatenated with a 3 digit sequence number.

The List constant function result checkbox will display the result of constant functions
in a separate text window. These functions include: mean(),mode() ,median(),min(),
max(),sd() and norm2(). Also, the various discrete wavelet transform functions, dwt_
energy(),dwt_nterms(), ..., display detail in the text window. Uncheck this option to dis-
able the text window output.

Band 60 (s1) of HYDICE image cube An 8 class map (s2) generated via K-means

(available at www.tec.army.mil/ using the class mean as the class color. See
Hypercube/index.html). section Spectral Classifications.

The result of combining the above left gray shade
image, s1, and the above right color class map, s2,
using the arithmetic expression:

hsi(hue(s2), saturation(s2), gray(s1)) with Remap
disabled in Image Arithmetic Options.
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Examples:
where: sl is a data image; s2,s3,s4 are bands of a cube and s5 is the shaded relief of s1

((s1>1000)&(s1<1200))*s1  Keep sl values between 1000 and 1200, zero rest.

log(sl) Should also choose a remapping option.
atan2((s2-s3),(s2-s4)) Also try various remappings.

shift_left(sl,3) Shift the s1 image 3 pixels to the left with wraparound.
shift_up(sl,.5) Shift the s1 image up .5 lines (fractional shifts are allowed).
slopex(sl,2) Generate the slope of image s1 over an interval of plus and

minus 2 pixels in the x direction.
gray(s5) Use the display gray values of s5 instead of any attached data.
(s1>1200)*{32,0,0}+gray(s5)  Generate a red tint image of s5 greater than 1200.

(fabs(slopex(sl,1))>1&fabs(slopey(sl,1))>1)*255 A mask of areas with x and y
slope magnitude greater than 1.

hist_masked(s2,s2==s3) Generate a hist of s2 wherever pixels s2 and s3 are equal.

O =———nne=——-=08 Shaded Relief

Corresponding shaded relief ~ The mask image resulting
generated via menu Appli- from the last expression in
cations->Shaded Relief. the examples.

This image of the above source image is the result of apply-
ing the the following arithmetic expression:

(slopex(sl,1) > 0)*{255,0,0} +

(slopex(sl,1) < 0)*{0,0,255} +

(slopex(sl,1) == 0)*{0,255,0}

so that positive x slopes are colored red, negative x slopes
blue and zero x slopes green. Expressions may be copied
and pasted to and from a text window (File->New ) and then
saved.

-
=

HyperCube Pictorial User’s Guide  09/06/12 74




More examples:
where s1 is a gray or true color image or cube file band.

dwt(sl,4,0) Compute the discrete wavelet transform of image sl using Daubechies 4
coefficients to level 8 (arg n2 = 0 implies the maximum level).
The resulting transform image is always a power of 2 in size.

00 I8.tif

B

)

Source 256 by 256 by 8 bit The 8 level dwt using 4
gray image. Daubechies coefficients.

dwt_energy(s1,20,0,99.8) Compute the 8 level dwt of image s1 using 20
coefficients and keep 99.8% of the energy of the
transform. Zero terms representing the remaining
2% and invert the transform to form a filtered image.

®0O6 18.tif O O O dwt_energy(s1,20,0,99.8)

>4

=N

A profile line displayed over the origi- The resulting filtered image with the same
nal image along with its plot below. profile line and plot shown below.
06 18.1if gray_profile O O O dwt_energy(s1,20,0,99.8) gray_profile
18 _tif gray dwt_energy(s1,20,0,99.8) gray
235.0 235.0
2240 2240
1920 122.0
160.0 160.0
1228.0 1220
950 960
&4.0 &4.0
320 20
oo oo
(27,224) <= Profile Endpts -> (249 220 (27,234) <- Profile Endpts -> (249 22)
/ /
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Shown at the left and bottom
are two images representing
the source and result of dwt
processing, respectively. The
bottom image has been re-
constructed from only 10% of
the dwt transform terms and
is visually indistinguishable
from the source image. This
represents a 10:1 compression.
Also shown is the color by
color result of the transforma-
tion. Argument level O uses the
max level which in this case is

9 (log2 512).

© 1965 Kodak
Original 512x512 8 bits/color image.

dwt_nterms:

red:

Daub20 level 0

% energy 99.9122

% terms 10.0002

# terms 26215

abs threshold 13.7915
green:

Daub20 level 0

% energy 99.913

% terms 10.0002

# terms 26215

abs threshold 13.3667
blue:

Daub20 level 0

% energy 99.8488

% terms 10.0002

# terms 26215

abs threshold 15.3345

© 1965 Kodak
Reconstructed image from the arithmetic expression:

dwt nterms(sl,20,0,10)
where 20 is Daub20, O represents level 9 and 10 is %.

Arithmetic detail output pro-
duced via Arithmetic Options
List constant function result.
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Overlaying Images

Flicker Cube
Flicker/Superimpose...
Statistics >
Plot >
Arithmetic...

Overlay Color...
Adjacency >
Classify...

Calibration...
F(Signatures)...
Fourier...

Mosaic >
Warp...

A special image function is provided to allow overlaying one image
on top of another. This could be accomplished by splitting the images
into red, green and blues planes followed by various logical operators
previously described in Image Arithmetic and then re-combining the
resulting planes. The Functions -> Overlay Color... menu makes
this much easier: you select the two images and the program will
construct a third true color image that is the result of overlaying im-
age 1 upon image 2. The first image is the mask or top and the second
image is the base or bottom. Every black pixel in the mask becomes
clear when placed upon the base thus allowing the base image to show
through at that pixel. Every non-black pixel in the mask overwrites the
base image. The spatial sizes and pixel depths of the source images
do not have to be the same, the output image will be the size of the
overlap and true color. Psuedo color and gray scale are automatically

accounted for. Note that the mask criteria is based upon color, in this

case black, and not on a zero index if the mask happens to be a pseudo color image.
Choosing Overlay Color... from the Functions menu brings up the following dialog:

Select Overlay Images

Select 2 source images. A new composite
output image will be generated consisting
of Image 2 wherever Image 1 is black and
Image 1 wherever not black.

Image 1: [ ED1 10.0 - |

Image 2: | dataBa.011 Copy v |

ED1 10.0

Image 1 (mask)

E[E= dataga.011 Copy Over =[]
=]
1o Sk
,‘, ot
ey,
(Ao
L7
= ERE
Image 2 (base) Color Overlay
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Adjacency

This image function can be used to delineate where two or more
pixels (classes) have the same value within a selected spatial neigh-
borhood. Four variations are available: the first, Images, cross
compares the pixels in two different images, the second, Colors,
uses a single image in the comparison and the third and fourth,
Classes and Singularities, pertain to spectral classifications. The
idea is the same for all: generate an output image consisting of a
combination of input image pixels that match some criteria any-
where within a specified radial distance of each other. The neigh-

borhood can range from zero to some arbitrary radius.
Menu Functions -> Adjacency -> Images is a generalization of equality. Given two
images it sequentially compares a pixel of the first image with the neighborhood surround-
ing the similarly located pixel in the second image. For example, a radial neighborhood of
1 is interpreted as comparing the source pixel with any of the 4 adjacent pixels in the second
image (a radius of 1 is not large enough to include the diagonal neighbors). If Coincidence
is checked (see below) then the central pixel is also included. A radius of 2 increases the
valid comparison region to 12 or 13 pixels depending upon Coincidence. Fractional radii
are allowed, e.g. a radius of 1.42 would include 8 or 9 pixels. If the radius is set to zero then
the function reduces to equality. The output pixel can be set to just the source pixel, just
the matching neighborhood pixels or, both as selected by the three radio buttons. The image
examples below demonstrate how two spectral classification output masks are combined to
produce a new mask in which the algorithms agree with each other allowing a spatial un-
certainty of 1 pixel, e.g. where Vector Angle and Correlation Coefficient matched exactly
(Coincidence set) and within 1 pixel of each other.

O===——vAl 18 =————H 8

Select Adjaceny Images

one or both of the two images wherever an
Imagel pixel has a matching pixel in Image2
within a neighborhood radius of [1,Radius].

Select two images. The outputimage consists of

Coincidence changes the interval to [0,Radius] .

1k

Image 1: | YAl 0.08
Image 2: | CC1 0.98

Radius:

[ Coincidence {range includes zero)

@ Image1 OR'ed with Image?2, if a Match
() Image 1 only, if a Match
(2 Image2 only, if a Match

1k

The two source spectral
classification outputs
used as input to the Ad-
jacency function produc-
ing the output shown at
the lower right.

Dialog is set to produce
an exact match as well a
spatial mismatch of a one
pixel radius.

AT B Utilities Windows Help
Flicker Cube I
Flicker/Superimpose...

| Plot »

Statistics b

Arithmetic...
Overlay Color...
Adjacency Images
. | Colors
Classes

Classify...
Calibration...

Singularities

CC1 098 ———=—=p 18

Adjacency | =——"~—0H
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Menu Functions -> Adjacency -> Colors operates on the front image window and is
used to extract pixels with two specific colors that are co-located within a selected radius.
This operation could be done by first separating the source image into two masks of the
given colors (see section Image to Mask) and then using Adjacency -> Images as above
but Functions -> Adjacency -> Colors greatly simplifies this. The image example below
shows how a multiple spectral classification output can be transformed into an output show-
ing the outline of everywhere one class is exactly adjacent to another class, e.g. grass and tree
canopy demarcation. Again, the selected radius allows a considerable latitude in the equality
range. The two colors to be compared are best chosen by first positioning the cursor over
the source image and using the special command-option-C combination described in section
Copy, Paste & Duplicate. The colors will then automatically be filled in when Functions
-> Adjacency -> Colors is selected. Note that checking Coincidence has an effect only
when the two selected colors are identical in which case the resultant image will consist only
of that extracted color (see section Image to Mask to accomplish the same thing).

Select Adjacency Colors

Select 2 colors (grays). The output image will
consist of one or both colors {grays)wherever
the 2 colors {grays) are adjacent within a
neighborhood radius of [1,Radius] . Coincidence
changes the interval to include zero, [0,Radius].

Image: 5ix Class Map

Color 1 {r,g,b}): -
Color 2 (r,g,b):
Radius:

O Coincidence {radius includes zero)

() Color1 OR'ed with Color2, if a Match
() Color1 only, if a Match
@ Caolor2 only, if a Match

EI
L7t

The dialog above was used on image Six Class Map to extract tree [43,96,43] regions
that are adjacent within a 2 pixel radius to grass [195,255,195]. The output consists
of only the grass border.

aes & Grass Adjacency —z= g1 5
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The third variation, Functions -> Adjacency -> Classes, is only available when the
front most image is a classification overlay produced via the Classify function. This type
of image displays the member class as the cursor is moved over it. The intent is to extract
all of the areas within the overlay that have a common adjacency but instead of specifying
colors you specify how many of the class members must be present within a certain radius.
If you select less than the actual number of classes that the overlay possesses then this subset
could and would change throughout the image. This permits generating a spectral classifi-
cation using similar signatures from a library (again using Classify) and then entering how
many of these signatures are needed (found) within a certain radius to reduce the ambiguity
of false “hits”. The output may be an image or a mask depending upon the Clear image
background checkbox. The image appears where the criteria fails and some combination of
the class member colors where it succeeds. If a mask then black appears where the criteria
fails. The mask can be overlaid on the original classification source using menu Functions
-> Overlay Color.

The following user dialog and examples illustrate how you can increase the accuracy of a
spectral library classification.

Select # of Matches

Select how many matches that must be within the Class map image Four Class Map COnsists
chosen radius to be defined as an Adjacency type

of match. The number of matches must be less 0f4 classes. AllfOI/tl’ classes are used and
than or equal to the total number of classes . . . .
it searched within a 2 pixel radius to generate
Four Qlass Map® contains 4 classes. the output mask image shown below right.

Radius {pixels): # of matches:

Clearimage background {output mask)}

0 =—"——"—=comp Adj 200=—"=0H

Vehicles

This classification overlay image was After applying Adjacency ->
generated by using 4 signatures from a Classes to the left hand image.
spectral library, each depicting some

characteristic of a vehicle.
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The fourth variation, Functions -> Adjacency -> Singularities, is also only available
when the front image is a classification overlay produced via the Classify function. This
type of image displays the member class as the cursor is moved over it. The idea here is to
scan the image for all occurrences of a single class map color (feature) that is surrounded by
a different feature or features within a specified pixel radius. Wherever this happens the sin-
gularity is replaced by the surrounding feature with the greatest abundance within the radius.
If the single class feature is surrounded by imagery (gray) then no replacement is performed.
The final output of this function is an almost identical class map with single pixel “noise” re-
placed by surrounding features. Since this modifies what the Classify function thought was
correct you must carefully inspect the new class map to determine the validity of this opera-
tion. The best use of this function is to de-clutter class map images before converting them
from raster to vector form (See section Class Map Editor).

Below are the user dialog and an example of applying this function.

Remove Singularities

Each singularly occurring class map color (feature)
will be replaced by the color of the feature with the
greatest abundance within the specified radius.
Singularities surrounded by imagery are not removed.

Image 'Six Class Map' contains 6 classes

| As the radius increases, the probability
of finding a singularity greatly decreases.
With a radius of 1, only the top, bottom,
left and right pixels need to be different.

Radius {pixels):

b
k _;:Ei

F

A three times magnification of a portion of
a six class map as output from the Classify
function. There are 169 singularities within
this subset.

The same subset after removing each oc-
currence of a single class surrounded by
different classes.
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Fourier Operations

Frequency domain filtering is initiated by selecting menu Functions -> Fourier. The
dialog presented allows you to interactively change various filter parameters and apply them
to an image. The filter’s characteristic curve is shown within the plot window as sliders are
moved. The radii sliders represent the half magnitude point. The attenuation slider deter-
mines how sharp the filter is. All filtering uses the same scenario: select part or all of an
image, click the FFT & PS button, select the filter type, move the sliders for the desired
effect, and click the Inverse button to generate the filtered image. If Dynamically is enabled
in Fourier Options then the filtering is performed as the sliders are moved. Fourier is an
operator like gray mapping, it is unique to the active image window when it was selected.
There can be several Fourier operators, each connected to its own source image.

An important visual key to interactive frequency domain filtering is the power spectrum
(PS). It displays the relative amplitude of the frequencies comprising the image. The center
of the power spectrum represents the lowest frequency with frequency increasing radially
outward. As you move the sliders the radii change indicating which frequencies will be af-
fected for the type of filtering chosen.

The images above show the ® O Fourier—>Capitol emb.

effect of applying the High O LowPass () BandPass () Selection
Boost filtering operation. At ||SHahPess O Bandsior @ High Boost
the left is the Power Spec- E—

trum corresponding to the e

upper left source image. See Attenuation

functions dft_phase() and e, —

dft_nterms() in section Image ° e iy
Arithmetic for additional Crrrers ) Cotoms. ) (e )

Fourier operations.
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Fourier contains five slider controlled filters and one user selection filter. These are de-

fined as follows:
Low Pass

High Pass

Band Pass

Band Stop

High Boost

Selection

The image area to be filtered must be a power of two sized
square. HyperCube accomplishes this by automatically
embedding the source image or selection rectangle in the
smallest power of two square image that will enclose it.
The border is set to the mean of the image (selection) to
minimize ringing in the inverse transform. All operations
then proceed using the embedded image. The result will be
extracted as a separate image and may, optionally, be pasted

Attenuate frequencies above Radius 1. Use this slider and

the Attenuation slider for desired response.

Attenuate frequencies below Radius 1. Also use Attenuation
slider to shape response curve. Because the average brightness
is zeroed remapping (Options) must be chosen.

Pass only those frequencies between Radii 1 & 2. Radii sliders
select pass band, Attenuation slider determines sharpness.

Also requires remapping option.

Attenuate frequencies between Radii 1 & 2. The inverse of

a pass band.

Similar to High Pass. The boost varies from 1.1 to 9.9 and is
controlled by the second radii slider (label changes to Boost).
Remapping should be used for data type images.

Attenuate frequencies within a user selection rectangle. Manually
draw a selection rectangle on the power spectrum image.

Fourier Options

"1 Also paste inverse into original

"1 Use binary filter cutoffs

E‘Remap inverse image display using:
() min & max

®) median interval, %:
PS Compression: | Log & ]

E‘ Dynamically update inverse
Cancel )

back into the source image. If the source is an 8 bit pseudo
color image you will be directed to convert it to a true color copy using menu Image ->
Convert Image -> Indexed to Color.

The Fourier Options dialog shown above presents additional controls. The top check
box determines whether the inverse image also overwrites the original image patch. The
second check box changes the filter characteristic from a tapered one to a vertical cutoff. The
Remap check box works exactly as that in the Image Arithmetic section and is a must for
high pass and band pass filters which zero out the fundamental frequency (image average).
This is also especially true for any images that represent data. The PS Compression popup
is used to present a better display of the power spectrum. If Dynamically is check then a
new invervse image is generated for every movement of the sliders.

® O 7 Fourier->gl.tif Copy2 ® O 7 Fourier->gl.tif Copy2
") Low Pass ) Band Pass ) selection . L. ") Low Pass ® Band Pass ) Selection
) High Pass ® Band Stop ) High Boost Typlcal Chal’actel”lsllc ) High Pass ) Band Stop ) High Boost
2 _ 18 curves for Band Stop, 2 _ 18
= left, and Band Pass, =
Attenuation rlght’ Fourler‘ﬁlterlng' Attenuation

37 37
L = ——

Radius 2 0o Radius 2 0.0

a Cycles 128 a Cycles 128
j_ FFT&PS ) ( Options... ‘ x Inverse J FFT&PS ) ( Options... ‘ j Inverse )
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Mosaic Points

Two or more images can be fitted together to form a single image. They are joined by se-
lecting conjugate image points on each of the images . The geometry used to force the join-
ing ranges from a simple orthogonal transformation to a plane to plane projection. However,
the transform must be the same for all of the images. Mosaic is more general than Warp
(described in the next section) in that the end result is to stitch images to a common geometry
for a greater view whereas warp’s objective is to match the geometry of one image to another.

By choosing menu Functions -> Mosaic -> Points, a dialog will appear with several
scrollable list areas. Only the Available Images list initially contains anything, namely all
open images that are candidates for mosaicking. Click on each Available Images list name
to highlight it and click the Add -> button to move the image name to the Mosaic Images
list. Double clicking an Available Images name will also move it directly. The order of
selecting images is not important (see Load/Save points). To remove an image from the Mo-
saic Images list click its name and click the Remove button or double click its name, it will
be returned to the Available Images list. Removing an image after starting the control point
selections will remove all control points. You are warned of this and are allowed to cancel
the removal.

Once the mosaic list has been determined the program is ready to begin the control point
selections. Position the cursor over any image and shift-click the mouse, a colored numbered
reticle will be left there. Move to the conjugate position on another image and shift-click
there. This can be repeated until each desired image contains a matching control point. Sub-
sequent attempts are disabled until the New Image Cntrl Pt button is clicked. This permits
selections for the next control point number. Each control point must appear on at least 2 im-
ages before going to the next control point. New Image Cntrl Pt is automatically disabled
until at least 2 images contain a given control point. A control point does not have to ap-
pear on every image, only on at least two. As a control point is chosen it appears in a scrol-
lable list. A point may be deleted my clicking on it and choosing the Delete Image Cntrl
Pt button. It will be deleted from each image it appears upon and the remaining points will
be renumbered. The number of control points determines the degree of transformation (see
section Warp) that will be allowed. Therefore if two images have only 2 control points in
common then only the Orthogonal transformation will be available regardless of how many
common points may appear on other images.

Unselected available .00 Mosaic Points
images Data t’ype Available Images: Add -= | Mosaic Images: e

| [woce wocs . List of images to
form the mosaic.

images may also be | |woce
mosaicked together.

TWO COl’ltl"Ol points Cll’ld ( Newlmage CntrlPt —————— ACl'lle'e anofher
their coordinates that ———-| s 1es wocs set of selection
2 220 nja \‘:‘DCa pOil’ltS.

have been measured. G daR

Centrol Image:
The image chosen to be —twoca B ( Delete Image Cntrl pi\\Delete the selected
the geometric conl.rol Transform: COI’ll‘I”Ol pOint.

. ‘Orthogonal ":] (" Load Pts... " I" Save Pts... ‘l
Type of transform and Interpolation: ]
interpolation ——Lpilinear 3] ( outine ) (Options.—+—— Described on sub-

£ | Generate cube mosaic (" Mosaic Images ) | sequent pages.

Mosaic each cube band.
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After all of the control points have been selected you can mosasic the images by clicking
the Mosaic Images button or generate an outline showing how the images will be placed in
the mosaic by using the Outline button. This generates a colored line drawing image that can
be overlaid on top of the final mosaic using Qverlay Color... in the Functions menu. The
Control Image popup is used to select which one of the mosaic list images defines the ge-
ometry that the remaining images are conformed to. The control image shape stays the same
and the other images are warped to its geometry using the selected Transformation and type
of Interpolation.

Any of the mosaic images may be chosen as the Control and it will appear “stationary”
in the output. The biggest problem with mosaicking to a control image is the cascading of er-
rors: e.g., Image 1 is the control and has points in common with image 2 which has points in
common with image 3 but image 1 and 3 have no (or not enough) points in common. Then
any errors between 1 & 2 and between 2 & 3 cause very obvious misfits between overlap
boundaries because the global least squares fit is to the control image’s geometry. A way to
minimize the effect of poor control points is to choose a good image as the Control image
and then only mosaic it and one other image together, then save the resultant mosaic im-
age and restart a new mosaic operation using the added image as the new control image (the
current mosaic will generally have black areas that would overwrite if it were chosen as the
control image). This has the effect of breaking the geometric fit into regions (more degrees
of freedom) and results in a more aesthetically pleasing final mosaic.

WDC a Mosaic3 Outline

The result of mosaick-
ing the two images in the
previous dialog is shown
on the left along with the
outline generated for the
same pair to the right.

Below is a description of each of the Mosaic window controls along with the possible
options and their effect.

Add ->: Move the selected image from the Available Images list to the Mosaic Images
list. Double-clicking does the same.

Remove: Move a selected Mosaic list image back to the Available list. Also may
double-click.

New Image Cntrl Pt:  Used to step to the next control point, is disabled until the current
point has been selected on at least two images.
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Control Image:

Transform:
Interpolation:

Outline:

Load...:

Save...:

Selects which of the mosaic images will be the control geometry.
Unless averaging (see below) the control image will always be

the top most image in the mosaic, i.e., it will overlay the others

in common overlaps.

The type of geometric transformation. See section Warp.

What type of interpolation to use in the resampling. See Warp.
Generates an output image the same size as the mosaic images but only
shows the outlines of the individual mosaic images. Becomes enabled
when a mosaic is possible. Also see Options.

Load a previously saved set of control points.

Save the current set of control points as an ASCII file.

Note: Saved and reloaded control points must exactly match the images and order
of the original mosaic. However, once reloaded they can be deleted, added to,
and resaved.

Options...:

Bring up the Mosaic Points Options dialog. See below.

Mosaic Images: Execute the mosaic operation.

Selecting the Options... button displays the following user dialog.

Average...:

Display mini...:

Void areas fill:

Masaic Points Options

[ Average pixels within overlaps
(default is use single image)

[ Display mini outline
(default is mosaic size outling)

Void areas fill:

( Cancel " Okay

Where the mosaic forms overlaps the control image’s pixel takes
precedence followed by the order of the Mosaic images list. When
this option is checked all of the images within an overlap will be
averaged together to form the output pixel.

When checked, the Outline button will generate a miniature instead
of a full scale line drawing. The mini cannot be correctly overlaid

with the Mosaic output.

The gray value that is used to fill new undefined areas.
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Mosaic References

This function also mosaics two or more images together except that no image points are
used. Instead, each of the images must have a geometric reference in a common coordinate
system (see section Image to Reference Coordinates). Menu Functions -> Mosaic Refer-
ences function computes the outer boundary of the images in the Mosaic Images list and
then places each image in the proper location based upon its coordinates. The resulting mo-
saic is created in the order of the Mosaic Images list with each image overlaying the mosaic
under construction. Note: If the overlaying pixel is zero then it does not overwrite the lower
layer. There are several options that determine how the images are combined in the overlay
region. One of the Mosaic Images list determines the scale of the final mosaic. That is,
even though all images must be in the same coordinate system they don’t have to have the
same scale. For example: one image could represent a meter per pixel while another could
be .5 meters per pixel. The scale of the selected Reference image determines the final
scale of the mosaic. Pixels are warped as necessary to make everything merge correctly. The
interpolation used is selected by the Interpolation popup menu and can be nearest neighbor,
bilinear or cubic resampling. Nearest neighbor works best for images that are essentially the
same scale.

The Mosaic References dialog is similar to the Mosaic Points dialog. They both show
a list of available images from which specific images can be selected for mosaicking (this
also determines the mosaic order). Double-click an image in the Avail list to add it to the
Mosaic list. Double-click a Mosaic list image to move it back.

[ N @) Mosaic References
Mosaicked images Available Images: Add -> Mosaic Images: " Remove _\' Three l‘mages Ofl.he
. Mosaic 1 1 .
are automatlcall)f R 2 || mosaic shown on the
added to the Avail next page.
list. Outline im-
— Details ——————— —Details ———
ages are not. £ Un:lacolosrds: color: 48 bits Details Ofa Currently
1088 pixels: B16 lines ... .
Interpolation: Reference Image: hlllghted lmage appear
Nearest Neighbor | :] 1 [ 5] here'
A multicolored out- | ouine ) Copons=) (€ wosaic
line image showing
where each will lie.
Scale can be Selected Mosaic References thions
in Options. @ Use histogram matching to remap each image's When histogram match-
color or gray values to the mosaic using their . .
common reference overlap as the color space ing s enabled each com-

match region. Continue the match with each
succeeding generated mosaic image within the

Which color domain to Avail list.

to modify the next image
perform the histogram () RGB space . fy . &
hi Ol s in the mosaic to match the
matching >

Hue hist match growing mosaic image.

*) Hue color shift

mon overlap area is used

These checkboxes display .

| Show intermediate images
details of the histogram C Show overlap masks

matching. They dO not 1 Show histograms and lookup tables A Scalefactor that de_
i | termines the size of the
leféCl’ theﬁnal mosaic Dutline scale: 10.50 — | . l < f
output image. — mosaic outline.
P 5 (CEameaD) =
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Three source images sharing a common coordinate system, UTM, to be mosaicked
together. In this case, they all appear to have a similar scale. However, that is not
necessary. The Reference image popup in the Mosaic References dialog determines
the final scale of the mosaic and popup Interpolation determines the resampling.

®O6 Outline O Mosaic

The result of selecting the Outline The final mosaic image with im-

button in the Mosaic References dia- age 1 selected as the Reference

log. The Reference image outline is image. Therefore, the remaining

always shown in red. images have been properly scaled
using Nearest Neighbor as the
interpolation.

Saving an outline or mosaic image as NITFE will also embed the Rational Polyno-
mial Coefficients (RPC) in the image header.
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Warp

Menu Functions -> Warp allows you to force the geometry of one image to fit the
geometry of another image. You can force two completely different types of imagery, such
as optical and radar, into registration, combine them and thus produce a new product. The
registration points, the pixel resampling, the final output scale and the type of transformation
used are all selectable.

After choosing the Functions -> Warp menu, you select two images from the dialog
popup list of images. All single images and cubes are permissible. Using the mouse control
points are selected alternately between the images as follows: position the cursor on control
point 1 of image 1 and click the mouse while holding down the shift key, then position the
cursor on the corresponding point 1 of image 2 and shift-click, repeat until all control points
have been selected. Each pair of points leaves a cross hair mark behind, usually red on image
1 and green on image 2. The coordinate pairs are listed in the Warp dialog window where
they can be edited or deleted. Either image may be zoomed to help position the cursor. The
number of points needed depends upon the transformation, higher order requires more evenly
distributed points.

The result of warping is a new image whose output size is determined by the value in
Scale factor. A value of 1 produces an image the size of the destination image. Depending
on the transformation there may be pixels in the output image that have no correspondence in
the source image, these will be set to Off image value. Transformations are performed in a
least squares fit manner to distribute the error across the control points. The Residual button
shows the mean error of the fit without producing an output image.

Shown here is the Warp dialog for a projective transformation.

Select images 6o Warp Direction of warp
) Image 1:  (wDC512 [3) ware: @1->2
Directs the user Oz2->1
Image 2: [ wDC512 +) =
__jCube | 7
O;hogonal Instructions: Control Points: Warp an entire
Affine i i int i 7
Shift-click trol t 119 25 22 33 i
e atrv mage wocsig P | (221 5% T loaded cube image.
Quadratic (6 terms) 5
Quadratic (8 terms) To remove a point, select it in g ?gE g; ?; i;

the list and press the Delete

6 134 241 132 230
button.

Cubic (8 terms)

Cubic (10 terms) i e Click in list to select,
¥ Projective 9 263 107 252 110 .
. . 10277 183 274 186 3 then edit or delete.
Eight types available _ i s s
\T@nsform. Edit V ( Del Edi ld
Projective I - “ | — llﬁe
-
Mearest Neighbor _ |‘34 32 134 48
Bilinear bl S —— — Fill data value
[T Cubic -+ : |
Pixel resampling e ! —— Multiply output size
(" Load Pts... _\'f_ Save Pts... \ (" Residuals ) "’ Warp \ by thls value.
9_ QG Warﬁ residuals _6_ QB Wa[_p coefs
RMS residual: 8.83, Projective Coefficients:
Point by point: Projective
X res, Y res, dist X coef Y coef
: s i e Residuals and coefficients | 7 e e
3 -1.523285  +2.054245  +2.557405 + .
g -_[124]332592017 _-;.:3;1695]1 j.ggii? fOi’ the above example i -ébzasrt?zaf:qm -0;;;3:2451
& S3.757156  <4.866318  +6.147949 when the Residual button is : Baiaia
7 14937515 +3.133507  +15.262642
8 2717484  -3.557953  +4.477024 ;
3 +9.733688 +3.446083  +10.325705 |v clicked.
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The transformation selected has a great affect on the shape of the output image. The non-
linear transforms are very sensitive to the number of control points and their positions. The
transforms along with their arithmetic are defined below. Each definition is actually a pair,
one for the pixel coordinate and one for the line coordinate. The Projective transformation
has the same denominator for both pixel and line. The value within parentheses is the mini-
mum number of points needed for the specified transformation.

Orthogonal (2): ax + by + c (with constraints on a,b for both pair of equations)

Affine (4): ax + by + ¢ (no constraints on coefficients)

Quadratic (4): ax + by + cxy + d

Quadratic (6) ax + by + cxy + dx? + ey? + f

Quadratic (8): ax + by + cxy + dx? + ey? + X2y + gy’x + h

Cubic (8): ax + by + cxy + dx? + ey? + fx3 + gy? + h

Cubic (10): ax + by + cxy + dx? + ey? + fx%y + gy’x + hx3 + iy? + j

Projective (4): (ax + by + c)/(dx + ey + 1) for pixel
(fx + gy + h)/(dx + ey + 1) for line

The orthogonal transform preserves shape, allowing only rotations and a single scale
change. Two points are required to define it. The second, affine, is a linear transform that
preserves parallel lines and is a generalization of orthogonal. It will transform a square into
a rotated parallelogram and is the most useful transform for registering two similar images.
The nonlinear transforms include cross products, second and third degree terms and produce
curved lines.

Three methods of pixel interpolation are possible: nearest neighbor, bilinear and cubic
resampling. Nearest neighbor is the fastest, it simply takes the closest source pixel and uses
it as the output. That is important if multiband imagery is warped and then used in a clas-
sification as no new intermediate “fringe” classes are created. Bilinear interpolation uses 4
surrounding pixels to form a positive weighted average. Cubic also uses weights but some
weights are negative. This produces a slight sharpening in the output image and appears
superior to bilinear for natural images but produces ringing in artificial images that contain
discontinuous gray values.

The figures below demonstrate the transformation of an image warped to a duplicate of
itself. The control points were purposely chosen to be slightly different. The higher the de-
gree of warp (e.g., cubic) the greater the number of control points needed. And they must be
well distributed across the image.

®0e6 WDC10.C ®en0e WDC 1P.C e0e WDC 1C10_C

Orthogonal. Projective. 10 Term cubic.
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Plot Scaling/Selection

When a plot is first generated the y axis limits are determined by the minimum and
maximum of the functional values and the x axis values represent the range of the function.
They remain so until changed, even if the plot window is resized. The vertical axis limits of
certain plots can be explicitly changed by choosing menu Functions -> Plot -> Scaling and
the x axis range can be changed by drawing a selection rectangle around the area of interest
and choosing menu Image -> Magnify Plot (the magnification value is set to 1). Each type

of plot has a corresponding scaling dialog (e.g., Plotting Signatures). Shown below is an

example of these operations applied to a histogram plot.

Malpais hist Scaling

Enter the desired y axis minimum and
maximum values. Selecting button
‘Restore’ will restore the true y axis values.
A selection rectangle and menu Image ->
Magnify can be used to subset the x axis.

Miny; ||0.000000
Max y: 86665.000000

(" Cancel ) { Restore ok )

The dialog corresponding to the histogram shown
on the left, below. The rescaled histogram is shown
on the right after changing Max y to 100,000.

806 Malpais hist

806 Malpais hist

BLEED

£45992

433F2

21666

________________|

o
=200 150 S00 250 1200

# Pts: 14365440, Mean: 232 226, 5D 86.0095, No exclusions 4
)

100000

Fa000

20000

23000

a
=200 150 500 250 1200

# Ptz 14365440, Mean: 232,226, 5D : 86.0095, No exclusions A
)

Original histogram with the y axis
limit set to the maximum functional
value. A selection rectangle has been
drawn to select an x axis subset.

The resulting plot after changing

Max y to 100,000.

806 Malpais hist Mag

BEEED

65033

43412

21786

160
23 132 24 249 438

# Pts: 143241035, Mean: 231 562, 50 : 84 4752, No exclusions 4

The new plot displaying only values
within the selection rectangle after
choosing menu Image -> Magnify Plot.
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Multiband Functions

Band List

Every multiband image has an associated band list that specifies the wavelength and
status of each band. This is necessary in order to correctly plot spectra and perform library
searches and comparisons. You can view/modify a band list by selecting menu Windows ->
Show Band -> List . A resizeable window with a scrollable list of 4 columns and several
buttons will appear. The columns display the band number, wavelength, band width and sta-
tus for each band. Except for band number, the items are editable by: clicking them, typing
a new value in the edit field and clicking the Edit button. Double clicking the band number
in the Mac version will automatically load that band as a single image not connected with its
cube parent. You must use Load Selection in the Windows version in order to load a spe-
cific band after highlighting it in the list.

The band list is the window display of the *.wvl file described in the Wavelength File
section. If a *.wvl (or older .wav) file exists when the multiband image was loaded then
HyperCube converts and loads its contents into the band list. The *.wvl file may also be
loaded via the Load wav... button. By choosing the Options... button, the band list can be
modified as desired and then saved as a new *.wvl file via the Save wauv... button. Also, it
can be copied to the clipboard via menu File -> Save or Edit -> Copy.

Band list window controls have the following definitions:

List column: 1 Sequential band number, same as image cube band numbering.
If the band wasn’t loaded, i.e. only a subset of the full cube,
an asterisk appears after that band number. You can load any band
as a stand-alone image by double clicking its band number.
2 Band center wavelength in (usually nanometers or microns).
Band width in same units of measure as wavelength.
4 Status, if “disabled” (no check mark) then the band is ignored in
spectral classifications, library searches and histograms. It will be
highlighted in red on spectral plots.

W

=
Enabled: 160
Bard nm  Width Status Disabled: 50 8eee dril Bands
12 iggg ig g!sagleg - Bl | Band nm Width  Status Enabled: 160, Disabled: 50
X % izable: — — —
F 4030 40 dissbled e oo Brt o a0 omned B S enantea =)
4 4070 5O dizabled | . 3 o isal SRR -
& 4100 50  disabled E - e i (" Disable all )
E* 430 &0 x Revert | 5 410.0 50  disabled  Srve—
7 4170 80 & 4130 50 o [ Revert |
L) 4200 5.0 i | o 417.0 5.0 v ——
5.0 o 8* a200 50 (_options... )
:IHD: i%‘l?g gg : Save wave.. | ?0. ::;:E :; :}r (" savewav.. )
1% 430 5D UL AL G800 5 [ e —
1 4m|0 50 - Load wave.. | 120 hebl At s
¢ 4420 B0 ¢ =l . aen o 3 ( save hdr.. )
Save hdr... | 15 4460 50 o ¥ [P———
16% 450.0 5.0 + v | [ Edit-> ) |424.0
Load Selection | [Edt>| [+220 50
The Windows version has an explicit Load Mac version band list showing the
Selection button, instead of double clicking. same selection area.
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Enable all  Set the status of all bands to enabled (check mark). Toggle
individually by clicking on Status (4) column entry.

Disable all ~ Set the status of all bands to “disabled”. Also toggle
individually as above.

Revert Restore the band list to the last loaded wave length file.

Options...  Display the Band List Options dialog. Sets up various combinations
of enabled and disabled bands. See details below.

Save wav... Save band list as *.wvl file.

Load wav... Display a standard open file dialog and load the *.wvl file.

Save hdr...  Save the current cube definitions in a *.hdr file.

In combination with the Band List Revert button, Band List Options allows you to de-
fine a variety of enabled bands for experimentation. There are 7 mutually exclusive options:

the first 2 change the wavelengths, the third rescales (a convenient way to convert between

nanometers and microns) and the last 4 enable or disable groups of bands. However, the
first 3 of the Enable/Disable options will not enable any band that is currently disabled in the

Band List.

Start & end is used to set a uniform
sequence of wavelengths. Delta is
computed.

Start & delta is similar to start &

Band List Options

end with a user defined delta.

Multiply each wavelength and widthby —— |
the scale entered below. Band width and

times delta change to Scale factor and

times wave respectively when selected.

Only those wavelengths within the in-
terval values defined in Image -> Cube
Color Composite -> Definitions are
enabled.

\

The complement of the above option, /

i.e., the Color Comp Defs are disabled.

Linearize wavelengths:
{®) Use start & end
™ () Use start & delta
— () Scale existing wavelengths

Starting wavelength: 397.0

2495.0
NfA

Ending wavelength:

Wavelength delta:
™ Band width: |1.500 | times delta

Enable/Disable specific wavelengths:
™ () Use Color Composite Defs

L () Exclude Color Composite Defs
() Every n'th: N/A | enabled band
() Interval (band #'s)

Start: [M/A End: I MN/A
Enable
Disable

Only enable every n'th band that was already
enabled, e.g., a value of 2 enables every
other band currently enabled.

The last of the 4 Enable/Disable options:
Specifiy the Start and End band numbers
to be enabled or disabled.

Band List Options dialog.
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Annotation List

You can associate a short (up to 64 characters) free text message with each band of a
multiband image. The messages are displayed in the band scrolling area of a multiband win-
dow (section Band Scrolling). Menu Windows -> Show Band -> Annotation displays a
dialog containing a listing of each band. Clicking on a band line displays the corresponding
message in the edit field that can be modified and updated with the Apply button. Choosing
Save hdr within this dialog or similarly in the Band List dialog will include the annota-
tion in the header (.hdr) file and automatically display it whenever the multiband image is

® O O fth 21-24 Annotation
Bal’ld numbers, Band Annatation
. . 88
Click on a line to ?30 =
display it in the edit L]
ﬁeld. :gi Bands 104 thru band 111
105 are disabled in the band st
106 due to atmospheric absorption. m
107
Apply the contents 1 Save the displayed annota-
of the edit field t 111 End of the band groupin. tion values in the multiband
na2 - .
the band number. 13 v image’s header file.
Edltﬁeld \\ Apply [ Revert ) Save hdr... l
Wﬂd gro‘uping.
A

Restore the annotation
values to those when

the dialog was opened. Clicking on a band line within the listing
displays the contents in the edit field where it
can be modified by clicking the Apply button.
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Band Scrolling
Every multiband image is loaded into HyperCube so that you can easily scroll through
the bands in a movie like manner. The band scroll bar (buttons in the Windows version) is
across the top of the image cube window and works like any other Mac scroll bar. The cur-
rent band number and corresponding wavelength and any annotation is shown at the top of
the image. If a specific band’s status is disabled then its band number is shown in red else
it is black. A specific band can be given its own display window by scrolling the cube to
that band and then choosing Duplicate from the Edit menu. It becomes completely sepa-
rate from the cube. Any band, whether it was loaded with the cube or not, may be loaded by
double-clicking a band number in the Band List (see sections Band List and Band Annota-
tion).

Band scroll bar, number, wavelength
and annotation area.

2 FTH21 22 —(ol x| 8eee fth 21-24
[« [+ [Band 60 of 6 750 nm Free tex annotation. |
VAR SR y

Band 60of 210: 750nm This areais for free text annotation.
=) i

All controls except for
Band Scrolling operate
in the same manner in
both versions.

Windows version. Mac version.
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Flicker/Superimpose

While band scrolling permits traversing an image cube in a contigu-

ous fashion sometimes it’s desirable to jump from one band to another - litles Wi
. . . . Flicker Cube

to compare differences. HyperCube contains two functions that facili- Flicker/Superimpose...

tate this. The first is the menu Functions -> Flicker Cube and is en-

abled whenever a multiband cube window is front most and the second

method is menu Functions -> Flicker/Superimpose which is enabled whenever at least

one image window is open. Flicker Cube differs from Flicker/Superimpose in that it is

specifically for the bands of an image cube and is adjustable, whereas Flicker/Superimpose

is fixed to the two specific images (of any type) which drive it (see Flicker Image dialog

below).

Flicker Cube creates a new window similar to the cube window but with three scroll
bars at the top which control the rate and the two bands to alternate. Flicker Cube is an
operator like graymap and if the cube window from which it is derived is closed then flicker
disappears. You can change the spatial offset between the two flickering images by using the
keyboard arrow keys while the flicker is the active window. Each keystroke moves image 1
a single pixel in the arrow direction. Enable menu Windows -> Show Info for a dynamic
listing of the current x,y offsets and the alternation between the pixel value under the cursor
(see section Info Window). The flicker image can be printed and also copied.

The figure below is the flicker window generated from the previous band scrolling exam-
ple. The flicker rate is nominal and some PC’s may not support the higher rates. Alternation
continues even if the flicker window is not the active window.

==

=— FHlicker->Frames 5-8r

Currently set to flicker be-
tween bands 60 and 69.

Flicker rate control expressed
in changes per second.
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The second flicker type function, Flicker/Superimpose, is more general in that it per-
mits any two image windows (and selection rectangles within) to be alternated between or
superimposed one on another as if viewing through a porthole. The images are selected from
two popup menus that appear when menu Functions -> Flicker/Superimpose... is selected.
The images do not have to be the same size, the viewing window is sized to their minimum.
The image depth, i.e. 8, 16 or 32 bits, also doesn’t matter. If one of the source images is
modified such as by gray mapping or filtering then the change will be automatically reflected
in the view window. Similar to Flicker Cube, if either source image is closed or rotated 90
degrees the view window will disappear. The window title alternates between the source
images when Flicker is chosen. Also, the keyboard arrow keys can be used to spatially offset
image 1 relative to image 2. Enable menu Windows -> Show Info to view the current off-
sets (see section Info Window).

Below is the dialog in which you select the two images and either Flicker or Superim-
pose. If Flicker then the rate of alternation for flicker can be set. If the resultant flicker is
too fast or too slow close the flicker window and generate another one. Superimpose places
a rectangular window (or inset) of the first image upon a base consisting of the second image.
This rectangle can be repositioned by clicking the mouse within it and dragging it anywhere
within the window dynamically superimposing image 1 upon image 2. To reverse the order-
ing, reselect Flicker/Superimpose and swap Image 1 and Image 2 names in the popup
menus. Superimpose is most useful when comparing an image band with a classification
output image (see Products).

Flicker alternates between the R GGl
. . Select 2 images to flicker between or
wo lmages Whereas Superlm_ superimpose. Draw a selection rectange

/ around the area of interest. Click and
pf)se ‘dlsplays a {‘ectangular draqg within the rectangle to re-position.
Vlerl’lg port Of lmage ] upon 3 Flicker between images 1 & 2
image 2 @) Superimpose image 1 rect on image 2

Image 1: [ Sin_classes_CC... v |
Image 2: [ r49_g35_b18_r... v |

Flicker rate: per second

[ ok ]

Image 1, Six_classes..., has been selected to super-
impose itself upon image 2, r49_g55_bl18... The
resultant window is shown at left in which the se-
lection rectangle can be dynamically moved about
the window.
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Constructing/Modifying a Cube

HyperCube can generate a new image cube from existing im-

ages of the same spatial size having various pixel types (e.g., byte, ﬁgzg t:;occoﬁ.r.'."

short, long, float for gray and byte or short (3) for color). Any 'C“g;’;gr;:n‘io"”

image is a candidate including bands of an existing image cube. =

However, the new cube must be all of the same kind, either gray Color to HS.1

or color. The bands for the new cube may be already resident in S
memory or reside in a folder (see following page). The in memory Rep ace Gra\, o
technique for construction involves two steps: selecting the first imae oMt

band which determines the spatial size and adding subsequent Hlmgm'm v Z
bands to the cube. As new bands are added the pixel type of the Bircibal Comporent

cube automatically changes to accommodate the maximum number
of bits/pixel required. HyperCube can also directly convert a true Color Table. >

color image into a 3 band cube. After completing the construction
save it via menu File -> Save As..., Multiband .

Click on the first image component. This will become the first band.

Choose menu Image -> Convert Image -> Plane to Cube.

Click on the second component.

Choose menu Image -> Add to Cube... A dialog appears asking you where

to insert the new band (see bottom right).

5. Repeat steps 3. & 4. to complete the cube. Menu Image -> Delete Band
can be used to delete the current band face (i.e., first scroll to band to be deleted).

6. Select menu Windows -> Show Band List and manually set up any
wavelengths for each band (the default will be band numbers).

7. Choose menu File -> Save As... and select Multiband to save the cube.

b=

If converting a color image, an additional dialog is presented asking whether to directly
generatfe a 3 band cube (red, gr§en, bh%e) or the ﬁrsF band of a inionAloane) n b ramvarad
synthetic color cube as shown in the dialog at the right. into a complete 3band (BGR) image

L. . cube or be the first band of a

New bands may also be added to an existing image cube synthetic color cube.
file by loading the entire cube. A warning dialog similar to
that shown at the lower left will appear when the first band
is added stating that the cube will be disconnected from the
existing file, becoming an all new cube that must be saved.
After adding or deleting bands, choose menu Window -> Show Band List to edit the list

and then File -> Save As..., Multiband (use a different name than the original cube file).

[ Color Cube I [ Cam:el] H BGR Cube ]l

Select Cube and Position

Wl Adding an image to this cube will
separate the cube from its file
reference (Sirius:dr Il run03:dril) and
close all of its attached functions

Select the Cube and the position in which to
insert the currently active Image. Only Cubes
with the same spatial size as that of the Image

(e.g., plots, classify). are shown.
Cubes: drt |3 ]
e Insert band:
e @ O Last ® Before band 60
OFirst O After band 60
( Cancel ) € oK Y
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The second method to construct a cube is to have an existing set of TIFF image files
within a folder. These may have been created by a program such as MATLAB®. Each file
name must have the format: *.xxx, where * is a fixed base name and xxx is a zero padded
value in the range [001,999], e.g.,dr.001, dr.002, dr.@03,.... The numbers don’t have to
be consecutive, just increasingly ordered and may reside with other files. The files are loaded
and automatically constructed into a cube by choosing menu File -> Open As..., Bands and
then selecting any one of the ordered files as shown by the Windows and Mac dialogs below.
The first band will be the image file with the lowest number value in the folder. Note: read-
ing a list of files (bands) like this is the inverse of selecting a cube image window and then
menu File -> Save As..., Bands (see section Saving Images).

You can scroll the cube bands and use menus Image -> Delete Band, Edit -> Dupli-
cate and Image -> Add to Cube to modify it. After constructing, choose menu Windows
-> Show Band List and edit the band values as necessary before saving (File -> Save As...,

Multiband).
Look in: I 5 Desent Radiance j = EF '
|10 Lib ] drb.009 =] drb, 020 [=]DR1r
" DRLIBR, =] drb.010 ] drb.021 2] orizHOR
=] Colorkey.c2n 8] drb.011 ] drb.0zz DRIL WYL
8] drb.001 =] drb.012 =] drb.023 D orLIE. ZIP
8] drb.00z 8] drb.013 8] drb.024 Selection Poin
8] drb.003 8] drb.014 8] drb.025
=] drb.004 =] drb.015 =] drb.0ze
8] drb.00S =] drb.016 ] drb.027
=] drb.00 =] drb.017 =] drb.0za
8] drb.00F =] drb.018 ] drb.073
| 8] drb.003 =] drb.013 =] drb.030
My Network P... [§ 55 | | ﬂ
File name: Open I
Files of bipe: ﬂl
£

Windows Open As..., Bands.

Open As: HyperCube
All file types
Show: | Bands 4+
From: | [ dr Il run03 :‘]

"”_‘_'.:.'”:tmg"s - :n e .:.
| DMsV L EE db.ooz m
7 Documents * [ db.0o3
[ 2 dr 1l runo3 » m EE db.004
[~ praw " K@ db.00s
~ Everglades | & db.oos
[ for Rand * | E@ db.oo7
[ fr il runos L & db.oos
[ Ft Hood * '~ EB db.0os .
[Fl Cr Lianchiicas Metho £ Moo p 1Y P a0 4
-l | = = >

Co to:
¥ S SR TR ¥ D
Add to Favorites Cancel Open

Mac OS X Open As..., Bands.
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Color Composite

HyperCube provides a direct function to construct
a true or false color image from a cube. Menu Im-
age -> Cube Color Composite allows the user to
automatically generate a color image for the currently
active (front) image cube window and to link it to the cube for point selection and classifica-
tion (see sections Spectral Plots and Classify Functions) breaking any previously linked
color image. Two methods are provided via a submenu: Specific Wavelengths and Interval
Wavelengths. The former finds the three closest bands to the wavelengths set in the Defini-
tions... menu (see below) and the later integrates over three spectral intervals to generate the
color components. In each case the data is extracted from the image file. Disabled bands
(see section Band List) are ignored so it is possible to have a null interval and HyperCube
will warn you if this occurs. The resultant color image is correctly mapped so as to maintain
the original brightness relationships, i.e. the red, green and blue are normalized as a group.

Choosing menu Image -> Cube Color

Embed Wavelength

Cube Color Composite » Specific Wavelengths
Interval Wavelengths

Definitions...

Composite -> Definitions displays the Composite Color Wavelengths
: . : Enter/change the specific or interval Red, Green and Blue

dlalog ShOWIl at the I'lght. If the lmage CU.be wavelengths. Histogram Equalization produces a non-linearly

header ﬁle Contains “CO-I.Ol"...” keywords distributed color image, while Remap % maintains the linearity.

(see section Keyword Format) then they e Ll RSB S000  faesi 700

. . . ;1545 i -

appear in the dialog edit fields else the Sl Green Interval: 500 ___Ito [600

Blue: 460 Blue interval: 400 to 500

initial wavelength values for the Specific
wavelengths red, green and blue component
bands are 646, 545 and 460 nm (or x#m)
respectively. These correspond to a set of
Kodak® color separation filters and may

be changed by editing the dialog fields. Interval wavelengths values are similarly entered
specifying the spectral range of integration to be used to form each color component. Note,
identical or overlapping values are allowed. The Remap % determines the area about the
median of the composite histogram that will be remapped to the [0,255] for each color. A
good starting point is 98%. Use histogram equalization performs a nonlinear stretch of
the components and is useful when the image cube has an asymmetrical histogram. Changes
may be incorporated in the image header file upon closing the dialog and selecting menu
Window -> Show Band List, Save hdr... (see section Band List).

If menu Edit -> Options -> Detailed Messages is checked then the composite histo-
gram of the three bands is generated. This is similar to the histogram described in section
Statistics except that it represents only the three bands or band intervals. A typical compos-
ite histogram is shown below.

) Use histogram equalization
® Use Remap %

Remap: 98 %

{ Cancel )

EN== Bands r49,935,b17 Statistics =——
Min: -26 Mode: 72 Rernap low: 14

Bands 49, 35 and 17 were automatically
B e SR e selected from the active image cube file to
' form a composite color image. The histo-
gram highlight represents 98% of the data
in these 3 bands. File values between 14
and 223 will be remapped to the display
-2 Bands 149,935,017 Histegram 684 range of [0,255] for each color.

coords: (1,10 -01,1), bands: 0--1
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Spectral Plots

Two methods of plotting spectral vectors
from an image cube are provided: statically via F'Iuhe
Functions -> Plots -> Spectra (Selected Flicker/Superimpose...
Points) or Functions -> Plots -> Spectra St =

Utilities Windows

(Dynamic) as a fgnctlon of the cursor position. —
The former, described here, allows up to 128 : _ HistograraiNBkeal

ints to be plotted al ith lib ; t AHERMEHC. Spectra (Selected Points)
points to be plotted along with library signatures E;_enay Color... " Spectra Oynamio
superimposed upon the same plot (see section L

Scatter...

Spectral Classifications). The later allows the Sha s
simultaneous display of the closest matching "'”"”"I
library signatures to the current cube vector (see Dynamic Displays and Plots in Spectral
Classifications).

Points are selected by positioning the cursor and clicking the mouse while holding down
the shift key. This draws a numbered colored cross hair on the cube face. The Plot window
need not be open when points are selected and if no plot points exist when a Plot window is
opened it will contain a message indicating what to do. If the wavelength file is incorrect no
plotting is possible and the Plot window will contain a warning to that effect. Having the
Info window open while you select points facilitates the process by dynamically showing the
spatial coordinates. As points are selected they are graphed in the Plot window along with
a color patch used for toggling them on and off. The number of color patches that can be
toggled is determined by the size of the Plot window, resizing the window (lower right grow
icon) displays more patches. All of the points can be erased at one time by choosing Clear
from the Edit menu or selectively in the Classify dialog. When the cursor is positioned over
a static Plot window the spectral and reflectance coordinates will be listed in an opened Info
window.

The static Plot window contains several controls for customizing the plots: three check
boxes, a standard button and dynamic colored push-buttons that toggle on and off their
matching color plots. Cube bands that have been disabled in the wavelength file have a red
highlight superimposed on them. Controls have the following definitions:

Scale: Rescale the vertical plot axis between the minimum and maximum of
all of the vectors. Otherwise, the minimum and maximum will be set
to the arithmetic range of the pixels.

[0,1]: Change the vertical axis labelling to the range [0,1] and map the plotted
values to it. Also see Scaling... example below.

Hide Bad:  If checked then suppress the plot wherever a band has been disabled.
See section Band List.

Clear Lib: ~ Remove any superimposed library signatures.
Plot->drll
Enter new minimum and maximum y axis
. . . limits to replace those in the current Plot’s
listogram When a plot window is active [0,1] check box. The x axis wavelength
HctooiairiMaskod . range may be changed by editing the Start
BOgraE A en), Scaling may selected from the e e
Spectra (Selected Points) .
Spectra (Dynamic) Plots submenu to produce a dia- Miny: [0 Start band: |1
SCAHEr log window which will result in Maxy: |15 End band: 210

[0,1] changing to [0,1.5].
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ElI=———— Plot—datala ="————=05

595
¥

0424
0370
0._306
0.242
0179

0115 [

0.051

434 498 562 626 689 T35 817
Yavelength {nm}

X scale  [©10,1] [ Hide Bad @

Four spectral plots from the 70 band
image shown at the right. Each number
corresponds to the numbered cross hair
in the image. Several bands at 750 nm
have been disabled in the wavelength file
due to a sensor error. These points may
also be selected from a linked red, green,
blue composite image constructed from
cube bands (see section Components to
Color).

EI=——— FPlot>rund3_1000 =—————[15

1.000

0.833

0667

0.500

0323

=
o

OO0OEEEOOEC N

0167

md
LU

0.000
397 T47 1096 1446 1796 2145 24935
¥avelength {nm}

Oscale  [K10,1] [ Hide Bad Clear Lib

[

=[[I=———— dataBa EEEI
Band 40 aof 70: 650 nm

A different image cube spectral plot after
resizing to show all of the corresponding
color patches. Numbers 2 and 11 have been
toggled off. Because Hide Bad is checked,
plots within the two major water absorption
regions are not drawn (disabled in the Band
List). The correspondence between a point
number and its color may be changed using
the Color Selector item in the Options menu.
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Selection Point Colors

When HypeCube is launched the correspondence between a selection point number
and its color is set from an internal default table that will be used when plotting spectral
signatures and classifying (see Products in Spectral Classifications section). The color
sequence is arbitrarily repeated in groups of 10 with each group slightly different in value.
Therefore, although points 1, 11, 21, 31,41, 51 and 61... appear as the same red, they are
not. The point # to color correspondence can be customized at any time by choosing menu
Edit -> Options -> Color Selector. Up to 1024 colors may be uniquely redefined. When a
change is made all windows using selection point colors will be updated to reflect the change.
Classify output products that have already been generated will not be changed (Overlays and
Masks will use the new color on a subsequent classify). However, products can be reas-
signed colors and labels after the fact by using menu Utilities -> Color to Name Editor (see
Dynamic Displays and Plots). A color that has been copied to the clipboard can be pasted
as the selected color (see section Copy, Paste & Duplicate). Also, see Classify -> Options
-> More Options -> Use source spectra color in section More Options as an alternate
method of specifying class map colors.

86N Color Selector

Click a color, adjust sliders and Set Patch Color patch #30 has been selected and the sliders

1 2 E 4 3 & i, g .

E DN D DN NN adjusted to a new color. The components of each color
i) 10 i1 12 13 14 15 16 . .

OO N E NODE H are shown to the right of the sliders and range from 0
E R0 OEONCD to 255. You can not select a gray value (i.e. all three
EEEEDOOSGS colors with the same value). The Selector will auto-

(5>) (specoy ) (mangeizo) ) | matically modify the blue value to be different.

Red m—f— 1 05
Gresn emme @ 51 i:\ Current palette color.

[ — —
E T New palette color.

(" Default \ ( toad.. ) / save... ) [ SetPatch \

To change a single color click on its patch to highlight it (a small frame is drawn around
it) and adjust the three sliders for the desired color. The top half of the palette shows the cur-
rent patch color while the bottom half of the palette changes to show the new color.

<< >> These buttons are used to navigate through the 1024 colors moving
forwards and backwards 32 colors at a time.
Spec (N) Generate a rainbow spectrum in the first N colors ranging from red

through yellow, green, cyan and blue. N is the currently toggled color
patch. If no patch is selected then N will equal 1024.

Range (1:N) Generate a smooth range of colors between the colors in patches 1 and N.
If no patch is toggled then 1024 colors will be generated.

Set Patch ~ Change the patch color to the new palette color and update all windows.

Default Change the selected color patch to its original HyperCube launch color

and update all windows. If no patch is currently selected, a dialog

appears asking you if all patches are to be set to their defaults.

Save/Load... The current color key correspondence is saved/retrieved to/from an
ASCII file. The output is the same format used in the Color to Name
Editor, i.e., red, green and blue values followed by a name which in this
case is the index number. The default file extension is “c2n”.
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Spectral Libraries

Format

The HyperCube program currently recognizes 3 types of spectral signature files: a signa-
ture format developed at USATEC, the NGA NEFDB (Nonconventional Exploitation Factors
Data Base) and a simple list of wavelength and value pairs. One signature file represents the
spectra of a single material. A set of signature files constitutes a library of materials. The
various signatures belonging to a library do not have to be related in any manner, they are
often grouped together to correspond to a particular sensor run.

The format of a USATEC signature file is defined as: a small header followed by an
ordered set of linearly spaced reflectances. All of the elements are in ASCII text and can be
easily edited in a word processor or spreadsheet application. Almost any ASCII text file can
be read, edited and resaved in HyperCube, including signature files (see section Loading/
Saving Text Files).

A library is a text file whose elements are signature file names, i.e. a library contains
no data except file names. The library file and all of the signature files must be in the same
folder.

The relationship between the library elements in the USATEC library is depicted below:

Each spectral signature, regardless of size, uses the following format:

El=——— ASPECDAT1 ="———5

JUOH19E.005 413 ftems 7963 ME indisk 2559 ME availabl junl JatR. 006

JUH19E 006 r N £

JUH19E .007 = B = 350

JUH19E 005 alibrary lib JUNTSB.00S JUNTSB.006 JUNT3E.00 2500

JUH19E 014 4 . . 5

JUH19E 016 0

JIIH19E 017 JUNTSE.O1E JUNTSED17 JUNISED1S JUMISE.D ]

JUH19E 018 3 3 0

JUH19E .019 ]

J'LTNIQB |:|2|:| JUNTSEB.0Z22 JUNZOA.001 JUNZOA.0DZ JUNZOA O |:|

JUH19E 021 - : . - 9.091973

JUH19E 022 9.406374

J‘UNEDADDI JUMZOA.006 JUNZOA 007 JUNZOADDS JUNZOA DO9 K 9492085

JUHZ04.002 = 9. 896400

JUH204.003 10.59715

JUHZ04.004 ) . 1153259

TITH204 005 A window of the folder consisting of 412 spectral 12 64317

JUHZ04. 006 ; : i ; 1470555

e szgnqture files ar'zd the library file, 'Allbrary.llb. T

JUTH204.005 Portions of the library file and a signature file text 21.18135

JUH204.009 . . 25.16871

TOH204 010 are shown at the left and right respectively. e £16ad

JUH204.011 2534675

JUH204.012 25. 10887
Alibrary.lib file with an This USATEC spectral sig-
entry for each signature nature file contains a total of
file name. 431 = (2500-350)/5+1

reflectance values.
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Line:

—
SOOI N B W

11
12

N
438
439

440
441

Parameter: Example:

File name jun19atR.018

Spectrum number 18

Starting wavelength (nm) 350

Ending wavelength (nm) 2500  fines 3,4 and 5 implicitly
Wavelength increment (nm) 5 determine the number of
Scan index number (hr) 0 reflectances.

True solar time (hr) 0

Solar azimuth (degrees) 0

Solar azimuth (degrees) 0

-- not used -- 0

First wavelength reflectance (%) 11.15

Second wavelength reflectance (%) 11.05

N-10" wavelength reflectance ~ ## ##

428" wavelength reflectance 25.27

429" wavelength reflectance 26.61

430" wavelength reflectance 0 These last two measurements
431" wavelength reflectance 0 are filler in this example.

For USATEC format spectra HyperCube only needs the information in lines 3,4 and 5
plus the reflectance values.

An alternate format of a spectral signature is simply a list of wavelength and value pairs.
The wavelengths and values can be in any units as long as the wavelengths are increasing.
Each pair should be space or tab separated followed by a carriage return. HypeCube deter-
mines the format of a spectral signature by first trying to parse it as if it were in the USATEC
or NEFDB format. If that fails it assumes it is wavelength, value pairs. An example of the
later is shown below.

399000000 O.02S000-

Wkﬂ%ﬂengﬂw"”’/’/’ 402000000 O, 027000 555555555“~‘&dues
405 . 000000 0. 012000
405 . 000000 0. 023000
412 .000000 O.02 1000
415. 000000 0. 024000
419000000 O.02S000
422 000000 O, 022000
426 . 000000 O, 027000
429000000 O.029000
433000000 O.022000
437000000 0. 035000
440000000 0. 034000
444 000000 O.025000
445 . 000000 O, 036000
452 000000 0. 039000
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Plotting Signatures

Viewing a spectral signature requires first opening a library by choosing Open As...,
(Library) from the File menu. This brings up the standard Mac file dialog showing only text
type files. Select the library file containing the signature names (Alibrary.lib in the examples
so far) and click Open. A new sizeable window containing a scrollable list of the signatures
within the library will appear. Click on any signature name, select Plot Selection and a sub-
sequent window, also resizeable, will open showing a list of reflectances with the correspond-
ing graphical plot. The average of two or more signatures can be plotted by double-clicking
the desired signatures, setting Average selections and then the Plot Selections button.
Double-clicking an item toggles its checkmark on and off. The plot range displayed for any
particular plot can be modified by choosing menu Functions -> Plot -> Scaling .

E0== Alibrary.lib =HZ EI=———- JUN20B.DY Spectra =———"o0117
. . Doutilegclick tuilunale W length Reflectance i
Double_cllcklng an Items selected: 1 / 12459 e — JUNZOE.O042
. . 55 JUN20E.046 1250 0eian
item toggles it on SE JUNZOE . 047 1555 oeiaT n7s W
57 JUMZOB.042 1260 06254
so that an average ¢ 58 JUNZOE. 040 1265 0232 4 050
. . 59 JUNZOE 050 1240 06210
of all items with a 50 U208 051 160 06z A
61 JUNZOE.052 1285 0E2z0
checkmark can be 62 JuZ0B 053 B
63 JUNZOE.OS4 D Scale D 108 350 a88 1425 1962 2500
PlOtt€d~ []Average selections E
.
Scroll to each signature of interest, The corresponding signature to the
click on it to highlight it, and then library list after clicking in the graph at
click the Plot button. the 1265 nm position.

Spectra plots have two check boxes that affect the appearance of the graph. The Scale
option toggles the vertical axis (reflection) of the plot range. If unchecked the range is fixed
to [0,1] else it is set to [min,max] of the reflectances of the viewable graph. The second
check box, 10X, expands the horizontal axis 10 times centered upon the current spectral
marker, if any. Clicking within the graph area sets the marker and forces the list to scroll to
the corresponding wavelength. Conversely, clicking the list sets the marker within the graph.
Spectral plots may be printed by choosing Print... from the File menu and a snapshot of the
window can also be copied to the clipboard. The list contents can be written to a file in the
form of a library (see section Spectra Libraries) by selecting Save from the File menu or
copied to the clipboard via Edit -> Copy.

SE=———— JUNZ20B.049 Spectra E—EE_____ Line 1 ofthe signatureﬁle.
w'length Reflectance JUNZOE 043 /
1245 0e1gs i
1250 06192
1255 05197 B
1260 06254 \\ . . .
i (V7 084 Click within the graph to set the
1z Dezzo i wavelength marker; the matching
1285 06230

e list element will be highlighted.

1165 12182 1270 1322 1375

[ Scale (<108

F
The previous spectra plot example \

Click and drag icon t. ze.
repeated with both check boxes set. el ana arag icon to resize
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Superimposing Signatures

If HyperCube is running in system 7.5 or higher then the Mac’s “drag and drop” feature
can be used to overlay signatures on a common spectral plot. First open a multiband image
and choose Functions -> Plot -> Spectra (Selected Points). Then click the mouse in a
signature plot and while holding down the mouse drag the rectangular outline, which will ap-
pear, over the spectral plot graph and release the mouse. The signature will then be plotted
in black superimposed with any selected cube points and will have its own toggle button. Up
to 8 signatures can be “dropped” on the spectral plot window. The signature will be re-sam-
pled to match the range of the multiband image.

EEI

JUNZ1B.060 Spectra

' length Reflectance JUNZ1B.O&0
o nhel? EF] Plot->run03_1000 [E
60 0.0563 646
To ooems T T 1-000 |
o oown I 1 [EEEE
85 0.0564
330 0.0546 ! Drag \ 0.667
350 a88 1425 1 9‘62 2500 \
[JScale []10H 1 0.500
1 [}
e e e 0.333
0167
o000
397 747 1096 1446 1796 2145 2495
wavelength {nm}
O Plot->run3_1000 S]] [scale [I0,1] [] Hide Bad &
734
1aoe = 1 Click and drag the outline of the Spectra graph
L1 .
R over top of the Plot window and release. The
0667 . .
| signature will be plotted at the same scale and
0.500 . . . .
M resolution as the existing image cube vector
0.333
plot as shown in the composite at left. Note
0.167 .
0.000 -~ that a toggling button, L1, has been added to
e D e the plot for the dragged signature.
Cscale [A[0,1] [ Hide Bad B
e
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Spectral Classifications
General Algorithms

Spectral classification is the process of segmenting a multi or hyperspectral image into
regions of similar spectral statistical characteristics or of finding the best match between pix-
els given a specific metric. HyperCube is designed to perform both. For example, Mahala-
nobis classify uses previously extracted statistical classes and decides which class, if any, a
pixel belongs to, whereas Vector angle directly compares image pixel vectors with selected
pixel vectors. The criteria of a match is the closeness of the comparison. This is a function
of the algorithm used to define the closeness and HyperCube provides several from which to
choose. No one algorithm is always better than the others. Some are very sensitive to noise,
e.g., Mahalanobis distance, derivative difference, and others, e.g., Euclidean distance, are
not. The best technique is to experiment.

Listed below are the algorithms from menu Functions -> Classify along with their arith-
metic definitions. Summation extends over all enabled bands (see Band List).

Abs diff 2 abs(reference - signature).

Corr coef Covariance(reference,signature)/(sd(reference)*sd(signature)).
Deriv diff 2 abs(delta(reference) - delta(signature)).

Euclid distance Sqrt(Z (reference - signature)?).

Fourier Compare corresponding harmonic terms. See Options.

Fourier (no DC) Same as Fourier excluding the zero (average) harmonic.
Fourier phase Compare only the phase of corresponding harmonics.
Fourier phase delta Compare the phase differences from harmonic to harmonic.

Kmeans Unsupervised classifier that segments an image into a user
specified number of classes.

Mahalanobis classify  Statistical difference between each image vector and the mean
vectors of a set of covariance matrices.

Mahalanobis distance Statistical distance between reference points and image points.

Mahalanobis list A listing of the statistical difference between reference points
and the mean of a set of covariance matrices.

Matched filter abundance Generate a gray shade output image consisting
of projections of the source data against a constructed
matched filter of a signature(s).

Matched filter mask Generate a mask over the image cube wherever the
abundance exceeds a set tolerance (see description
on next page).
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Template Max(abs(reference - signature)). Useful for finding very
similar signatures.

Vector angle N-dimensional angle between reference and signature.

Closeness is defined differently for each of the algorithms. Euclidean distance uses
minimum as the criteria whereas the correlation coefficient approaches 1 for the best match.
This is automatically taken into account by HyperCube but it is not possible to equate the nu-
meric values of one method with corresponding ones in another method because the distribu-
tion of each method is totally different.

It is important to remember that a classification extends only upon bands whose status
is Enabled in the Windows -> Show Band List and is spatially confined to any selection
rectangle. The Band List makes it easy to test the contribution of a given band by running a
classification, enabling/disabling the band, and rerunning the classification to see the effect.
Any statistics required by the algorithm will automatically be recomputed.

Specific Algorithms

Matched filter abundance does not use a tolerance, instead it directly generates a data
image where each pixel has a value approximately in the range ~[-2,2]. It is possible to have
numbers greater than 1.0. If the pixel used as the matched filter signature is also part of the
classification region then it will have a value of exactly 1 at its position within the output im-
age. The matched filter and abundance are defined as:

matched filter = (cov)™! (signature-m)/((signature-m)™ (cov)! (signature-m))
abundance = inner product of each data vector minus m and the matched filter.
where:

cov is the NxN covariance matrix of N bands of imagery

m is the Nx1 mean data vector

signature is the Nx1 pixel vector, N being the number of enabled bands.

Note that the denominator is the Mahalanobis distance between the signature
vector and the mean vector.

When Matched filter is chosen as the classify Method the program must first compute the
band to band covariance of the enabled file bands of the image cube or the corresponding
subimage selection rectangle, if any. The determination of the statistics region is via Clas-
sify -> Options -> Stats Region (see Mahalanobis description, next). The computation is
done once and the covariance matrix remains the same even if the current selection rectangle
is moved or a different selection rectangle is drawn. This allows the statistics for the covari-
ance to be generated for an image region other than the area chosen for the matched filter
classification region. To force a recomputation of the covariance choose Classify -> Op-
tions -> Redo stats. Also, changing the state of enabled/disabled bands in menu Windows
-> Show Band List will cause a recomputation of the statistics on the next classify.
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Mahalanobis distance is a generalization of Euclidean distance that uses the statistics
of the imagery. Specifically, the Mahalanobis distance squared between 2 vectors, X and Y
is defined as:

D=(X-Y)! (cov! (X-Y)
where:
D is the resulting scalar (i.e., IXN times NxN times Nx1 matrices)
X and Y are each pixel vectors of length N
(cov)'1 is the inverse covariance matrix of N bands of imagery
and N is the number of enabled bands.

In HyperCube, X and Y are defined by the various Mahalanobis classify methods as:

Mahalanobis classify - X is each image pixel vector.
Y is the mean pixel vector of the region used to generate
a covariance matrix. There can be one or more regions, each
producing a mean vector and covariance matrix. Classification
involves computing the Mahalanobis value of an image vector
for each region and choosing the region (class) with the
smallest value within a user supplied tolerance. Selection
points are not used. Regions are defined by user selection
of a mask image in Classify -> Options -> Stats Region.
The statistics (covariance) are automatically generated by
HyperCube based upon the mask definition.

Mahalanobis dist - X is each image pixel vector.
Y is one or more selection points.
The image statistics are the same as defined for Mahalanobis
Classify except that the mean vector is not used and only
one statistical region is used. This produces the statistical
distance between one or more selection points and an image,
not the distance between the statistical class mean and image.

Mahalanobis list - Same mathematics as Mahalanobis Classify except selection
points are used and the output is a numerical listing
showing each selection point’s distance from the mean vector
for each of one or more classes.

Class names are those names that ap- ®06 Pt vs Mahalanobis Class
pear as the cursor is moved across the e . . L . .
1 18:?621 12.4872 22.6941 17.5496 62.82688 116.485
class map that was used to generate 2 14.3019 12.8932 28.4360 12.8012 58.3139 181.791
. . . 3 15.1254 15.3763 30.6713 19.44% 51.9883 99.5439
the statistics classes. Also, note their S la.ean 17.e811 130533 213416 14.298 18,02
. . G 151468 19.8145 11.6841 23.7932 11.2181 16.1463
order. In this case the points them- |
selves were used to create the class 4
map so the minimum class matches Six selection points and their Mahalanobis
the point number. value for each of six statistical regions.
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The image area used for computing the covariance matrix depends upon Classify -> Op-
tions -> Stats Region. This displays the dialog shown below. There are 4 ways to define
the regions. The first type computes the covariance statistics using all of the pixels within the
image cube or a portion if a selection rectangle is present. The remaining three methods use
an image mask. The pixels used for generating the covariance statistics are determined by an
intermediate image mask that spatially matches the image cube. A simple way to generate a
Class map image mask for the fourth method is by using the Classify function itself (e.g.,
select image points followed by method Vector angle). Classify can also be used to gener-
ate a detailed zero, non-zero mask by selecting image points, toggling neighborhood points
and choosing Form Neighborhood Mask Image in the Classify dialog.

Statistics are automatically computed when the Classify button is executed (section
Classify Function) if there has been any change in the Classify -> Options -> Stats Re-
gion -> Select Image Mask selection. They remain in effect so that a different area on
the image cube can be used for classification based upon the same statistics. Also, any en-
able/disable change in a band list (see section Band List) will cause a re-computation of the
statistics. Button Classify -> Options -> Redo stats forces a re-computation and is use-
ful if the selected image mask was generated as a class map sequence (see section Classify
Options). Then the current class map is taken as the sequence cube face and can be used as
follows: Select a new face, Redo stats, and then Classify to see the effect of a mask change
within the sequence (saves having to repeatedly go to Classify -> Options -> Stats Region
-> Select Image Mask each time the sequence face is changed).

Some additional considerations: the covariance matrix is very sensitive to noise. Noise,
being defined here, is anything that is not representative of that class. Even a single outlier,
such as striping in the image, will skew the statistics and produce a non representative covari-
ance matrix. If the imagery is noisy then try using fewer widely spaced bands (see section
Band List). If a two state mask image is selected or in use and Mahalanobis Classify or
List is chosen as the Classify Method then the outputs reduce to one statistical class.

The covariance, its inverse and the mean vector for the selected region(s) can be dis-
played by checking Output region... in the Statistics Region dialog. If already computed
then check Redo stats in the Classify -> Options dialog. If fewer than 16 bands are en-
abled then the matrix results will be text windows else they will be image windows. The
matrices and plots can be saved or copied to another program.

Statistics Region

. L . . Define the image area(s) to be used to generate
Use every pixel within the image or selection rectangle. | |the statistics for the Match Filter and
Mahalanobis classify methods. Optionally,
output the covariance matrix, its inverse and the

Skip image pixels wherever the mask has a zero, use corresponding mean vector for each region.
image pixels wherever mask is not zero. Produces a Gt .

. . L _ Use image or selection rectangle
single covariance statistics class.

Indirectly via an image mask defined as:
) Two states: zero(0) and non-zero(1)

Skip image pixels wherever the mask is gray (including | = 1, states: gray(0) and color(1)
zero) and use image pixels wherever mask is color. Also @ Class map: not class(0) and class(1)
produces a single covariance statistics class. okt tbtcniiidis
Output region statistics (cov, covi, mean)
v

Mask must be a class map (section Image Products).
Each color produces a covariance statistical class.

(" Cancel ) € oK)

Output covariance, its inverse and mean vector
each time new statistics are generated.
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K-means is an unsupervised classifier that does not use any selection points and re-
quires minimal input. The algorithm segments the image into n classes by initially guess-
ing the mean vectors of the n classes. It then scans the image and determines (using one of
the four classification metrics listed below) which class each image vector belongs to and
a corresponding set of new mean vectors. This procedure is repeated until the number of
image vectors that changed classes is below a certain minimum or a maximum number of
iterations has occurred. The number of classes and both termination criteria as well as other
parameters are user selectable. Choosing Options in the Classify dialog while the classify
Method is Kmeans displays the dialog shown below (note: the Options dialog associated
with Kmeans is different from the options shown for the other classify algorithms).

See section Image Arithmetic for an example of combining a K-means classification
and the gray values of a specific band using the hsi() function.

The number of desired classes is limited to 500
or less. The actual number of classes generated

may be less than the number requested. Use K-means Options
menu FunCtiOl’lS -> PlOt -> Histogram on the K-means estimates the class mean vectors

and then repeatedly updates the means until

ClClSSlfy output to list the classes. \ max iterations or convergence.
Enter:

[~ Number of classes: 16
A Progress window dynamically displays the | Maximum # of iterations: |50
iteration count and the number of class chang- Convergence # of changes: 0 |
es. When the number of iterations reaches this ™ Collect iterations into a sequence

E Plot final class mean spectra

value Kmeans classify stops and outputs the S T T
results up to this point. T T
Euclidean distance 4 ] A
When the number of class changes is less than or U;‘Ei*;ti":;“ means as class colors:
equal to this value classify terminates. ™ Intensified
((Cancel ) ok

Correlation coefficient

Various metrics popup menu. | Derivative diff, delta:
¥ Euclidean distance

Vector angle

Remaining options:

Collect iterations:  Each iteration (classify) is assembled into a class cube that can
be scrolled to view the convergence sequence.

Plot final class...  Each mean vector forms a spectral plot window.
Save final class... The final class mean vectors are saved as a spectral library.

Classification metric ~ The algorithm that is used to determine which class an image
vector belongs to by comparing it the mean of each class.

Use final class means as class colors:
Natural - Determine mean class colors directly from mean vectors.
Intensified - As above, but intensity the color.
Red, green, blue wavelengths are determined by menu
Image -> Cube Color Comp -> Definitions.
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Classify Function

The HyperCube vehicle for spectral classifications is initiated by [Functions REL R
choosing the Functions -> Classify menu and is available whenever a e
cube or a linked color band composite window is front. Each image cube [ gstics >
can have at most one Classify window. A classification scenario has Plot >
three basic steps: decide on the signature to be matched (what to look il
for), choose the search domain (where to look), and pick the method (how | Adiacency 4

to look). The output product is determined by the domains and numer- AT

ous options. The simplest classification is to shift-click on a point in the SNSRI
image cube window, double-click on it in the Classify list, choose one or

more neighborhood points and generate an overlay image of the current Search Domain
cube face band using Vector Angle as the Method. This is the default setting of the Clas-
sify window and does not involve a library. A Classify window is logically connected to its
image cube and closes when the cube window closes.

As you select cube points their coordinates are added to the Classify list. These points
are then used to reference one or more surrounding neighborhoods from which you can
toggle one or more signatures to be averaged together. The list coordinate is the central
pixel in the neighborhood and has the same color as the cube selection point reticle but with
a transparent interior. It is also the same point that is graphed if a plot window is open (see
Spectral Plots). By clicking the mouse within the neighborhood, points may be added or
removed from the signature mean. Shift-clicking adds or removes a rectangular region be-
tween the shift-click and last non shift-click point. Any combination of neighborhood points
is allowed. If more than one pixel is toggled-on then their mean is formed. Multiple neigh-
borhoods are selected by double-clicking each list point number. Clicking the Plot Mean
button produces a graph of the resulting signature and this graph may be superimposed upon
an open spectral Plot window (see Superimposing Signatures).

The neighborhood image is generated from the band currently shown on the Signature
cube window and therefore will change as the cube is band scrolled. However, if a linked
color image has been constructed from cube bands (see sections Components to Color and
Color Composite) then the neighborhood is extracted from the linked color composite.

806 Classify->Malpais The Search Domain
An 11 by 11 nelghborhood\\ MSzi:‘;;aitsure: SelzraciD::main: — does not have to be
furroundmg the se.lected & e in the same cube as
image cube coordinate. Ubrary Library the Signature which
(" Load Lib... ) Lib: (none) . d h l
7 e - s fixed to the selec-
All four list points haveT sorows 7o Form eighbrhod Waskmage ) t'ﬁ int cub
— on point cuoe.
been selected as the iz —— g
v3 78 143 ———
. . . | 4 1@@ 272 | Options... 1 Lib Key
neighborhoods in which ' —_— s
.. . [ load Pts... ) [ Save Prs... | Abs diff
addltlonal pOlntS may : Classify mean of + points Corr coef
- T TT— ) Classify each v point Deriv diff
be toggled on tO fOrm a {w—\ o Euclidean distance
mean signature for each Method:  (Vector angle B ( casiy ) Fourier
. hb h d Cl' k' Fourier (no DC)
neit ornood. ICKIn Fourier phase
g . g Fourier phase delta
once on point number 2 K-means
. . . . Mahalanabis classify
h’lghllghts i and dlsplays Mahalanobis distance
ilS nel‘ghborhood Mahalanobis list
: Matched filter abundance
Matched filter mask
Template
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The following is a description of each Classify window control.

Signature: The signature source is always taken from the point selection cube and
its name is shown beneath Signature. The only exception is when
Library is chosen (see below).
File Use a selected signature from the image cube.
Library  Use a selected signature from the current library as the signature.

Search Domain: The popup menu beneath this title is used to select the cube in which
to search. The Search Domain does not have to have the same
spatial or spectral dimensions as the Signature source. A different
cube is only permitted when Signature and Search Domain are
both set to File. Also see Library below for another exception.

File Match the selected signature against image cube signatures.
Library = Match the selected signature against all signatures in the library.

Method: Popup menu of available search algorithms.

Library... Open a standard file dialog to select the library to use. The name
of the library will replace Lib:(none) in the Classify window.

Lib Key Active after a library load. Generates a window showing the
correspondence between a toggled-on library item and the
color that will be used in the classification. See the later section on
Products and earlier section Changing Selection Point Colors.

Form Neighborhood Mask Image:
A separate gray image is generated spatially matching the current
selection area and having 255 gray values at each toggled selection
point and neighborhood with zero elsewhere. See ROC Curves.

Plot v Generate a spectral signature plot of toggled-on neighborhood points.
If Classify each V point is checked then the plot will contain each
neighborhood and their mean. If Classify mean of v points is
checked then one mean of all the selected list points and their
neighborhood points is formed and plotted. If Method is Fourier
then the plot is pre-filtered.

Options... Open the Classify Options window.

Delete Pt # Delete the highlighted selection point from the list and move lower
points, if any, up. Also affects any current plots.

Load/Save Pts...  Save the current list of selection points including their
neighborhood definitions. Upon loading all points are
automatically toggled on.
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Save Sig... If Signature is set to File, then the currently toggled on selections
can be saved as a spectral signature of raw values, as a new library
or added to the currently opened library. The following dialog is
presented.

Save Signature Options

If no library is currently attached to the Classify
then only the 'Data vector' option is possible, If
scaling is unchecked then the data vector remains
in cube file values.

Save signature(s):
* As Data vector(s) (wavelength, value pairs)
Make a new library and add vector(s)
@ Scale values to [0,1] range

Resampled and scaled in the current library

| Apply Fourier filtering (limit bandpass)
| Zero disabled band values

( Cancel ) o)

Classify mean of v points

Classify each V point
These form a pair of mutually exclusive radio buttons that determine how
the toggled-on ) points are used in the classification process. The default
is Classify each. Then each v point generates a classification region in
competition with the others. That is, cube pixels are compared with each
point and the closest point is defined as the proper classification. The
program requires that the classification criteria be set to Threshold in the
Classify Options dialog. If no point matches within the Threshold then
that pixel remains unclassified (see the next sections, Options & Products).
If Classify mean is chosen then all of the v points are averaged together to
form a single mean signature that will produce a singe classification region.
Any classification criteria may be chosen in Classify Options.

Note that if there is only one v point then either of these choices will produce
the same result if Threshold is the criteria. Also, any v point that has
multiple neighborhood points selected will still form an average of that
neighborhood to represent the signature of that v point regardless of the
choice here.

The color that is used to delineate classification regions is the same as each
selection point color for Separate and the color of the first selection for
Mean. The colors can be changed using the Color Selector described in
section Changing Selection Point Colors.

Classify/ROC Curve:

Perform either a classify or ROC curve. This button toggles between these
two as a function of the ROC curve checkbox in Classify Options dialog.
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Classify Options
Pressing the Options... button in the Classify window opens the following window.

Classify Options
— Selected Method Parameters

Each classify Method has a theoretical math- Mahalanobis (no param) A ] O Redo stats
ematical range and is shown along with any Classiy sach image pixsl ageiost e g sremegionm)

or more Mahalanobis classes. SR
parameter that must be set for that Method. — Classicaion Watch Ceiteria

@Threshiﬁd, Enter tolerance, [best,worst]: 0.08

. Lo Percentage, Enter tolerance, [0, 100%] 10
There are 4 ways to compare a signature within Esunldistribition. Enferclisses Zetb-s ]
the search domain. If Classify each is set then Countable, Enter N closest, [1,32767):  [40
. . . — Classification Qutput(s)

the criteria will be forced to Threshold. St e

@ Color image (cube face shows where no match)

The output format is determined by these radio { Generate a sequence, Enter # of outputs:  N/A

buttons and the checkboxes. WL =
MJA ROC Mask..
. . — Library Parameters
The number ofSlgnatures fo llSt when MNfA Closest library matches _ | Lib:File match lists
Search Domain is a library' _lignore the Disabled Bands List in Lib:Lib searches
| Enable dynamic display in File:Lib searches
If enabled then each spectral signature is fil- s e
. . . . |_| Enable spectral wavelet denoising Parameters
tered based upon its energy distribution before
being used in a classification or plot. Fomeid risreoptions=) Okay

Selected Method Parameters:
This section shows the currently selected classification Method and allows you to change
a specific parameter associated with that method. Presently, only Deriv diff and the various
Fourier methods have such a parameter and are described below. The Theoretical best
and worst tolerances refer to the mathematical closest and furthest difference between the
signature and search domain vectors. These are used to set thresholds and sequence limits
and vary depending upon the algorithm (Method). For instance, Vector Angle and Fourier
Phase range from 0 to m radians whereas Corr Coef ranges from 1 (best) to -1 (worst). The
various metric distances such as Abs Diff are normalized to the range [0,1] regardless of the
arithmetic range of the search image cube. Euclidean distance is normalized to the sqrt of
the number of enabled bands. The Methods which allow parameters are described below.

Deriv diff delta: The sample distance from signature point to point used to compute the
derivative. Generally, signatures are quite noisy and using a delta
greater than 1 provides a better indication of the true slope.

However, if there are few or widely spaced bands some important
signature variation may be skipped.

Fourier terms: The low order number of Fourier transform harmonics to be used
in comparing signatures in the frequency domain. The greater the
number of terms the finer the discrimination and sensitivity to noise.
The smaller the number the greater the filtering and immunity to noise.
A good starting point is 8 and this value must not exceed the number
of enabled bands divided by 2.

Redo stats: Available with classify methods Mahalanobis and Matched Filter.
Stats Region: Used to define the region for generating needed covariance statistics.
See description in section Algorithms.
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Classification Match Criteria:

The four mutually exclusive radio buttons in this area specify how the mathematical dif-
ference between the source signature spectra (vector) and the search domain spectra is used.
The first one, Threshold, is the most direct. It allows you to enter a tolerance in the range
given by the Selected Method Parameters section just described. Then, each computation
is compared with this tolerance and if it is between it and best then the image cube pixel is
defined to be classified as the source spectra, otherwise not. If more than one point is being
classified, i.e. Classify each, then the closest point to the best within the tolerance, if any,
determines the classification.

Threshold: A value in the range: [best,worst] that serves as a breakpoint.
Computations within [best,value] are classified, outside this range are not.
Example: if the Method is Vector Angle then the tolerance range will be
listed as O (best) and st (worst). Setting the tolerance to .08 means that
all vector angle differences between 0 and .08 will be considered to be
“classified”. The color given to a classified region is the same as the
selection point color and may be changed via the Color Selector.
Threshold is the only criteria possible if Classify each is selected.

Percentage: Generate a color image using the selection point color to indicate the
closest percentage of the entire distribution of the match. For example,
if the percentage is 10% then the upper (best) 10% matching pixels
are defined as classified.

Equal Distribution: Generate an N color output image where N is chosen by you.
The entire match distribution relative to the source spectra is
divided into N equal areas. Each area then becomes a
classification region. Unlike the other criteria, the closest region
has the color of patch 1 in the Color Selector, the second closest
region has the patch 2 color and so on.

Countable: Generate an output image with the N closest matches delineated.
For example: if N equals 50 then the 50 closest matches will define the
classification region. Good for showing very small targets.

Classification Output(s):

This section defines the form and number of output products. There are 2 types and both
produce an image. Each generates the appropriate color classification regions for the Match
Criteria listed above. Their difference is how an unclassified region appears. The Color
Mask leaves these areas black while the Color Image shows the current cube face band
where there is no classification. Both selections produce a true color image. Note that the
colored regions correspond exactly to the color currently defined for points in the Color
Selector. If the colors don’t seem appropriate for the given classification change them in the
Color Selector and redo the classification. Also, see the color note above regarding Equal
Distribution. Flicker/Superimpose is very effective in dynamically comparing a classifica-
tion output with a source image (i.e. the linked Color Composite or an image cube band).
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Color Mask: The output image has a color where a classification is define as
successful and black otherwise. The only output possible if
Equal Distribution is selected.

Color Image: A copy of the current cube face band will be used as a base image and
the classified regions will be overlaid.

Generate Sequence: If checked then the 2 tolerance values entered below the
checkbox define a range of Match Criteria in which a sequence of
classification images will be generated. The number of outputs is user
selectable. The outputs are arranged into a synthetic cube for display
(see Products). The example below will generate a synthetic cube of
10 images where image 1 represents a classification tolerance of 0 and
image 10 a tolerance of .5 (in this case radians).

ROC curve: This option is available if Classify mean of v points and
Generate a sequence are both selected. No image output is

Classification Output(s)
() Color mask (black where no match)
@ Color image (cube face shows where no match)

[€] Generate a sequence, Enter # of uutputs:

Starting tolerance: |(0.000 []ROC curve
Ending tolerance: ﬂ ROC Mask...

generated, instead a plot of the number of classify hits versus tolerance
is generated. See ROC Curves section for details.

ROC Mask...  Displays a popup menu dialog allowing you to select the
“ground truth” mask image to be used in generating ROC curves.

Library Parameters:
This last section is applicable only when the Search Domain is Library. In this case the
output is not an image but ordered sets of matching library signatures.

Closest lib matches:  You can specify how many library signatures to list
(see the Products section).

Lib:File match lists: Generates a list of the library elements found in the image
and a list of the source library elements that didn’t match.

Ignore Disabled bands:  Available when Signature and Search Domain are both
set to Library. In this case you may want to perform
matching at every spectral band value by including any
wavelengths that are disabled in the Band List.

Enable Dynamic Display: Available when Signature is File and Search is Lib.
As the cursor is passed over the Cube or Link image
a real time display of the closest library matches is
dynamically displayed. If a dynamic spectral plot is
enabled, then the closest 2 library spectra will be plotted.
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Pre-Filter:
Enable wavelet spectral denoising: If checked then each enabled cube file spectral
signature is filtered using the discrete wavelet transform.
The parameters are determined by the dialog window shown below.

Parameters...  Displays the following dialog.

. . . . Wavelet Filtering
Fllterlng can be applze.d selectlvely: Wavelet transforms are used t;pre—ﬁlterl
only file spectra, only library spectra or both. ﬁg::: ;'g:;%ucr:tﬁobnesf_oﬁeteh:yE?‘;fi;:Ed in

percentile’ of transform, zero the rest. Cube
file vectors, library spectra or both can be
The percentile of the total energy of a spectra in the pre-fitered.
. . Filter:
wavelet transform domain to keep. Generally, this @ Enabled cube file vectors
number should be very close to 100%. By displaying a O 'éi:trhar‘f spectra
cube selection point and enabling filtering you can plot Ene}’gv sercantile-to keep: S5 5600
(Classify:Plot) and drag the filtered signature onto the Eannibe bR 220 |
selection point plot window as a comparison. P
Specifies the number of Haar (2) or Daubechies (4,...,20)
coefficients to use in the wavelet transform. The greater the
number, the smoother the filtering.
QO_EB Plot->drll
744

1.000 . 1

0938 HL
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This plot, Functions -> Plot -> Spectra (Selected Points), displays a cube selection point (red)

versus the same signature (black) used for Classification with Enable wavelet... checked (see
section Superimposing Signatures). The wavelet filtering values applied are those listed in
the dialog window above. Disabled bands, highlighted in red, are not filtered and therefore
remain the same in both signatures.
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More QOptions

When performing a classification you may request several output products that can be
generated in addition to the class map. By selecting More Options... in the Classify Op-
tions dialog the following dialog appears.

More Classify Options Three options have been selected: produce a
When Classify mean ... on the main Classify ] ] 111-
dialog is selected then the following additional dljf_erence' image between the Sel_eCIed ClaSS:l‘ﬁ'
outputs may also be generated: cation point and each spectral signature within
"] Difference and histogram plots ;
e the image cube, compute the average of all

The following output option is available spectral signatures within the image, and use
regardless of the type of Classification:

the source color (determined by menu Image ->
Cube Color Comp -> Definitions) of the selec-

E Mean spectra signature plot

The following options apply the source spectra

xolorvhenrgEneratng clasmaps:histeatol tion point as the class map overlay color. The
the selection point colars:

% Use natural source color mean spectra does not depend upon the clas-
Use intensified source color . . . . .
T 7
Eaa j;ﬁcatlon points whereas the difference image
— oes.

A single selection point within the delineated area shown on the left is
used to produce the overlay type classmap appearing to the right.

Frames 5-8r Spectra4 YA Difference Hist Equal
F Ty et B
nrm Walue Mean of 47872 signatures pos e
1.00 i

399 0.0000

402 0.0000

405 0.0000 075

403 0.0000

412 0.0315 .50

415 0.0335

413 0.0332 0os

422 0.0322

426 0.0353 oon

299 924 1449 1974 2499
[ scale O 10x =

The plot of the mean of all 47,872 spectral signatures in the classification area.
Bad bands are zeroed. A plot that includes bad band values can be generated
by choosing Enable All in the Band List and then reclassifying. The difference
image (shown right) is coded so that the brightest values represent the closest
match to the chosen selection point(s) for the given classification method. How-
ever, the data attached to the difference image gives the actual metric difference
(e.g. radians for Vector angle) as the cursor is moved over the image and the
Info Window (menu Windows->Show Info) is active.
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Mare Classify Options

‘When Classify mean ... on the main Classify
dialog is selected then the following additional
outputs may also be generated:

Ebiﬁerence and histogram plots
[_] Difference image

The following output option is available
regardless of the type of Classification:

[ Mean spectra signature plot

The following options apply the source spectra
colors when generating class maps instead of
the selection point colors:

"] Use natural source color
Use intensified source color

[ Cancel )

ok

The selected option will produce two plots: The ac-
tual value produced by the Method used in the clas-
sification for each pixel and a histogram that plots

a relative frequency count of how often a specific
difference occurred. Any section of each plot can be
magnified by dragging a selection rectangle about
the area of interest and then choosing the Image ->
Magnify -> 1x menu. The magnification factor is
ignored, instead, the selection rectangle is expanded
to full size.

O

YA Values =]

1.2245300

09736640

0.7247420

0.4292320

02443160

0.0000000

1 Q023

13627

18169 22711
YA Yalue for each Pixel
Z

i

Each of the 49,970 spectral signatures is plotted against the Vector Angle differ-
ence between it and the chosen classification point shown on the previous page.
The maximum difference is 1.22 radians. By dragging a selection rectangle any-
where within the plot and choosing Image->Magnify->2x a new plot consisting of
just that region will be constructed. This may be repeated on the new plot to get

even finer detail.

VA Histogram

1] 0.1020483 0.2040967 0 2061450 0 4081922051024 7 0.6122900 0.7143284 0 B16Z2670.9124350 1 0204834 1 1225318 1.2245200)
* Pts: 49970, Mean: D.360201, SD: 0187094, No exclusions

-

This Histogram is essentially the same plot as the Difference plot reordered so that
the horizontal axis represents Vector Angle differences (in radians) verses how
frequently this difference occurred. This plot may also be magnified repeatedly.
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Image Products

Each Classify produces an image(s), an ordered set of spectral file names or an ROC
plot. The image can be a color representation of the goodness-of-fit or a composite consist-
ing of the color representation overlaid on an image background. The background is auto-
matically chosen to be the Search Domain band face so for example if band number 35 is
visible, a duplicate is made and used as the overlay base. The colors of the mask/overlay
are the same colors as v points in the classify list. If a selection rectangle is present on the
Search cube face then the classification and resultant image is limited to the rectangle size.

An output image has one or more classification regions depending upon the various op-
tions described in the previous section. The default is one region per Vv point or % library
spectra. However, if the Classify mean radio button is chosen then the average of all %
points is formed for the source signature for comparison and therefore only one classify
region is generated. Shown below is a source image with four selected points, and 2 clas-
sification outputs using the default Vector Angle Method with tolerances .08 and .8 radians
respectively. Each region color corresponds to the selection point color and can be changed
via the Color Selector (see section Selection Point Colors) or Use source spectra color
in More Options.

The utility of the classification output can be greatly expanded by using Flicker/Super-
impose in the Functions menu or compositing it with another image via Overlay Color
or using image Arithmetic. Furthermore, classifications can have labels that dynamically
change as the cursor passes over them (see section Dynamic Displays and Plots).

Four selected points
on a linked color
composite.

e i i A7
& EE

FtH23m006.020 Ovly VA 0D.80

The top right output is the result of using
the Vector Angle Method with a toler-
ance of .08 radians. The base image cube
shows through where the angle exceeded
the tolerance. The right image is the same
classification re-run with a tolerance of .8
radians which just about forces each pixel
into one of the classification regions thus
obliterating the underlying image.
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One of the more interesting products of Classify is the generation of a synthetic cube
consisting of a linear sequence of classification tolerances. For example, the Classify Op-
tions dialog shown below will generate 11 outputs ranging in tolerance from O to .1 radians
that will be automatically collated into an 11 band synthetic cube also shown below. Besides
band scrolling, most of the HyperCube functions that can be applied to a spectral image cube
can also be applied to the synthetic cube, such as: Gray & Color mapping, Flips. Rotates,
Flicker/Superimpose, Magnify and Filtering. The exceptions are Shifts, Histograms and
Statistical Measures.

Classify Options

— Selected Method Parameters

Vector Angle (no param) N/A Vector Angle is the chosen Method.

Theoretical best Tolerance: 0.00
Theoretical worst Tolerance: 3.14

— Classification Match Criteria
® Threshold, Enter tolerance, [best,worst]: N/A

_ Percentage, Enter tolerance, [0,100%]: MNJA The number Ofoutputs in the synthetlc
; Equal distribution, Enter classes, [2,64]: |N/A cube. In this instance the Output se-
C ble, Enter N cl t, [1,32767]: .
= o WA ) quence will be: 0, .01, 02, .03, .04, 05,
— Classification Output(s) .
() Color mask (black where no match) 06, 07, 08, .09 and .1 radians tolerance.

® Color image (cube face shows where no match)
E Generate a sequence, Enter # of outputs: 11
Starting tolerance: 0 — s

Ending tolerance: .1 \ RO (_|\_-"|_1_595\

— Library Parameters

/A Closest library matches - LM \ IfCheCked then a plOt Of uhl-tsn Versus

__Ignore the Disabled Bands List in Lib:Lib searches .
\ “false alarms” will be generated.

Starting tolerance of the first output.

/

__| Enable dynamic display in File:Lib searches

Bl Ending tolerance for the last output.
[ Enable spectral wavelet denaising Parameters...
( Cancel ) {"More Options... ) ¢ Okay )

Ovly 0.00 -> 0.10 VA

Shown left and right respectively are two views of the resulting synthetic cube. The left one
has been scrolled to the fifth output band in which the overlay tolerance is .04 radians while
the right view has been scrolled to the last band showing a tolerance of .1 radians.
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The classification regions of a classify image can be tabulated by selecting menu Func-
tions -> Plots -> Histogram when the image is active. The result is list of each class name
and the frequency with which it appears in the image. Zero frequency classes are omitted.
The list can be selected (normal drag selection and command-C key) and pasted into another
program, e.g., Excel®. Below is a portion of a very detailed Lib:File classification and the

histogram of the selection rectangle area within the image.

BB

22 11 EG-1, FH3b,
23 144 EBG-Z, FH3b,
24 15 BG-3, PU3b,
25 39 EBG-4, PU3b,
26 20 EBG-S, PU3b,
27 17 EBG-6, PU3b,
283 112 BS-1, Flg,
20 292 EBG-Z, Fle,
38 3 EBGE-3, Flg,
31 343 BG-1, Tle,
33 97 EBG-2Z, Tie,
33 58 BG-3, Tie,

E = (lass =: E [0 =—— dlass map count

# Count Hame

. 5 4 BG-1, asphalt, light
=] 1 BG-2, asphalt, light
13 16 BG-1, roodway, packed
14 1 BG-1, roadway, gravelly
15 1 BG-2, roadway, gravelly
16 186 BG-3, roadway, grawvelly
17 163 BG-4, roodway, growvelly

19 36 BG-6, roadway, gravelly

sand
sand
sand
sand
sand
sand
grawvel
gravel
gravel
gravel
gravel
aravel

At the left is a portion of a classmap generated via a Lib:File classification. The library con-
tained several hundred signatures. At the right is part of the histogram frequency count list-
ing for this classmap. Each library signature has multiple measurements. The first column
contains the index of the library signature in the color key. See sections: Library Searches
and Class Map Editor for a description of the class name and color association.
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E(Signatures)

Whenever the Classify dialog is active you can construct the eigenvectors and/or ortho-
normal basis of the selected signatures via menu item Functions -> F(Signatures). Either
image or library signatures must have been toggled on and Classify each... must be select-
ed. If from a library they are resampled to the enabled bands of the attached image cube. Ei-
genvectors requires 2 or more signatures while Orthonormal 1 or more. The covariance or
the correlation of the signatures may be chosen for the eigenvectors computation.  Since the
number of signatures is usually much less than the number of bands the resulting eigenvalues
and hence eigenvectors have little significance after the N-1 value where N is the number of
signatures used. Compare this with the HyperCube menu item Image -> Convert Image
-> Principal Components that uses all of the pixels within a cube (or selection rectangle)
to compute the covariance. Orthonormal uses the Gram-Schmidt method and the number of
signatures can not exceed the number of bands. Orthonormal also produces the correspond-
ing projection matrix defined as: A(ATA)'A" where A is the column matrix of orthonormal
vectors. Both methods generate matrices that are saved to a file and can be used in Ultilities

-> Apply Transformation.

Mathematically, the following matrices are produced for the particular instance of an im-
age cube with 160 of 210 bands enabled and 10 signatures.

Eigenvector matrix (Matrix.ev): 160 rows x 160 columns.

Orthonormal matrix (Matrix.gs): 160 rows x 10 columns.

Projection matrix (Matrix.pm); 160 rows x 160 columns.

Below and on the following page are examples of the Eigenvectors method and the re-
sult of applying the matrix to the original image cube using menu Windows->Apply Trans-
formation.

F(Sighatures)=—————— 0 =———Fame6=————HH

Band 60 0f 210: 750 mm

The selected Classify signatures form the basis for
constructing eigenvectors and orthonormal vectors
subspace. Classify each+~ must be chosen. The outputs
are matrix files that can be used in Utilities->Apply
Transformation.

Currently:

File source: FTH5_8
Number of selections: 10
Classify type: each

[ Eigenvectors O orthonormal vectors
@ Use covariance And the projection matrix:
() Use correlation Ax (AT x Adinverse x AT

F(Signatures) dialog set to compute the
eigenvectors corresponding to 10 Classify
signatures. The result is a matrix file. Classify selection points.
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[0 =——="Frameb Al

Band 1 of 125: 1.000 pm
1]

The left and right im-
ages are the first two
bands of the cube re-
sulting from applying
the eigenvector matrix
to the original data

using Utility Appl

0 —————=rframeb AT—=——"—=01H8

Band 2 of 123: 2.000 pm

Transformation.
- :// . E 3 ot J z ://
First principal component. Second principal component.
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ROC Curves

One type of classification output is a ROC (Receiver Operating Characteristic) curve.
This produces a plot of the probability of correctly classifying a data set (statistically not
committing a Type I Error) verses the probability of erroneously classifying a data set (statis-
tically of committing a Type II Error). This relationship is commonly referred to as the “hit
rate” verses the “false alarm” rate as a function of a varying decision criteria. In HyperCube
the criteria is the tolerance for a given classification algorithm. The validity of whether or
not a signature is classified correctly is determined by a previously constructed “ground
truth” image mask matching the classification area. A mask pixel of zero means there
shouldn’t be a match and a nonzero pixel means there should be. During the ROC computa-
tion as each image point is classified (matched against a given spectral signature) a tabulation
is maintained of whether an image point was classified (within tolerance for the given algo-
rithm) and if the classification was correct according to the “ground truth” image mask. Each
tolerance value produces one tabulation. A sequence of linearly spaced tolerances (~250-500
values) produces tables that are then normalized to form the ROC plot.

The ROC option is available when Classify mean of v points is selected in the main
Classify window along with Search Domain set to File and the Generate a sequence in
Classify Options checked. It is similar to generating the classification image sequence pre-
viously described. After checking the ROC curve box the ROC Mask... button is clicked
to select the ground truth image mask from a popup list of images. This image must spatially
match the classification area used in generating the ROC sequence of classifications. Note
that “Classify mean of v points” always results in a single classification region so the sum-
mation is over a single class.

Listed below is a representative scenario for generating a ground truth mask from an im-
age cube and then forming the various ROC plots shown on the following pages.

1. Choose several image points representing the same classification feature.

2. Select one or more neighborhoods around each point (to form a good average).

If these points exactly delineate the ground truth then click the Form Neighborhood

Mask Image button and Classify mean of v points and continue at step 7.

Choose an algorithm such as Vector Angle and Classify mean of v points.

Choose Classify Options and set up a sequence of ~15 outputs and Color Image.

5. Click Classify. Choose the output within the sequence of images that best
represents ground truth for this feature. Select Convert Image -> Image to Mask
menu to extract the mask. This mask can then be further edited (e.g. PhotoShop®)
to give it more validity.

6. Clear all of the selection points that were used to generate the mask and select a
new point from the cube that represents the feature in the mask. Or, open a library
and select a signature from the library list (see section Library Searches) and
select Library as the Signature in the Classify window.

7. Choose an algorithm from Methods in the Classify window. Select Classify
Options, check Generate sequence and ROC curve and then ROC Mask... .
Select the mask image generated above from the popup (this only needs to be done
once). Return to Classify Options and enter the number of outputs (~250) and a
broad range of tolerances for the chosen algorithm. Return to the Classify window.

8. The Classify button will change to ROC Curve. Click it to generate the plot.

9. Repeat steps 7 and 8 for each algorithm. Step 6 may also be repeated to see its effect.

B
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The mean of six points representing a
typical tree canopy was used for this
image mask that was extracted from a
sequence of 15 classifications using Vec-
tor Angle.

The selected image point on this
linked color composite was the
classification signature to be
matched when generating the ROC
plots shown below.

E=——————— AL =——— 15 Sl=————————— RIL h =—————P8I=5
Mask: Owly 014 WA Mask Pask: Owly 014 ¥4 Mask
Tolerance Hits False Alarms Alg: Mector Angle, Area: 0902 Tolerance Hits False Alarms Alg: Euclidean Distance, Area: D746
1.000 1.000
0. 1542 15229 0.0000 o
0.1574 15738 0.0241 o
0.1606 16035 el 0.0482 17 U ol
0. 1639 15371 0.0723 12
0. 1671 16663 0.500 0. 0964 360 0.500
0.1703 15063 0. 1205 578
0.1735 17243 0250 0. 1446 1056 0250
0.1767 17513 0. 1637 1554
0.1799 17731 0.000 0. 1928 2106 0.000
0.000 0250 0500 0742 0992 0000 0250 0500 0750 1.000
[ Scale []10x []Pts Hits v False Alarms Rate = [scale []10x []Pts Hitz vs False Alarms Rate |E

From above clockwise are the ROC plots corresponding to Vector Angle, Euclidean
Distance, Fourier Phase and Derivative Difference respectively. The vertical axis

is the hit rate and the horizontal axis is the false alarm rate. The greater the area
under each curve the more discriminating the algorithm. Ideally, the Hit Rate would
approach 1 while the False Alarm Rate stays near zero producing an area close to 1.

I=——————RILB =————— |-

Ei=———————— RIL? =—————[8i:

Mask: Owly 0,14 W4 Mask
Tolerance Hits False Alarms Alg: Deriv Diff 2, Area: 0.535
1.000

Mask: Owly 0,14 ¥4 Mask
Tolerance Hitz False Alarms Alg: Fourier Phase 8, Area: 0742
1.000

0.0024 6725 0. o000

0.0025 710 0. 000

0.0026 T 0ol 0.0181 L)

o.o0z? 00 0.0z41

0.o0z? 2495 0.500 0.0321 0.500

0.o0ze8 242 0. 0402

0.0023  @; R 0.0482 o

0.0020 9655 ’ 0.0562

0.0031 90 o0 0.0843 e

0.000f 0250 0500 0730  1.000 0000 0250 03500 0550 1.000
[ Scale []10x []Pts Hits v False Alarms Rate [ Scale []10x Pts Hits vs False Alarms Rate
[ [=)

|

The Pts checkbox switches the
plot from continuous to a discrete
scatter plot which the ROC actu-
ally represents.

Clicking within the graph displays a green dot
and highlights the corresponding tolerance value.
Conversely, clicking within the scrolled list shows
the corresponding plot position.
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Malapai

E Classifyl
Signature: Search Domain: —
I File @ File
(@ Library () Library
Lib: AnnLib list

MNeighborhood points: 9
Selected + points: 15

(Form Neighborhood Mask Image ]

[ save Sig... ] [Plot v Mean]
[ options... ] [ LibKey ]
[ Load Pts... | [ save Pts... ]
@ Classify mean of » lib spectra
(1 Classify each « lib spectrum

Method: [ Euclidean distance w |

Fifteen selection points along with various neighborhood points
were used to generate the resulting selection mask shown to the
right by choosing Form Neighborhood Mask Image in the Classify
dialog above (see section Classify Function). Each target point rep-
resents the same physical material. The library spectral signature
of this material was used in the classification to produce the four
ROC curves shown below. Note that the classification area and the
mask selected for the ROC curves must spatially coincide which in
this case was automatic.

ElE] ROC 16 EE
Mask : Target Mask
Tolerance  Hitz  Falze Alarms Alg: Yector Angle, Area: 0931
0.0000 0 o ik
0.003z2 u} o
0.0084 0 0 7ot
0. 0096 u} o
0.01z29 u} o 0.500
0.0161 u} o
0.019z2 u} o 0250
0.0225 u} o
0.0257 u} o 0000
0.000 0250 0500 0750 1.000
[JScale [J10x []Pts Hits vs False dlarms Rate [

= Target Mask

= ROC 19 EE
Mask: Target Mazsk
Tolerance Hits False Alarms Alg: Euclidean Distance, Area: 0.892
1.000
0. o000 u}
0.0321 u}
0.0643 0 070
0. 0964 u}
0.1285 u} 0.500
0. 1606 u}
0. 1922 u} 0250
0.2249 u}
0.2370 u} 0.000
0000 0250 0500 0550 1.000
[ scale (1108 [JPts Hits vs False Wlarms Rate 1=}

These plots correspond to the same four methods shown on the previous page that

were used in discriminating the tree canopy. Here they give a quantitative measure

of target verses background discrimination.

Em ROC 15 = ROC 17 EE
Mask: Target Mask Mask: Target Mask
Tolerance Hits False Alarms Alg: Deriv Diff 2, Area:0.911 Tolerance Hits False Alarms Alg: Fourier Phase 8, Area:0.940
1.000 1.000
0.0000 u} o |4 0. o000 u}
0.0001 u} o 0.0126 u}
0.0002 0 0 0ol 0.0252 0 L)
0.0002 u} o 0.0372 u}
0.000z2 u} o 0.500 0.0304 u} 0.500
0. 0004 u} o 0.06321 u}
0.0005 u} o 0250 0.0757 u} 0250
0. 0006 u} o 0.02a2 u}
0. 0006 u} o 0,000 0. 10093 u} 0,000
0.000 0250 0500 0730 0999 0000 0250 0500 0550 1.000
[ Scale []10x []Pts Hits vs False Alarms Rate [ Scale []10x []Pts Hitz vs False Alarms Rate
[&] [&]
. . ) .
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Library Searches

Choosing Library as the Search Domain produces a list of library signatures that best
match the criteria selected by the user. The list is ordered in decreasing closeness with a
numerical value derived from the classification Method. The numbers are only meaningful
within the same method and are most useful in detecting a cluster of matching signatures,
i.e. items that are physically similar. The spectrum of any listed signature can be plotted in a
spectral signature window by double clicking it and can be added to the spectral plot window
by dragging its graph (see the Superimposing Signatures section).

A library is loaded by choosing the Library... button in the Classify window. Once load-
ed the name will replace Lib:(none) and the Library option radio buttons under Signature
and Search Domain will then become available. Loading a library connects it to the clas-
sification process whereas using menu File -> Open As..., and selecting Format: Library
does not and that library remains independent. However, signatures from the later may also
be dragged onto the spectral plot window.

The steps to perform a typical library classification are as follows:

1. Load the image cube file and select one or more (if averaging) image points.

2. Choose Classify... from the Functions menu.

3. Click the Library... button to load a spectral library.

4. Select (v) one or more cube points from the Classify coordinate list.

5. Click the Signature: File and the Search Domain: Library options.

5. Choose a classification from the Method popup menu.

6. Click the Classify button. A list(s) of matching library signatures will appear.
w= File Edit Applications Image Functions Utilities Windows 5:20 PM 3)

Plot->run03_1000 Classify2

wE Signature Search Domain

run03_1000 run03_1000 +
@ File 2 File
O Library @) Library

Load Lib... Lib: Alibrary.lib
I
Neighborhood points: 1 ]

Selected / points: 1 |Form Neighborhood/Mask Image ]
]

skt 168 55 (Savesig..) [ Fiote )

( options... | [ LibKey ]

1096 1446 1796 2148
Yavelength {nm}

.y - ) Classify meah of « points
Oscale 0,11 [ Hidpfad (Clear Lib | TR @ Classify eac « point
L] i r & %]

(Load Pts... ] [ save Pis... |

i A ; { Method: [ Euclidean distance + | Classify

EI=— Library Searchl Alibrary.lib

Method : Euclidean Dist Double-click to toggle
Library : Alibrary lib Items selected: O
(4] 1 #* Sig. vectors: |
JUNZ21B.060 Spectral File : run03_1000 1 JUH19E . 005

1 JUNZIE0E0 02117 02746 Z Kl oe 000

e JUNZ1E.050 2 JUNZIEOST 03122 08150 # JUn19B.007
=0 00619 3T JUNZIEOSE 0.3541 05021 4 JUN19E 003
Ere s 4 JONZIBDS9 0.4207 07508 5 JUNTZE. 014
a i : 5 JUNZIEDE9 0.80F7 05238 6 JUN1GE. 016
¢ B o3t D "l o
1 00605 : g JONZIEOTO 1.0829 03584 U196 012

375 0.0565 9 JUM19E. 019
=20 0.0520 9 JUNZIB.O&E 1.0870 03560

85 0.0564 []Average « items

390 0.0546 5
Plot Selection

250 [ ]

1l

888 1425 192 2500
[ Scale 104

The Library Search window lists the library signatures matching the selected image cube
file point. The top signature in the list has been superimposed upon the Plot window.
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The opposite of the previous example is also possible: i.e., choosing one or more library
signatures and generating a classification output (Lib:File search). The region colors are then
taken from the patches in the Color Selector as follows: the lowest Vv library signature index
corresponds to the first color patch, the next higher Vv library signature index to the second
color patch and so on (see right hand example below for an alternate method of defining the
color correspondence). In the same manner that the selection point color correspondence
can be chosen, so can the library signature color correspondence by choosing menu Edit ->
Options -> Color Selector. The color to name correspondence can be displayed by click-
ing the Lib Key button in the Classify window. This generates a palette like image of the
correspondences. This can be saved like any other image. Shown here is a typical output.
To select (toggle on) a complete library, click on the library window and then choose Select
All from the Edit menu. Up to 1024 signatures can be selected. To deselect (toggle off) all
choose Edit->Clear menu or double click individual selected spectra. Section Dynamic
Displays and Spectral Plots describes how to change both the color and the associated
name after a Lib:File classification has been made.

If Lib:File match lists is checked (default) in Classify -> Options then two lists are
generated in addition to the classmap. One contains a list of the library selections that are
in the classmap and the other list contains the library selections that are not in the classmap.
Toggling a list item will display its corresponding spectra. Empty lists are not generated.

E0= Alibrary.lib Cc 555 O = Alibrarylib .. =B B
Color * idx Lib Name [{F
1 JUN19E.005
2 JUN19E.006
3 JUN19E.007
4 JUNTSE.00S
3 JUN19E.014
6 JUN19E.016

Color * idx Lib Mame |=]
1 1 JUM19E.005 5
2 JUM19E.006

At left is a portion of 412 color to library
signature correspondences after Select All was
chosen in the Edit menu to toggle-on all of the
library entries showing the default colors. At
right is the same library color coding after
Use source spectra color has been selected in
Classify: Options: More Options.

z
33 JUNI9E.DOT
4 4 JUNI9E.D0E
5 5 JUNISEDIA
£ & JUNISEDIE
77 JUNISEDIT
g & JUNISEDIE
9O JUNISEDIY
18 JUN19E 020
111 JUN19ED21
12 12 JUN19E.DZZ
12 13 JUMz0A001
14 14 JUNZ04 002
15 15 JUNZ04003
16 16 JUNZ04 004
17 47 JUN204 005
12 18 JUNZ0A006
1919 JUNZ0A.007
28 JUNZOA003
21 JUNZ0A.009
22 JUNZ0A.010
23 JUNZ0A.01
24 JUN20A.012 ||
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Dynamic Displays and SpectralPlots =~~~

Each time a classification output image (class map) is created a list is generated that as-
sociates the colored regions with the selection point number or library signature name cor-
responding to that region. Then, as you move the cursor over the classified image the name
appears as a small label next to the
cursor. The labelling font and its
position can be changed by choos-
ing menu Edit -> Options -> La-
bels. Saving a classification also
saves its correspondence in a text
file with a “.c2n” extension. The
correspondence between the color
of a region and the label name that
appears is completely editable by
using the Utilities -> Class Map Editor described later.

Below are two examples of classification outputs showing the region labels for a specific
cursor position.

Options

Detailed Messages
List Allocation
[0,0] Image Origin
+ Retain Source
Labels Anchor to Upper Right

»  « Geneva 9
Geneva 12
System 12

Mag/Rotate Interp
Color Selector...
List Clipboard Contents
Image to Ref Coords...
Pixel Exclusion...

Bold

tH23m006.060 Ovly LA

classes_CC_
W — ~

™ Cursor
Position

On the left is the output image from a 4 point selection File:File classification showing point
#1's region label. Vector Angle was used with a tolerance of .08 radians. To the right is the
classification output of a different image cube resulting from a Lib:File search. The label and
color of either image can be changed via menu Utilities->Class Map Editor.

Attach Class Map
An image can be made into a “virtual” class map by linking it with an actual class map
using menu Image -> Attach -> Class Map. The actual class map image must be front

most. This displays the dialog at right listing “vir- Attach Class Map

tual” class map image candidates. Once an image Class map image: 'FTH5_8.060s Ovly VA 0.08'

. . . . identifications will be displayed on the selected image

is selected then moving the cursor over it displays or cube. The upper left corner defines a common
registration point.

the label corresponding to the same position in the

actual class map. Closing the class map breaks the | ™% [FTH5-8 ™
( Cancel ) € oK)

attachment.
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A dynamic display similar to a classification output image can be generated when per-

forming a File:Lib search.

classifying it against
producing an ordered
However, if the En-
check box in the Clas-
selected as shown here

Library Parameters

4 Closest library matches
| Ignore the Disabled Bands List in Lib:Lib searches
@Enable dynamic display in File:Lib searches

i
(" Cancel ) ( More Options... |

| Lib:File match lists

(Okay )

Normally, this consists of selecting an image cube point and

a library of signatures
list of best matches.
able Dynamic Display
sify Options dialog is
then the match vector

is chosen from the cursor’s position on the image cube. A label containing the best matches
will be computed and displayed as the user moves the cursor. The dynamic search remains
in effect until any mouse click in the Classify window. It must be restarted by clicking the
Classify button. If a color composite Link image of the cube image has been created then
the dynamic display will also appear when the cursor is moved over the linked image.

Em

FtH23m006

Band 60 of 83: 730 nm

Dynamic Plot->FtH23m006

JUMZSE.0G2

JUNZSE 08D

1.000

0.750

0.500

0.250

0.000

399 924

[Scale [I0,1]

1449
Yavelength {nm}

1974 2499

[] Hide Bad H

A dynamic display of the current image cube
vector position can be shown by selecting Spec-
tra (Dynamic) from the Plot submenu. As the
user moves the cursor over the image cube or
linked color composite the plot is automatically

The dynamic display of 4 library spectra that most
closely match the image cube spectrum at the cursor
position. The graph is the corresponding dynamic
spectral plot of the top 2 library spectra (red and
green) along with the cube plot in black. In this case
the Method chosen was Vector Angle.

Arithmetic...
Overlay Color...
Adjacency

Histogram...

Histogram (Masked)...
Spectra (Selected Points)
Spectra (Dynamic)
Scatter...

updated. The data is read from the image disk file and works best when the cube file is in
BIL or BSQ format. If the user has enabled Dynamic Display in the Classify Options dia-
log, described previously, then the two closest library spectra will also be plotted on the same
graph. Similar to the static Selected Points plots, you can ‘Scale’ and ‘Hide Bad’.

EN=——

Dynamic Plot->FtH23m0D6

&

EN=——

Dynamic Plot->FtH23m006 =P85

Dynamic spectral

0_333

P W’
0.264

/\

1.000

plots of the same
cube vector point

0.730

0.194 0.500
0.125 f’\“ with and without 0.250 W"\w
0.055 the optional check 0.000
399 924 1449 1974 2499 399 o924 1449 1974 2499
Wavelength (nm) boxes selected. Yavelength (nm)
[ Scale [{[0,1] [<] Hide Bad &l [ Scale [{I[0,1] [] Hide Bad &
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Class Map Editor

The correspondence between the color and name of an image
classification can be modified by using Utilities -> Class Map Edi-  [EHIIEH windows
tor. You can do this after the image is generated or retrieved from e R
a saved file (the saved file has an associated *. c2n file defining the Library-to
correspondence). A classification image is a true color image where
each pixel is either a gray value (including black if it’s a mask) or a Concatenate Images...
specific color. Associated with each color is an ASCII string com- Concaranate Hias:
prising the name that will be displayed whenever the cursor is over R o
that color or no display when over a gray (image) pixel. The Editor :
allows changing that association so that a color or group of colors
may be “renamed” or the color itself changed with a corresponding change in the image.
For example: a classification region titled “Water” and represented by a light cyan color
can be changed to “Shallow Pond” with a medium blue color. A single colored region can
be changed to any other color (not gray) as long that color is not already used for a different
region. You can choose multiple items using the shift key for contiguous and the command
key for non-contiguous selections (Windows version uses the Ctrl key for non-contiguous).
As each item is chosen the corresponding class on the image will flicker in white. So, as
multiple selections are made they produce a larger and larger composite region. The Apply
button will consolidate all of the selected items into the displayed name and color and change
the image appropriately. The original class map and its associated color correspondence can
be restored at any time by the Reset button.

806 Edit->Six Class Map

: = = : Six Class Ma
Select 1 or more items in the list. Edit the T - 'i"*"""‘ L
name or color and Apply. Save the source ot 'f;.'f_@_:—', o i)
image to update the file correspondence. - 7 s W
Epaﬂ:e Grass R 195 : 2
rees
Trails
Main Roads G: 255
Open Grass Z
Water B: 195
Sparce Grass { Apply )
Export Item to ESRI Shapefile... Sorcz )
Delete Item (" Reset ?‘. 'f(_ Load... ) .‘_' Save...
’ Search... ) ( Generate Color Key Image

The Editor window on the left shows 2 highlighted items that have been selected and are
about to be consolidated into a single class with the name and color shown. The classmap
image on the right shows where these 4 items are located by flickering them in white. When
Apply is clicked both items will have the color: {195,255,195} and the item list will be up-
dated. The Search button displays a dialog allowing you to enter a text string and every list
item containing that string will be highlighted as if manually selected. The Export... button
saves a single item in the ESRI Shape File format (see section ESRI Shape Files).
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Scrollable List  For each classification region the associated name and color.
Click to select, edit name and color followed by Apply or return.
Multiple lines may be selected via shift click and command click.

R:G:B: The color components as each is selected. Edit as desired. The
color patch shows the composite.

Apply Change the selected list name to that of the edit field and color
and update the image. Hitting the return key is same as Apply.
Delete Remove the selected list item and replace its color with black.
Color Key Generate a legend type image (see section Library Searches).
Load/Save The color to name correspondence may be saved without having

(2]

to resave the image. It must be saved as ‘’name”.c2n. A previous
(e.g. master) may be loaded to overwrite an original correspondence.
This is an ASCII file and is also compatible with Edit->Options->
Color Selector. See section Selection Point Colors.

Load Options

The correspondence between name and

color may be selected below. (*) options . . .

are irreversible (Save or Duplicate first). Various combinations Of the

Also, differing table sizes truncate the #

of entries to the smaller table size. current and new colors and
@ New colors and new names (¥) names may be Selected.

) New colors and existing names (*)
! Existing colors and new names

(Cancel) €okay)

Search This displays the dialog shown below and is used to select items based
upon their common names. Each item containing the search string
will be highlighted. No modifications are made until Apply is clicked.

Search Color to Name Editor

Enter a search string below. Each line IfPI‘eCleaI' iS Checked ﬂ’len any
item within the Color to Name Editor .. . . . .
containing this string will be highlighted. existing hlghllghtmg is cleared
Clicking Apply will collapse all of the . .
selected entries to the displayed name €lS€ items matchmg the search
and color. Apply is not reversible. string are added to currently
"] Case sensitive E Preclear selections hlghllghted items.
Asphal]
(GanceD) (o

Sort Class Color Sort Order

= All of the elements in the list, i.e., the class
elect 1 of the following: . .
S names will be re-ordered according to
U Hue, blue first this dialog option. This makes it easier to
) Saturation, high first
T group a large class map by color such as
O Intensity, high first classifying against a library.
O Intensity, low first

{ Cancel ) @
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Export Item...  Convert a single item into a shape file as specified in the ESRI
Shapefile Technical Description - July 1998. Brings up the user
dialog shown below presenting a number of options.

ESRI Export Options

The chosen classification is converted to the
ESRI Shape File format {origin at bottom left)
that you may save and/or display according to
the options below.

b4 Save files: #.shp, *.shx, *.dbf

[ Plot shape file {2X size)

[ Flip output {origin at top left)

[] Transform to Image Reference coords

=

Save files:  Solicits a file name using the item as the base name
and produces the three files listed. The .shp
extension is a must, the other two are automatic.

Plot shape: Generates a vector plot of the result at 2 times size.
This plot will exactly match a 2 times magnified
image of the class map. See sections Magnify and

Flicker/Superimpose.

Flip output: Invert the y coordinate so that the origin is at
the upper left instead of the image’s lower left.

Transform:  Convert shape file coordinates to the transformation
specified by Image to Reference Coordinates.

S

1 1l ] k|

The left image is a 2x magnified view of a six class map. The main dark green
regions are the selected item in the Class Map Editor that was Exported to a
shape file. The right image is the vector plot output showing the class outline in
green and any interior voids in the complement color, magenta.
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Spectral Calibration

HyperCube has the ability to empirically calibrate a cube against a set of two or more ref-
erence spectral vectors. The reference may be from an external file, another cube or a library.
Calibration uses the same point selection and neighborhood toggling as is done for a Clas-
sification. It can be invoked whenever a Classification window for a given cube is active by
choosing Functions -> Calibration. Calibration produces a gains and offsets file that may
be saved or immediately applied so that you can see the effect on a classification or plot by
toggling it on and off.

The idea behind calibration is simple, try to compute a separate linear transformation,
gain (or scale) and offset, for each band that will convert that band’s pixel values to the same
values in a reference set. The assumption is that the difference between the measured and
reference spectral values is closely represented by a linear change. In practice this isn’t exact
so more than two spectral vectors (selection points) are used in a least square solution.

A typical calibration scenario is as follows: Suppose there are four panels in the source
cube that have known spectral reflectance signatures (somewhere else). Then choose four se-
lection points over these panels and toggle them on as if doing a classification. You may then
choose additional neighborhood points around these if an average spectral signature for each
panel is desired. Bring up the Calibration dialog as stated above. The Meas column will
be the measured spectral vector for the given point and the Ref column will be the desired
reference spectra and initially will be zero. The next step is to put data into the Ref column
that you want the Meas value to be transformed into. This could be done by manually enter-
ing the data as described below (very tedious for hyperspectral data!). However, the easiest
method is to drag an existing reference spectral signature plot over top of the calibration win-
dow list. It will be automatically interpolated from its wavelengths to the cube’s wavelengths
(see section Plotting Signatures). The signature plot can come from a library list (see
Spectral Libraries) or from another cube. The later is extracted by loading a second (refer-
ence) cube, selecting a point, opening a classification window, toggling that point on and then
clicking the Plot V button. The resulting signature plot can then be dragged onto the calibra-
tion window. The final method of entering Ref data is to read it from a previously generated
file. Its format is ASCII tab delimited text pairs of wavelength and value. Note that it is not
defined by a band number. The wavelengths are used to properly interpolate the values into
the cube’s wavelengths. If the cube’s spectral range extends beyond the Ref values then the
corresponding Ref data is zero filled.

Edit highlighted or selected item. Current point.  Next or previous point.
EE=————— Wassifyl Calibration LE
Band  Wave Meas Ref\ Pt. ®: m

L1 299 &0 0000 [4F S /L dR f
P a0z 290 0o = - save Rer..JT—— Lave/Lod € fOl"

/405 230 0000 Edit-> || 0.000

7

5

&

7

5

5

412 230 0.000

| .
Band and d i B O Selected Item the current point.
d @ Band Range

WaV€l€I’l th. 413 300 0.000 )
& 2 = o [Tl |soemns
o 4 20 oomo [JZero G & O at disabled bands
11 433 300 0000 Brmg up the Ref
12 437 350 0000 [/ Compute | [ Apply ][ Remove | : .
13 440 3o 0.000
/. a scaling dialog.
Generate gains and offsets. Apply (remove) them to (from) current cube.
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The various Calibration Dialog controls are defined below:

Scrollable List:

Pt. #:

<-->

Edit->:

Selected ltem:

Band Range:

Save Ref...

Load Ref...

Scale Ref...

Zero G & O...

Compute

Apply

Remove

Contains four columns listing the Band, Wavelength, Meas value
and Reference value for the given Pt. #. Clicking on a
Meas or Ref column item allows that item to be edited, see Edit button.

The current selection point number shown in the list. May be manually
edited or incrementally changed with the adjacent arrow buttons.

Step to the previous or next selection point.

Enabled when a Meas or Ref item is highlighted (clicked on). The high
lighted item will be changed to the number in the edit field. Works in
conjunction with the two radio buttons described next.

If on then only the selected (high lighted) Meas or Ref item will be
changed. Mutually exclusive with Band Range.

If on then all of the items within the Band Range specified will be
changed to the same given value. Mutually exclusive with Selected
ltem.

Displays a standard Mac save dialog and saves the current point Ref data
as ASCII tab delimited wavelength, numeric value pairs.

The opposite of Save, loads a previously defined Ref file and interpolates
as necessary to overwrite the current point Ref data.

Brings up a dialog that permits you to enter a numeric value that will
immediately be multiplied times a specific Ref column or all Ref columns.
A convenience to change the range of the Ref data.

When checked the gain and offset computed for each disabled band

is set identically to zero. When these gains and offsets are then applied
to a cube the disabled band’s spectral values will then be zero.

See section Band List for a description of disabled bands.

This button becomes active when at least two Classify points are selected.
When clicked the gains and offsets are computed and shown in a separate

data list window that can be saved via Save in the File menu.

Also generated is a data list showing the corresponding residuals from the
least squares solution.

Becomes active after a Compute and immediately applies the gains and
offsets to the current cube meaning that any plots are automatically

updated and subsequent classifies will accommodate them.

Remove any gains and offsets that may be in effect for the given cube.
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ER Classify3 E
Signature S$earch Domain
@ File @ File
(O Library (1 Library
Lib: (none)

Neighborhood points: 1

Selected + pomte- 4 (FOrm Neighborhood Mask Image ]

/1 192 750 atn =
T3 e s | (savesig... ] [ Plotv ]
43 193 759 _ §
v4 1a3 744 [ options... ] [ LibKey ]
(Load Pts... | [ save Pts... ]
7| () Classify mean of » points
Delete PI 2 @ Classify each « point

Method: [ Uector angle b | [ Classify ]

Four selection points from cube Frames
5-8r have been chosen as reference val-
ues. Point #2’s spectra is shown below
and is being dragged over the corre-
sponding point #2 listing of data8a’s

EE] Classify2
Signature Search Domain
dataga
@ File @ File
> Library (O Library
Lib: (none)

MNeighborhood points: 1

Seleated f pomts: 4 FOrM Neighborhood Mask Image ]

£ 1 186 367 akr =
T m e [ | (savesig... ] [ Plotvs ]
43 180 394 _ _
v 4 177 302 [ options... ] [ LibKey ]
[ Load Pts... ] [ save Pts... ]
= (> Classify mean of » points
Delete FI 2 @ Classify each « point

Method: [ Dector angle hd |

These are the four points of data8a that
have been selected as the matching
spectral vectors to the four reference
vectors of Frames 5-8r along with the
data8a calibration window below.

calibration window

Exj Frames 5-8r Spectra3 EE B Classify2 Calibration EE
nirn Yalue Selection pt: 2, ® neighbors: 1 Band Eave Heas L Pt. ®:
T [ Ee——— L I T
402 0.1060 ; | = |:| [ Save Ref... |
e 01120 0.75 1 1 z 445  01Z0 0000
| BIEER 1 R s
o s : :
iis 130 1 D g 1 6 462 0129 0000 @) BantiRange
413 0.1040 1 1 7 #ogy  OE0 0.000 :
i e 0.25 . g 47T 0430 0000 Scale Ref...
3 479 0131 0000
426 01150 - :
4 + 1 10 424 0430 0.000 [J2ero G & 0 at disabled bands
3% %24 1440 19V _249] 1 490 0129 0.000
[ Scale  []10H B 12 45 o01z0 0000 [ (Compute | [ Apply ) Remove |
. 13 501 0432 0000
[&]

Spectral plot of point #2 of Frames Point #2 of data8a’s calibration window before

5-8r. the drag operation.
EO==—————— Classify2 Calibration

e vee e Ty

s wms 01m E>)[ | Leuetet T

8 Samd honge "

. & o= A v |meeme)| — |3 som

?10 353 Egé [ Zero G & 0 at disable Z :gg}gg

1z 495 0120 Compute Apply | Remove | : b

13 301 U:152 E =] +0.0184
Point #2 after the drag operation. The spectral
plot values have been interpolated and placed Ei=—— Datal [E
into the Ref column. This is repeated for each o nage:
of the remaining points followed by the Compute 1 a0 0 [
button which then produces the Gains and Offsets : el o]
values along with the Residuals for each band. : I\ e0e o peas
These may be applied immediately (Apply) to o i oo
data8a or saved (File->Save).
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Saving Images

HyperCube can save images in various formats depending upon

m Edit Applications

the File menu item chosen and on the internal format of the image. If — i
the image has not as yet been saved a standard save file dialog with the Open... %80
suggested name will appear asking for confirmation if the file already =

exists to overwrite it. Subsequent saves of the same image will per-

form the save directly automatically replacing the old image with the = W
same name. However, if the image has been modified since the last — —
save the confirmation dialog will again be presented. To save a spe- e

cific band, scroll the cube to the band, choose Duplicate from the Edit Page-Setups.

menu and then Save. To save all of the bands within a cube image as Print... %P

sequentially numbered TIFF files, choose menu File -> Save As...,
Bands. File -> Open As..., Bands will reload the bands into a cube (see section Con-
structing/Modifying a Cube).

File->Save As... is used to save images in Bands, ERDAS Imagine®, HDF, JPEG,
LASF, Multiband, NITF, Raw, SRF, Text or TIFF format. If ERDAS Imagine®, HDF,
NITF, SRF or TIFF is selected from the Format popup then no other dialog is required.
Raw is used to save a single image and allows specifying a rectangular subset and the pixel
type. Save As... LASF will display an alert if the image does not have a geo reference but
will continue. Selecting Raw displays:

Save Raw Ima_g_e
Image is 557 pixels by 774 lines. The Save As... Raw dlleg deﬁn'
ing the file format for a 32 bit float
e i i b pixel type. If the image had a
Sl R #oflines: |74 selection rectangle displayed upon
Pixel type: [Float  |s it the coordinates of the selection
Interleave: | BIL (line seq) * area would have been automati-
—= p— cally inserted into the various edit
S— fields as defaults.

The dialog edit fields are defined as:

Starting pixel:  First pixel defining the image rectangle to save. These first 4 edit
fields are preset to the current dimensions of the image.

Starting line: First line to save.

# of pixels: How many pixels per line to save.

# of lines: Corresponding number of lines to save.

Pixel type: Either byte, short, float or long.

Interleave: If the image is true color then this popup will be enabled to allow the

image to be saved as a 3 band cube with the specified interleave.
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The Save As... function is also used to save an image cube as a multiband image. The
dialog is similar to the previous Raw dialog with the addition of two more edit fields and a
check box to selectively dump only bands whose status is Enabled in the Bands List. Un-
like the Raw dialog, the Interleave popup is always enabled, not just for true color. Save
As... also generates a new *.hdr, and for multiband a new *.wvl, file.

Save Cube Image
Cube is 320 pixels by 1280 1ines_;);r 20 bands (60-79).
Selection is 279 pixels by 290 lines. ThlS dlCIZOg Wlll save all 20 bands Of
Starting pixel: |21 # of pixels: 279 a multiband image within the area of
SiRingline:—| 192 # of lines: {290 a selection rectangle whose coordi-
Starting band: |60 # of bands: |20 nates are shown in the edit field. The
[ Don't save disabled bands interleave format is BIL (Band Inter-
Pixel type: | Short K3 leave by Line) and the pixel depth is
Interleave: | BIL (line seq) | & ! 16 bits.
(_Cancel )

The additional dialog items are defined as:
Starting band:  The first band of the cube to start saving. The default is the first band.

# of bands: How many bands to dump beginning at the Starting band. The
default is the number of bands in the image cube.

Don’t save dis... If this check box is set then disabled bands specified in the Bands List
will be skipped. This option is unavailable if all bands are enabled.

Note: To change the format of the multiband file use menu Ultilities -> Reformat Cube
File. It is much more general and operates directly on the file pixels images that have been
loaded into memory.

Save As..., Bands can be used when an image cube window is active. Its purpose is
to save each band of the cube as a TIFF file forming a set of sequenced images that can be
made into a QuickTime™ movie using a program such as Adobe Premiere™ . The user cho-
sen name will be concatenated with the a number (e.g. name.001) as each band is extracted
and automatically saved. These band images can be automatically reloaded and formed into
a cube using menu File -> Open As..., Bands by selecting any one of the numbered images.

Saving a Class Map image also saves a text file with the same base name and a .c2n file
extension defining the correspondence between the image colors and their class names.
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Printing

Any HyperCube window or underlying image can be printed to the currently chosen
printer using the functions File -> Page Setup... and File -> Print. These bring up the
standard Mac or Windows dialogs with options usually specific to the type of printer. The
default is to print the contents of the front most window with its name below centered on the
page. Print Image prints the entire image regardless of what is shown within the window
whereas Print Window limits itself to just the way the window appears including any opera-
tions being performed on the window such as gray mapping or filtering. Print Image will be
replaced by Print Text if the window contains any ASCII lists. Whether window or image,
the output will always be resized to fit within the print area.

Macintosh Print Dialog details

Sk If a selection rectangle has
Printer: | hp Laseret 4200 F been drawn then you have
Presets: | True gray B —" the option of just printing
_ HyperCube Carbon L :] its contents.

® Print image "] Suppress Title _| Print Selection
OPrinfWindow () Suppress Border  (_OPI (96)... ) The desired output resolution.
== — = S ——— However, the image will al-
f\?)/ e (o) D ways be scaled, l];g necessary,

/

Selects either print the entire
image or just that portion
shown in the current window.

to fit the page.

You have the option of
omitting a title or border.

Print 2l
— Prirter
MName: HF Laser et 4200n Properties |
Status: Feady
Tupe: HF Laszerlet 4200 PCL E
‘Wwhere:  hplagerlet4200
Comment: [ Prirt ta file
— Print range Copies
& Al Mumber of copies: |1 3:
" Pages frum:l to'l J
: : 3 |— ¥ Callate
€ Selection
— HyperCube option
% Print image V' Suppress title ™| Bittt selection rectangle
= Print wirdow ¥ Suppres: barder |SB Diats per inch
ok I Cancel

The corresponding Print dialog in the
Windows version. The HyperCube
options appear at the bottom.
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Utilities
Reformatting a File |
Menu Utilities -> Reformat File... operates on Multiband, Raw, %:‘:’:E
NITF sequential multiband and NITF mono image files. If the file to be o )

reformatted has a *.hdr file these values will be extracted and inserted ;'":I?EEJ;EE::S':LTE,}F___
as defaults into the appropriate edit fields of the Reformat dialog GeoTIFF, JPEG to NITF...
window. A new *.hdr file will be generated along with an updated *. ASCIl to Library...

wvl file if one existed for the source image cube. NITF multiband and L_ibra"" o g

mono files don’t have a separate hdr or wvl file, all sizing informa-
tion is contained in the source file. Reformatting a NITF file produces Eg:sz:::;: s »
a cube or mono file, not another NITF file. Selecting a single output

band from a multiband image essentially extracts the band and writes a
single raw type image. The Reformat dialog appears below.

Change Window Title...

Merge LAS Files...
ASCII LIDAR to LASF...

Reformat Multiband

The upper elements define the spatial -~ Source File Format —-

format of the data. Normally, this is Pixels: |320 Header hytes: |0

retrieved from the * hdr file or directly Sk bk Pixel type: 16 bit unsigned |
from a NITF file. = Interleave: [ BIL (line se) [5)

Byte order: Mac,5un (big endian)

-- Qutput Format --

This dialog area specifies the format Starting pixel: |1 # of pixels: 320

of the converted output file. Its initial spring et | #oflines: 960 |
Starting band: 1 # of bands: 210

values are set equal to the source file

size and are edited as desired. Min: 0 Pixeltype:  [32bitfloat [
Max: 1204 Interleave: [ BIL (line seq) | & ]

......................................................................... S s 5 ORI

Check boxes used to change the order of # Flip top <-> bottom (] Output header bytes

pixels within a line, the order of the lines B Kol s oaling 3 Reverse Band preer
™ Limit to Min & Max "1 Reverse wavelenth order

within a band and whether any scaling,
limiting or byte swapping is to be applied.

I'\’ Cancel ) 4 Scaling/Calibration... :fl

The example shown will generate a full size cube scaling
16 bit signed pixels to floating point pixels while limiting
the range to [0,1200] and reversing the order of the lines.
Swap bytes will change the byte order to PC (little endian).

# Pixels: The number of pixels per line in the source file.
# Lines: The number of lines in the source file.
# Bands: The number of bands in the source file.

Header bytes: The number of bytes in the source file preceding the image data.
Pixel type: Size and type of the source pixels.

Interleave: Structure of the source file: band, line or pixel.
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# Pixels, Lines, Bands: The subset of the source file to be reformatted.

Start pixel, line, band: Starting coordinates within the source file for subsetting.

Output Pixel type: Output pixel size. If Limit... is checked then output
pixels are kept within the Min & Max range, else they
are automatically limited to the range of the pixel type.

Output Interleave: The format structure of the output cube.

Min, Max: The lower and upper ranges for limiting the output pixels.

Flip left <-> right: Change the order of pixels within a line.

Flip top <-> bottom: Reverse the order of the lines, i.e. first line last.

Apply scaling: Modify each output band according to the type of scaling
selected in Scaling/Calibration. If checked then each band
is modified by: scale * band + offset.

Swap bytes... This check box allows swapping the order of bytes within

16 bit and 32 bit pixels. Note that this applies to the output.
The source byte order is taken from the header and if it is
unknown you will be prompted for a best guess.

Output header bytes:

Reverse band order:

Reverse wavelength...

Scaling/Calibration:

Directly copy the source file header bytes to the output file.
Output the bands in reverse order.
Also reverse the order of the output wavelength file.

This brings up the following user dialog which is used to

determine the type of scaling to be applied to the output.
The Apply scaling option checkbox becomes active after
returning from this dialog.

Scale/Calibrate

Apply this scale and offset to A typical gains and offsets

every band. .  Choose type of rescaling: ﬁle content: apair ofval—
e iobals senie: |[TTG / ues for each band...
-~ Oor -- e 0.00716025 -0.0044436
. : : 0.0054349 -1.367508
elect a file containing a ® Gains/offsets file - [ Load.."|
feparatefcale & oﬁsefpair R 000553983 -1.2478907
0.00583894 -1.2276135
for each band. The number of 0.00571494 -1.1864042
pairs must equal the number of 0.00562544 -1.1921199
bands in the source file. 0.00553107 -1.5069996
Scale and offset pairs are
separated by a space or
tab.
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Wrap JPEG in NITF

A JPEG (DCT) or JPEG (2000) image file can be embedded within a NITF file using
this utility. Additionally, an IKONOS formatted RPC text file may be included. This is the
complementary operation to the JPEG extraction described in section NITF Files. Choos-
ing menu Utilities -> Wrap JPEG in NITF displays the normal open file dialog. Select the
JPEG file (either the older DCT type a new 2000). A second open file dialog will appear al-
lowing you to include a corresponding RPC (Rational Polynomial Coefficients) file.

Shown below is a portion of a NITF image header resulting from embedding a JPEG
2000 file. By setting the menu Edit -> Options -> Detailed Messages flag, subsequent im-
age loads will display header information.

ENCRYP: 0

ISORCE:

NROWS: 00029696

NCOLS: 00035840

PVTYPE: INT

IREP: MONO

ICAT: VIS

ABPP: 11

PJUST: R

ICORDS: G

IGEOLO: ©013202S1445153E0132085S1450248E014247S1450259E01424251445143E
NICOM: 1

ICOM1: Saved via HyperCube, waw.tec.army.mil

COMRAT: V@39

NBANDS: 1
IREPBAND1: M
ISUBCAT1:
IFC1: N
IMFLT1:
NLUTS1: 0

ISYNC: O
IMODE: B
NBPR: 0035
NBPC: 0029
NPPBH: 1024
NPPBV: 1024
NBPP: 11
IDLVL: 001
IALVL: 000
ILOC: 0000000000
IMAG: 1.0
UDIDL: 00000
IXSHDL: 01055

Part of the NITF image header after a large JPEG 2000 file has been embedded and re-
opened. The value of C8 in the IC (Image Compression) field indicates that the image
data is actually a complete JPEG 2000 file.
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GeoTIFF, JPEG to NITF

The geometry of an existing GeoTIFF image in UTM coordinates along with a matching
JPEG image can be converted to an encapsulated JPEG NITF file in geographic coordinates
with geographic RPC’s. Either a single file or an entire folder of files can be converted. Se-
lecting menu Utitities -> GeoTIFF, JPEG to NITF brings up the following dialog.

GeoTIFF, JPEG to NITF

GeoTIFF file(s) and matching JPEG file(s) are used to
construct a wrapped JPEC NITFimage file containing
RPCO0B geometry. Matching is via image filebase
names. Selecting ‘Entire folder’ processes every
matching pair.

Enter 2 character country code, if known: JuUs

() Single file
{®) Entire folder
E‘ Use same country code for all files.

(_Cancel ) (Process...)

As shown in this example, country code ‘US’ will be embedded in the final NITF and will
be used for each converted file within a folder. Selecting Process will then display a Select
Folder dialog . If option Single file had been selected then the standard Open File dialog
will appear and only that file will be converted. The program preceeds on its own and when
finished displays a summary text window. It is important that for each GeoTIFF file (name.
tif) there is a corresponding JPEG file (name.ext) where extension ‘ext’ can be ‘jpg’ (JPEG
DCT) or any of: ‘j2c, jp2, j2k, jpc, jpf or jpx’ (all JPEG 2000).

Buckeye Files to NITF

This function is only applicable to special Buckeye imagery and supporting meta data.
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Converting a Library to a Cube File

HyperCube can create an image cube whose pixels Rl Windows
Reformat File...

are the spectral signatures from a library. This is accom-

plished via Utilities -> Library to Image Cube File... | WrapJPEC in NITF...
A . . ) ] . Buckeye Files to NITF...
which is enabled whenever a Library List window is GeoTIFF, JPEG to NITF...
front most. Each signature is replicated into a square ASCII to Library...
block (for clarity). Blocks are placed side by side and SOFSFPES mage Ltbe i .

ASCII File...

row by row in the same order that the signature names
appear in the Library List. The total number of blocks and their rectangular arrangement (per
row and the number of rows) is initially chosen by the program and can be edited by you.
Null signatures are added to fill out the last row. If you enter values that produce a block to-
tal that is less than the number of signatures in the library then only that number of signatures
will be converted.

After selecting Library to Image Cube File... the following dialog appears:

Library -> Cube

Lib name: AnnLib list The structure of the library is determined by
# of signatures: 412 . . . .
Siainities Ieciothe A3Y readlng. the first spectral szgnatur'e in {he Li
Shariyave, 338 nin brary List (see section Spectral Libraries).
End wave: 2500 nm
Delta wave {(mean): 5 nm

— The 431 band image cube will consist of 288
b Blockes 118 floating point pixels/line by 368 lines with the
Vert blocks: |23 last 2 blocks containing zero filled signatures.

Last row includes 2 null blocks.

(Canes)
(Cancel

The upper portion shows the structure of the library while the lower portion defines the
size of the resulting image cube. Note in this case that the total number of blocks (18*23) is
2 greater than the number of signatures, 412, in order to make the cube somewhat square and
that the resultant image cube file size will be almost 183 megabytes, (16 * 16 * 18 * 23 * 431
* sizeof(float)). These values can be edited and a Block size of 8 (~46 MB) still yields a
usable image cube. The image cube is stored in band interleave by pixel (bip) format with
floating point values along with newly created header and wavelength files. The Reformat
Cube File utility can be used to reconstruct a different format image cube.

If the Library List window already has attached spectral data, as is the case when opened
from a Classify window, then you are immediately presented with the save file dialog re-
questing a name for the image cube. If the library list does not have attached spectral data,
i.e. opened using Open As..., Library, then there will be a delay of several seconds while the
spectral signatures are being loaded before the save file dialog appears.
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ASCI| File to Library

A text file can be read and converted to a HyperCube Library file using menu Ultitlities
-> ASCII to Library. This is basically the inverse of menu Utilities -> Library to ASCII File
using the “Columns” option. Therefore, the text file must consist of white space delimited
columns with the first column containing the wavelength values and subsequent columns rep-
resenting the individual spectral values that will be paired with the wavelengths. A portion of
a typical source ASCII file is shown below.

350 0.059 0.056 0.055 0.055 0.056 0.058 0.060 ...
355 0.060 0.057 0.056 0.056 0.057 0.058 0.061
360 0.060 0.058 0.057 0.057 0.057 0.059 0.062
365 0.061 0.059 0.058 0.058 0.059 0.060 0.063
370 0.062 0.060 0.059 0.059 0.060 0.062 0.065
3750.064 0.061 0.061 0.061 0.061 0.063 0.067
380 0.066 0.063 0.063 0.063 0.063 0.066 0.069
385 0.068 0.065 0.065 0.065 0.066 0.068 0.071
390 0.070 0.067 0.067 0.067 0.068 0.070 0.074
395 0.072 0.069 0.069 0.069 0.070 0.072 0.076
400 0.073 0.071 0.071 0.071 0.072 0.074 0.078
405 0.075 0.073 0.072 0.072 0.074 0.076 0.080
410 0.076 0.074 0.074 0.074 0.075 0.078 0.082
415 0.078 0.076 0.076 0.076 0.077 0.080 0.084
420 0.080 0.078 0.078 0.078 0.079 0.082 0.086
425 0.082 0.081 0.080 0.081 0.082 0.085 0.089
430 0.085 0.083 0.083 0.084 0.085 0.088 0.092

2500 0.28 0.19 0.28 026 0.26 0.24 0.27...

A text file subset in which the first column defines the wavelengths and
subsequent columns contain the spectral values for a series of signa-
tures. The result of menu Ultilities -> ASCII to Library will be a file
containing the signature file names and a separate file for each signature

(see Spectral Libraries).
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Converting a Library to an ASCII File

The currently active (front most) Library List window can be saved as a text file by
choosing Utilities -> Library to ASCII File. You are presented with the following dialog de-
scribing the size of the library along with several options defining the format to be used when
generating the ASCII file.

Library -> Text File

Lib name: AnnLib list
# of signatures: 412
Signature length: 431
Start wave: 350 nm
End wave: 2500 nm
Delta wave (mean): 5 nm

Signature order:
() Rows
) Columns

M Include wavelength as
the first row or column.

_Cancel ) ( Construct )

The structure of the library is determined by reading the
first spectral signature in the Library List (see section

Spectral Libraries).

If Rows is selected then each row will be a complete signa-
ture (431 points in this case). If Columns is selected then

a row will consist of all of the spectral values for each sig-
nature for a given wavelength (412 values per row shown
here).

Include Wavelengths adds an extra row or col-
umn at the beginning containing the wavelengths.

If the Library List window is already loaded such as part of a Classify window then the
standard save file dialog is presented else there will be a delay while the library data is ex-
tracted followed by the save dialog requesting the name of the ASCII file.

EE LibRow.text
A1 B8 1 © T B T € _T T ]
| 350 355 360 365 370 375
(D2 00224 00228 0.0z05 0.0z038 0.0193 00197
| 3 | 0.025 0.0z4 n.0zz 0.0235 00213 00205
| 4 | 0.0z6 0.0225 0.0z24 0.0z21 00216 00217
S| 0.0239 0.0247 0.0z09 0.0235 0.0z11 00217
| 6 | 0.0243 00222 0.023 0.0zz2 0.0z207 0.0223
|| 0.0302 00272 0.0263 00276 0.0259 0.0285
| & | 0.0z201 0.0168 00172 0016 00158 0.0173
| 9 | 0.0z02 0.0176 0017 00158 0016 0.0166
| 10 | 0.0178 0.0192 0.016 0.0197 0.0158 0.0179
| 11 | 0.0308 0.03 0.0262 0.0294 0.0253 0.0266
| 12 | 0.0315 0.0291 0.0279 0.0263 0.0266 0.0255
| 13 | 0.033 0.0z294 0.02583 0.0279 0.025 0.0256 . .
14 0.0207 0.0171 0.0177 0.0167 0.015§ 0.0176 Small portions ofa llbrary saved
15 0.0z 0.0206 0.0196 0019z 0.0183 00159 .
16 0.0301 0.0263 0.028 0.0251 0.0256 0.0244 in row and columnform respec-
tively and opened in Excel™ . In
e LibColumn. tent =— each case the wavelength option
_ A_1 B8 T © T B T € _J F ] .
1 350 00224 0.025 0.026 0.0239 0.0243 was lncluded.
2 355 002238 0.024 00228 0.0247 00222
3 360 0.020%5 n.0zz 0.024 0.0z209 0.023
4 365 0.0z2038 0.0235 0.021 0.0238 0.0z2z2
5 370 0.0193 0.0213 0.0216 0.0z211 0.0z207
6 375 0.0197 0.0208 0.0z217 0.0z217 0.0223
7 350 0.01838 0.0z11 0.0203 0.0z2z21 0.0197
& 385 00173 00193 0.0z09 0.o0z1z 0.0z
9 390 00155 0.021 0019z 0023z 0.0203
10 395 0.0171 0.0194 0.0z 0.0z21 0.0z
11 400 0018 0.0z06 0.0z04 0.0235 0.0205
12 405 0.0186 0.0217 0nzzz 00252 0.0z14
13 410 00202 0.0234 0.0236 0.0273 0.0235
14 415 n.ozz 0.0249 0.025 0.0295 0.0244
15 420 0.0229 0.0267 0.0271 0.0311 0.026
16 425 0.0251 0.0298 0.0258 0.03H 0.0284
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Concatenate Images

Two images may be combined side to side or top to bottom to form a new single image
by choosing Utilities -> Concatenate -> Images, Bands. The images don’t have to be the
same spatial size, the output will be sized to the minimum dimension of the two. However,
they must have the same pixel depth, i.e., both gray or true color. If the images both have at-
tached data then the attached data pixel size and type (e.g., unsigned short, short, float, long)
must also match. The bands of a cube are also candidates for concatenation. To concatenate
an entire cube see the Concatenate Cubes description in the following subheading.

Select Concatenate Images

Select two images. The second image will
be concatenated with the first either by
adding its lines or by adding pixels. Both
images must have the same pixel bit depth
but may be of different spatial sizes.

%) Add lines to bottom
() Add pixels to right

Firstimage: | 10008 (1:5).tif ]
Second image: [ 10009 (1:5).tf M
_Cancel ) F oK )

Concatenate Cubes

Two in-memory image cubes can be joined side-by-side if they have the same pixel depth
and the same number of bands. In order to concatenate them by adding their lines they must
first be saved as cube files and then processed using menu Utilities -> Concatenate Files.

Concatenate Cubes

Select two image cubes. The second cube
will be concatenated to the right by adding
pixels. Both cubes must have the same
pixel depth and number of bands.

*) Add lines to bottom
®) Add pixels to right

First cube: | Malpais |
J

ar||4r

e )

Second cube: | Malpais €C

. Cancel |

i
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Concatenate Files

This utility allows you to make one continuous file from two or more files by reading
each file and sequentially concatenating their contents to create a single new output file, e.g.
combining individual Landsat file bands into a contiguous BSQ (Band Sequential) cube. The
source files are not altered in any way. Compare this with the previously described Concat-
enate Images, which operates only on images loaded for display.

You start the process by selecting menu Utilities -> Concatenate Files which brings up
the following dialog:

Concatenate Files

Use Add...to construct a list of file names that
will be concatenated together to form one

Each button press displays the

conious v, Togeee steclikon) L standard open file dialog. Any
generating any output. type of file may be selected.
8107.TIF =
it 1 Each selected file is added to
rsefbrl3 = the list. A selection may be re-
moved by clicking it and press-
([ cancel | [ ing Delete Selection.
Ignore all selections and exit Display the standard save file dialog
without creating an output file. and solicit a name for the concat-
enated file.
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Changing a Window Title

It is often convenient to be able to change the title (name) of a window without having to
first do a Save as... . An example is when printing where the title can be changed to some-
thing more descriptive and then listed below the output (see section Printing and note be-
low). To perform the change activate the window and choose Utilities -> Change Window
Title. This brings up the following dialog.

Change Name

The current window title is:
Frames 5-8r

IfCheCked and Wll’ldOW iS a Edit new window title below:
cube then the loaded bands will —_ [Ft Hood, Frames 5-8r |

be renumbered starting at 1. [~ Sequentially renumber the bands
(o

The current window name, Frames 5-8r
being changed to a more descriptive title.

Note: Window titles may consist of up to 63 characters, while file names are limited to 31
characters. You will be alerted when saving an image window with too many characters.
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Apply Transformation

The active image cube file can be transformed (Utilities -> Apply Transformation) into
another cube file by multiplying each spectral vector (signature) by a linear transformation in
the form of an M x N matrix. The matrix must be an ASCII file (File->Save As Text and
answering affirmative to Matrix) or such as those optionally saved via menu items Image
-> Convert Image -> Principal Components, Functions -> Statistics -> Band Cor-
relations and Functions -> F(Signatures). The format consists of a single line containing
the dimensions of the matrix, (# rows tab # columns) followed by the M rows of the matrix
with each of the N column elements separated by a space or tab and ended with a return. An
example of a 4x3 transformation matrix is:

4 3

4.6864242694e-01  -6.9847956895e-01 2.5492193504e-01
5.0310142892e-01  4.5755700310e-01  7.0505069625e-01
5.0999322932e-01  -2.8597312694e-01 -3.8238290256e-01
5.1688502971e-01  4.7009281141e-01  -5.4009410160e-01

Algebraically, the following occurs:

AP=B for the forward transformation
AP'=B for the inverse transformation
APT=B for the transpose transformation, where

Ais each 1 by M spectral signature in the source cube

P is the M by N transformation matrix

B is each resulting 1 by N new spectral signature

P! is the inverse of matrix P, PTis the transpose of P
If the Output complement option is checked then A - B is formed.

You can use less than M rows or N columns of P, the unused rows are treated as if they
are zero and unused columns reduce the output vector dimension to 1 x cols. This allows
you to construct an output cube using just the first significant vectors (columns) of a matrix

file (see sections Image to Principal Components and F(Signatures)).

Apply Transformation

An M x N matrix file transforms the source file’s
enabled bands {1 x Mvectors)into a new N band cube
file. Less than M rows and N columns may be used
{unused rows are treated as if zeros, unused columns
reduce output # of bands to cols).

The source cube that will be transformed.

The transformation matrix to be applied.

drll
Source Cube File: 308 pixels, 960 lines
210bands, 160 enabled The number of rows and columns of the transfor-
(_select MatrixFile... ] [Matrix.gs (160x10) | mation matrix to use. In this case all of the rows
# Matrix rows: and cols: to use and columns will be applied. Setting cols less
@ Forward: enabled bands x matrix
) Inverse: enabled bands x matrix inverse than the number Of enabled bands reduces the
(3 Transpose: enabled bands x matrix transpose Output Cube to the same depth as COlS.
[ Output complement (source - transformation)
(ransorm—g——— Generate the new transformed cube file.

It will be in BIL floating point format.
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Merge LAS Files

The point cloud data in several LAS files can be merged as a single point cloud in a
newly created LAS file. All of the source files must have a common geometry. Specifically,
they must be in the same UTM zone with coordinates expressed in meters. Selecting menu
Utilitites -> Merge LAS Files displays a dialog similar to the dialog shown in Concatenate
Files. Here, the files are LAS whereas any file type can be selected in Concatenate Files.

The Continue button then produces a Save As dialog requesting a new file name for the
output. Also generated is a list of the source files and an outline depicting how the source
file’s extents (X,Y max,min) are geometrically positioned to each other. The later is exactly
the same type of diagram image produced in Mosaic that includes the name of each image
color coded within its corresponding outline.

Merge LAS File

Use Add... to construct a list of LAS file names

that will be merged together to form one LAS

output file. To delete a file click on it and

press Delete. Cancel exits without generating

any output.
A list of the LAS files to be (Addafiletolist.—~— | Display Open File dialog.
concatenated. The nuber of 53073 0107 :

199079 _011.las
les is limited to a maxi- — | |07a0125s 0 A .

fi sl . Select a file in the list and
mum output file of no more —/ click to remove.
than a 4GB point cloud. et

(" Cancel ) Continue

ASCII LIDAR to L ASF

Atext file (e.g., ASCII LIDAR) that repesents LIDAR data can be directly converted into
the LAS file format using menu Utilities -> ASCII LIDAR to LASF. Typically, each line
of the text file consists of X, Y, Z and intensity return values. The intensity value may be
absent. The X and Y values are usually UTM Easting and Northing requiring that the user
supply the UTM zone (see below). However, the program also accepts X and Y as repesent-
ing Latitude and Longitude (note their order) that can be converted to UTM, in which case,
the zone is automatically derived.

Convert ASCII LIDAR to LASF

File: 'points_al_whitney_tile10.xyz’

# records: 43078090

Rec 1: 385620.530 4042422.730 3544.300 2.1
Rec 2: 385621.240 4042422880 3543.710 1.9
Rec 3: 385620.050 4042421.210 3544.650 2.2
Rec 4: 385620.730 4042421.410 3544.640 2.3

(" LASF File Name... )

J/Images /Buckeye/LIDAR/p...s_al_whitney tilel0.las

— ASCIl Coordinate System

Preset based upon the e
numeric range of the X @ UTM (Easting, Northing, Zone) |11 | —— INeeded to complete
al’ld Y COOl’dll’lates. O Geog rahic (Latitude, Longi[ude} the UTM COOI’dS.
Transform to UTM
Cancel ( Convert to LASF )
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Applications

Shaded Relief

An image can be rendered into a synthetic image (or sequence of im-
ages) that depicts the effect of uniformly illuminating it with a parallel
light source, e.g. the Sun. Each gray value, or its associated (attached) data
Files, Data..., Raw, Multiband, NITF Files, TIFF Files), is
interpreted as an elevation that intersects and reflects the light source as a
function of the angle of incidence between the light and the slope of the el-
evation. Choosing Applications -> Shaded Relief... when a gray image

(see sections

Applications !@
Shaded Relief...
Contour...

Stereo >

Perspective...

Radiance 4

Lens Distortion...

is the front most window brings up the Shaded Relief dialog. Checkbox
Exclude zero overrides any global pixel exclusion values (see section Pixel Exclusion).

Elevation angle above
the data plane of the light

source. \

If Az sequence is checked
then a synthetic cube of #
values between Start Az
and End Az is generated.
Choosing this option dis-
ables Anaglyph.

Shaded Relief->DTED

Sun elevation is measured from the horizon and
azimuth is CCW from the X (East) direction. If
Anaglyph is checked, Parallax is used to construct a
matching left, right stereo pair and red, cyan image.
Parallax is in pixels.

Elevation: 450 Azimuth: 135.0

— —
X slope scale: 1196101 | Y slope scale: |15.8188

[ Az sequence, #: [y | *) Start AZ () End AZ
"1 Anaglyph, Parallax: N7

[T Exclude zero

(Cancel) ok

If checked then ignore zero values
when computing slopes.

| Heading angle measured

CCW from the east or
positive X direction.

The denominator used in
computing the slope in the X
and Y directions. Initial values
are computed from the aver-
age slope within the image.
The lesser these values are the
greater the shadowing effect.

If Anaglyph is checked then a red:cyan stereo anaglyphic image is also generated
using the specified Parallax value. See section Stereo Mate for an example.

O DTED

==

SR3E45 A1 =—1H1=

B

i

Gray image representation of data used to
generate the Shaded Relief image shown

to the right using the values
above dialog.

defined in the

Resulting Shaded Relief with the light com-
ing from the upper left 45 degrees above the
“horizon”. The fine vertical striping is part

of the data and not an artifact. The source
image’s data is also copied to this image.
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Contour

A non-color image can be displayed as an ordered sequence of planes
that intersect the gray values or attached data within the image. The result
is a same size color image consisting of connected line segments (contours)
at the points of intersection. In addition, the elevation at each line can be
shown dynamically by enabling the Info window and placing the cursor
over the contour line. A contour image can be saved as a polyline ESRI
Shapefile using menu File -> Save As... . It can also be saved as a color

TIEF file.

Applications

Shaded Relief...
Contour...

Stereo >
Perspective...
Radiance >

Lens Distortion...

Choosing menu Applications -> Contour... displays the dialog shown below.

The contours can represent
either the attached data or the
displayed gray values.

The Starting and Ending
contour respond to any Pixel
Exclusion setting.

Limits the spatial area to any
selection rectangle or the full

%
Enter the start, end, placement and output.
Contours may represent window gray values or any
attached data. Use menu Functions -> Owverlay to
combine the output with the source image.

— Contour using

—— @ Attached data
min: 870
max: 1516

M Exclude zero

() Window gray values
min: 13
max: 255

— Limits
/

Starting contour: 970

Ending contour: 1516

— Placement

(® Interval (spacing): B0.6EET

(") Number of contours:

— Output
| Use selection rectangle

image. The output can be
scaled by a factor of 2 and the
contour color is selectable.

The minimum and maxi-
mum values are shown and
change as a function of
the Use selection rectangle
checkbox.

The starting and ending
limits of the contours.

You can choose either the
spacing between contours
or the total number of con-
tours to be drawn.

@ 1x ()2x Color(rgh): @

E Form overlay image

Presently, set to green.

— Superimpose contours on a
copy of source image else
only output contours.

The source image representing elevation.

The resulting contours via the dialog shown.
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Stereo Mate

A Base image along with a Data image representing el-
evation that is spatially registered to the Base image can be
used to form a new version of the Base image with elevation
induced displacements by menu Applications -> Stereo ->
Mate. If the Base image is used as the red component and
the output image from Stereo Mate as the green and blue
image components. Then the resulting color anaglyph can be
viewed in stereo with red and cyan glasses. If the Base im-

LVl 1L Image Functions  Utiliti
Shaded Relief...
Contour...

Mate...

Compilation...

Perspective...

Radiance >

Lens Distortion...

age is color the Stereo Mate image will also be color and if placed along side of each other

as narrow strips you can view them with a pocket stereoscope.

Select Stereo Mate Images

Select two images. The base image forms
the stereo mate and the data image
represents a registered elevation matrix.
The scale determines the vertical

exaggeration. Multiplicative factor applied
to the Data image.
Base image: | L.tif }—é—j/ g
Data image: M If the Base image is a cube band
¥ 3 . / .
Scale: Joos | [ Entire cube —| then this check box allows generat-
—— p=——\ ing a stereo mate for every band in

the cube.

An anaglyphic stereo
image generated by us-
ing R,G,B to Color and
selecting red as the base
image and blue and green
as the stereo mate. View
via red and cyan glasses.
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Stereo Compilation

Two overlapping images that have associated Rational [N Eul 'mage Functions Uil
Polynomial Camera (RPC) models can be stereo triangulated Shaded Relief...

. . . . Contour...

to extract geographic or UTM coordinates using menu Appli-
cations -> Stereo -> Compilation. In addition, stereo com-
pilation can be performed to generate an elevation matrix and
orthographic and anaglyphic images. The RPC’s relate normalized latitude or northing (U) ,
longitude or easting (V) and height (W) to normalized image coords as follows:

Stereo

- Compilation...
Parenartive

Define cubic polynomials Px1 and Qy1:

Px1(U,V,W) =a0 + al*V + a2*U + a3*W + a4*V*U + a5*V*W + a6*U*W + a7*V*V
+ 8*U*U+ a9*W*W + al0*U*V*W + al 1*¥*V*V*V + al2*¥V*U*U
+ al3*V*W*W + al4*V*V*U+ al5*U*U*U + al6*U*W*W
+ al7*V*V*W + al8*U*U*W + al 9*WHW*W

Qx1(U,V,W) =b0 + b1*V + b2*U + b3*W + b4*V*U + b5*V*W + b6*U*W + b7*V*V
+ b8*U*U+ b9*W*W + b10*U*V*W + b11*V*V*V + b12*V*U*U
+ b13*V*W*W + b14*V*V*U+ b15*U*U*U + b16*U*W*W
+ b17*V*V*W + b18*U*U*W + b19*W*W*W

Define similar polynomials Py1, Qy1 with their owns sets of coefficients giving a total of 80
coefficients for one image.

Then the normalized image coords (X1, Y1) for image 1 are computed as:
X1 =Px1(U,V,W)/Q1x(U,V,W) Y1 =Pyl(U,V,W)/Qly(U,V,W)

with a similar set of equations for image 2 with a corresponding set of RPC polynomials.
X2 =Px2(U,V,W)/Q2x(U,V,W) Y2 =Py2(U,V,W)/Q2y(U,V,W)

Therefore, measuring the same (conjugate) point on both images yields 2 pairs of image
coordinates (4 equations in 3 unknowns) which are solved via least squares to produce the
normalized latitude or northing (U), longitude or easting (V) and height (W). Visit www.spa-
ceimaging.com for source information pertaining to RPC models. Also, search for “Rational
Polynomial Camera” in www.google.com.
The steps to perform stereo triangulation are delineated below.
a. Each image must have RPC data. This is needed to provide.
b. Select two images from the dialog Image 1,2 popups.
c. Load the RPC’s for each image via the Load RPC button, if necessary.
d. Follow the dialog instructions. Alternately shift-click on each conjugate point.
Latitude, longitude and height will appear in the list window.
e. Use button List to create a formatted list of the results.
f. If a solution isn’t possible “Invalid RPC computation” will appear in place of
the coords.
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When at least one point has been triangulated you can perform a stereo compilation
surrounding that point or any chosen selection rectangle appearing on Image 1. Currently,
Stereo Compilation is still under development and there will be changes and refinements to
the dialog interfaces in the future. The Stereo Compilation dialog is shown below and the
controlling details are shown in the Parameters and Recompile dialogs on the following
pages by clicking the respective buttons.

The example shown here has an associated RPC file defined in UTM coordinates (North-
ing, Easting). If the coordinates are given in geographics (Latitude, Longitude) then the
dialog labels and values will change appropriately.

Select 2 images from the available images 860 Stereo Compilation

ShOW”l ln tl’le popup menius. If‘there iS a te.xt gric]:ti_c;”;:(s?irlti.mage point in image 1: '219rgb.tif (1:9)".

file with the same base name as the image . W (e W

name concatenated with _rpc.txt then it will be e s [EDEERES) m) (Red )

loaded. Else, you can load any RPC file via _ _
219rgb.tif (1:9) Anaglyph 220rgb.tif (1:9)

menu Edit -> Options -> Attach RPC File. If
an image is true color then select the compo-
nents to be used as the basis for all operations.

Image area surrounding the selected list
point. Use Scale and Angle to orient for 3

: Rewverse anaglyph

X parallax (pixels): _ 0.0 ¥ parallax (lines): _: 0.0
proper stereo parallax viewing. S . -
Northing: : 3457309.1 Morth delta (mtrs): | 4.44
Manually introduce X and Y parallax into -
Image 2’S Compuled l'mage COOFdinates. Easting: 2 B07457.9 East delta (mtrs): 4.44
Height: E 239.42 H delta (mtr): 1.00

Interactively offset the Northing, Easting
and Height of the given selected list point. S — Haight

| 1 725,588 484,563 3457309.1 6B7457.9 239.4
Select a point in the list and | | I 50 55 lwri aovs se

4 683,415 279,387 3456747.2 6BE634.9 227.9
use Del button to delete. \

Load/Save list points. TroxdPs.. ) ((saveps. ) ( Pajams... )

/ st ‘-/&(-:o-nnllu... "/ Compile )

\“‘_\De!ete Pt ) .’Em —» | 725 588 404 563

Generate a separate text window
with formatted results.

Displays a dialog listing previous com-
pilations that can be recompiled using
various criteria.

The Params... button will be enabled
after a point is selected from the list.

The following pages contain the stereo compilation results of a user selected area along
with the specific compilation parameters. In this source image Northing is to the right and
Easting is downward. Stereo compilation outputs are always oriented so that Northing
(Latitude) is upward and Easting (Longitude, east direction) is to the right. Therefore these
outputs appear rotated 90 degrees counter-clockwise relative to the image area. See section
Rational Polynomial Coefficients Files for a listing of one of the two RPC files used.
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eee 2109rgb.tif (1:18)

A

Image 1 of a stereo pair showing the selected b s T
compilation area after choosing Selection
rectangle in Stereo Compilation Parameters.

Compilation area shown in blue result-
ing from user selection rectangle.
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Stereo Compilation Parameters

— Image Scale
Image 1 and 2 Ground 5ample Distances (GSD) are 1.00 and 1.00 meters per pixel respectively.
An 'Output scale factor' of 1 preduces image outputs with a pixel size equal to the GSD.
Increasing/decreasing the 'Qutput scale factor' effectively increases/decreases the output G5D
and results in a minification/magnification of the image output size.

— Compilation/QOutput Areas

Comp pixels: 123 lines: 128 Output scale factor: 1.00
¥ Centered around point: 1 Output pixels: 128, lines: 128
Selection rectangle on image 1 Qutput GSD: 1.00
— Image Outputs
@ DEM image @ Correlation image ; Corr vs height cube
Ortho image _ Kernel image _ Height vs kernel cube

EAnaglyph image
Ortho/Anaglyph interp: ' Cubic [

Height vs parallax cube

r— Correlation Parameters

Decreases kernel size from max to min while height Max kernel size (odd): 17
delta and correlation are within the entered values. = :
Min kernel size (odd): 7

Height limit range {mtrs}:

min: 200 max: 62.00 Height delta limit: 3.00
Height resolution (mtrs):  1.00 Correlation lower limit: 060
(" Cancel ) € ok

Image Scale:

Lists the relationship between a 1 pixel spacing in the image and the corresponding
spacing, in meters, on the ground. This is determined by the values in the RPC file and is a
nominal value for the entire image.

Output Area:
User defined values that set the output size of the various images.

Pixels, Lines -  Defaults to 128 by 128, changes automatically if Selection rect
is chosen, below. This will be the size of Image Outputs.
The orientation is always North (Latitude) is upward (lines)
and Easting (Longitude) is to the right (pixels).

Output scale -  This is a relative number. A value of 1 represents an output
pixel equal to the Ground Sample Distance (GSD).
Increasing the scale increases the area that is compiled so that
an output pixel represents a greater distance on the ground.
A smaller scale essentially magnifies the area to be compiled.
Note: Output scale factor does not change the output size.

Centered around... Uses an area of Pixels, Lines centered on the selection point
as the nominal compilation region.

Selection rect... Uses the area defined by a selection rectangle drawn upon
Image 1, if a selection rectangle exists, as the compilation
region.
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Image Outputs:

Each output image is the size determined by Pixels, Lines. All images are 32 bit float
except the anaglyphic image which is true color (24 bits).

DEM -
Ortho image -
Anaglyphic image -

Correlation image -

Kernel image -

Corr vs height -

Height vs kernel -

Height vs parallax -

Digital elevations. Needed for the Recompile Image dialog.
An orthographic image for each source image area.
A red/cyan stereo image using Image 1 ortho.

The linear correlation values for each elevation. Also, needed
for the Recompile Image dialog.

The final size of the correlation kernel for each elevation.

A floating point cube consisting of height(max-min)/delta
bands of correlation. One correlation for each height plane.

A floating point cube consisting of kernel(max-min)/2+1
bands of elevation. One elevation for each kernel size.

A floating point cube is constructed. Each plane represents

a specific x,y parallax offset. If this options is selected the
dialog below will appear when the Compile button in the
main Stereo Compilation dialog is chosen. Enter the starting
and ending X,y parallaxes and the number of steps. The
compilation will proceed and generate a DEM and correlation
for each combination of x,y offsets. The result is assembled
into a cube. These offsets are independent of those selected
in the main Stereo Compilation dialog which are not used.
Menu Functions -> Statistics -> Band Correlations can be
used to analyze the results.

Height vs Parallax

‘Height vs parallax' is checked in the Parameters dialog. A
sequence of compilations will be generated based on the x
and y parallax offsets entered below and assembled into a
cube. The number of planes is the product of the steps.

Starting x parallax: -1 Starting y parallax: -1

Ending x parallax: 1 Ending y parallax: 1

Number of x steps: 3 Number of y steps: 34 .

ok )

e
[ Cancel )
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Correlation Parameters:
These determine the correlation size (kernel), height range and various limits.
Height limit - Height determination is limited to this min, max range.

Height resolution - Change in height between correlations for a given
kernel size.

Min, max kernel sizes - The minimum and maximum size correlation areas.

Height delta limit - Each change in kernel size must produce a change in height
less than or equal to this value to continue to a smaller
kernel size.

Corr lower limit - Stop decreasing the kernel when the correlation coefficient
for a specific height determination is less than this value.

The procedure used in determining a height value follows this algorithmic scenario:

a. Set latitude and longitude to upper left corner of output area.

b. Choose a kernel size (starting with Max kernel size).

c. Set height to minimum.

d. Compute image’s pixel values using RPC equations for each point within the
the kernel and add/subtract any X and Y parallax entered in the main
Stereo Compilation dialog. Parallax correction is applied only to Image 2.
If Parameter dialog option Height vs parallax cube is checked then it will
substitute its own dynamic parallax values.

e. Compute the linear correlation coefficient between the 2 arrays of pixels and save.
One height produces one correlation value for this kernel size and position.

f. Increment the height by Height resolution and repeat steps d. and e. until the
maximum height is reached. Now have an array of correlation values.

g. Find the maximum correlation value and the corresponding height (same index).
This produces an elevation for this kernel size.

h. If the correlation value that generated this height is greater or equal to
Correlation lower limit and the difference between this height and the height
produced by the previous (larger) kernel is within Height delta limit then
decrement the kernel size and repeat steps c. thru g. When these conditions are
false or the kernel size equals Min kernel size then the last height satisfying
the conditions is associated with the current latitude and longitude.

Generally, you want the smallest kernel size that produces a valid correlation
and slowly changing height vs kernel size.

i. Increment the longitude or latitude an amount determined by Output scale and
repeat all steps until the output area is covered.
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Notes:

It very important to set the Height limit range so that it encompasses the expected range
of elevations within the selected compilation areas. Not doing so will result in limited values
in the DEM image and erroneous ortho and anaglyphic outputs. View the DEM histogram
(menu Functions -> Plot -> Histogram) and check that the histogram is wholly contained in
the plot. The counts should taper off to zero at each end. If not, expand the height limits in
the Stereo Compilation Parameter dialog and rerun the compilation.

Each DEM output image has a title that identifies the compilation parameters that gener-
ated it. The first part is simply “DEM?” followed by the number (in sequence) of the output.
This number matches the correlation, ortho and anaglyph outputs so that they can be identi-
fied as a group. Each ortho contains either “a” or “b” for Image 1 or 2 respectively. If a
DEM is recompiled then the source DEM number is affixed to the new DEM number and ap-
pears within parentheses. Shown below are examples of a compilation and its recompilation.

Height limit range Height limit range
Height resolution Height resolution
Min and Max kernel size Min and Max kernel size
Height delta limit Number of std’s
Corr lower limit Corr lower limit
Image is zoomed
for clarity.

806 DEM1 262 1717 3 0.6 (2x) - ®06 DEM2(1) 2 62 1 25 25 2.5 0.65 (2x)

Elevation output image. The matching A recompilation of the DEM image shown
correlation, orthos and anaglyph images on the left. The “(1)” in DEM2(1) indi-
are titled: cates that is a recompilation of image
Rhol; DEMI1. See Stereo Recompilation for
Orthola c details.
Ortholb c

Anaglyphla ¢

“c” stands for cubic resampling.

where
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Stereo Recompilation:

A DEM output image can be recompiled as long as it was generated during during the
current Stereo Compilation dialog. This is done by choosing the DEM from a popup list
and selecting the criteria that determine which of the heights in the DEM will be recompiled.
Each height in the DEM is tested against the selected parameters and a new height is gener-
ated using the specified kernel size. Generally, a larger size kernel will produce an average
height with a smaller deviation from the DEM’s mean and a higher correlation. Note: a
recompiled DEM can again be recompiled.

Shown below is the Recompile DEM dialog. The current options are still being devel-
oped and like the basic Stereo Compilation dialog they will change.

Recompile DEM

A list Ofpreviously Compiled DEM Recompile heights statistically out of range or with low
. correlation. Choose a DEM image from the popup menu.
Ou[put images. Select the Criteria, Logic and Qutputs. The mean height
is computed once for the entire DEM unless
‘Recompute...’ is checked.

Height and correlation criteria to decide DEM image: (DEM1262171730.6 [3)
which DEM values to recompile. — Criteria & Locality

@ Height out of range, # std dev from mean: |z
lfC]’leCked then the mean and std are com- [ ™ Low correlation, min corr coefficient: 0.60
pul-edfor each kernel size area surround- ™ Recompute mean height for each kernel size area
ing the tested DEM pixel instead of one Recompiiation kernel aoa size =

computation for the entire DEM.

— Logic

// ¥ Match both criteria
If more than one criteria then how they O Match either criteria
are logically combined. — Outputs

@ Correlation image
| Create new orthos and anaglyph images

What new outputs are created in addition — ] ™ Modified pixels mask
t? anew DEM. If a matching correla- —
tion image was not generated when the

selected source DEM was created then a

new Correlation image is not created. Generate a red mask image displaying
each corresponding pixel that meets the

given criteria and is recompiled.
Parameters:
Each height pixel in the DEM is tested against the chosen Criteria using the parameters
listed below and if out of range that pixel is recompiled with the Recompilation kernel.

# std dev from mean - Recompile each height < mean - (#)*std or
height > mean + (#)*std.

min corr coefficient -  Recompile all heights for which the corresponding correlation
for that DEM was less then the given lower limit.
Note: in order to use this Criteria the chosen DEM image must
have been compiled with the Correlation image option in

the Stereo Compilation Parameters dialog.

Recompilation kernel - The size of the kernel to use when recompiling a pixel
that meets the criteria.

HyperCube Pictorial User’s Guide  09/06/12 165



Perspective

A data image of elevations can be reconstructed as if viewed from almost [EFTlmn :
any perspective by applying basic photogrammetry. If there is a correspond- gli‘:zgr“e”ef---
ing Base image, i.c., each feature pixel is one-to-one with an elevation then
the features themselves can be draped across the elevations to yield a different
perspective. The process is initiated by selecting Perspective... from the Ap-
plications menu which displays the following dialog. All values may be interactively modi-
fied.

866 Perspective

Select two images. The Base image forms the
perspective and the Data image is a registered

Stereo

elevation matrix. X,Y,Z is the perspective point. Z
Omega, Phi and Kappa are the sequential Kappa
photogrammetric angle rotations about X,Y,Z. kj\

Base image: “Shaded Relief f l

Data image: | dted =% l

"] Output Data perspective

Image point

Focalllength —
—— Perspective point

X: ;--256_00' v: [§) 47200z [7) 256.00 inc: 1.00 Omega
| Generate a Start -> End sequence, #: MN/A *) Start pos End pos. G X
Omega: ; -32.00 Phi: ; 0.00 Kappa: ; 0.00 inc;  1.00 DTED point

" Link Omega & Phi to X,Y,Z (" Reset )

Data scaling: 0.05 Focal length: £11256.00 | inc: [1.00 ( Perspective Phi

Y

Base Image: Feature image that is transformed into the perspective view. The Data
image may also be used if no Base image exits.

Data image: An image whose pixels are interpreted as elevations. See section Raw.

Output Data... If checked then a perspective view of the selected Data image will also
be generated else only the Base image is constructed.

Starting pos.:  The coordinates of the perspective or view point relative to the Base
image. The origin is the upper left pixel with positive X in the right
direction and positive Y moving downward. Z is above the image.

After selecting the Base image, X,Y,Z are preset to above the middle of
the Base image at a height of the maximum of X and Y. You can readily
edit these values. Note that X,Y,Z is a point, not a direction, that is
determined by Omega, Phi and Kappa.

Ending pos.: If Generate a sequence, below, is checked then this is the ending
view point of a uniform set of view points and angles that will be used to
generate a synthetic cube movie.

Generate a sequence: If checked then # equally spaced view points are constructed and
assembled into a cube.
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Omega, Phi, Kappa:

Link Omega & Phi to X,Y,Z:

Data scaling:

Focal length:

Reset:

Perspective:

The rotations about the X, Y, and Z axes respectively in degrees.
If Link Omega & Phi is checked then the perspective orientation is
fixed pointing to the center of the Base image. Therefore, a Sequence
will produce a fly-by perspective with an invariant center.

If checked then Omega and Phi are automatically
computed as a function of X and Y so that the perspective view is pointed
at the center of the Base image. You can check this box to force a
centered view, click an Outline button and then uncheck it to modify
Omega and Phi manually for a more desirable view. See the Outline
buttons described below.

The multiplicative factor applied to the Data. The smaller the number
the “flatter” the perspective appears. Usually, a value of .05 is a good
starting point. The larger the scaling the more exaggerated the effect of
elevation and the longer the computation time.

How far behind the perspective point the imaging plane lies. The greater
the focal length the larger the nominal magnification. A small Focal
length is analogous to a wide angle lens. The initial value is set equal to
the Z coordinate and produces a one-to-one scale.

Changing the Focal length does not change the output image dimensions.

Set the perspective back to the initial starting values as if viewing
the image from a point directly over the center with no rotations.

Generate the perspective image(s).

O

Shaded Relief

==

O

Perspective Yiew =—H1 5

)
e

”

7,

J- .. -~

' s
s
Fd

i!

A shaded relief image generated from
elevation data is used as the Base im-
age and provides the features that will
viewed from a different perspective as
shown to the right.

be

L

The reconstructed perspective image

using the photogrammetric parameters

entered into the previously described user

dialog.
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He——————— el e——— B

Select two images. The Base image forms the
perspective and the Data image is a registered
elevation matrix. X.¥.Z is the perspective point.
Omega, Phi and Kappa are the sequential
photogrammetric angle rotations about X,¥.Z.

Base image: | FTH21_24.061 =)
Dataimage: [dtedtobandéd | 3]

X: |e||153.53| ¥: |e{|255.aa | z: @|329.aa | inc: [1.88
[ Generate a Start -> End sequence, #: @ Start pos. ) End pos.
Omega: |¢”5a.27 | Phi: |¢“a.aa | Kappa: |e{|a.aa | inc: | 1.00 |

[ Link Omega & Phi to X,V,Z
DIEDscaling: .4 | Focal length: [5][1280.0( inc: [1.00 |

The above dialog was used to select and generate the perspective im-
age shown here. Both images were then rotated 180 degrees to produce
the final views shown below. Note that Link has been selected to force

pointing at the center of the source image.

0 - Band 64 Perspective
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Radiance

Applications -> Radiance -> Emissivity processes PP T - Functions Utiitie
thermal images, generally in the range of 3 to 18 microns, Shaded Relief... |
that are in radiance units of Wm?2ym™. Structurally, there is Contour...
no distinction between a thermal image cube and a visible Stereo
to SWIR cube, only the wavelength definition. HyperCube Perspective...
allows you to generate a temperature data image and op- Radiance Emissivity...
tionally, an emissivity cube. The temperature is derived by G Preodie :32::[;}; e
comparing the radiance of each image cube pixel with the
radiance of a series of black body curves. The closest match, via a user specified tolerance,
produces the temperature for that pixel. There is also a utility, Plot BB Curve, that can dis-
play a black body radiance curve for any given temperature.

Shown below are the various user dialogs. Note that the routines require wavelengths to
be in microns (zm) but that the temperature can be in centigrade, Kelvins or Fahrenheit.

Plot Black Body Curve —— O0=——— BBPitiI——""HH
Enter the wavelength endpoints in pm o Value Elack body st $00.00 K°
i 99527
an,j the tempera_ture inthe selected Zazads @298
units for the desired black body 7.4451 25114 e
74571 83309 :
Initial wavelength: |7.433 T4E32 23503
Y 74813 B836.95 497 .63
Ending wavelength: TA4E3 2IE86
4 g 75054  840.76 24380
Temperature: TIITS 54285
@® KE ocC O 300.000 75295 84452 000
O scal O 10x 74330 259742 105155 12,0567 13.597
cale
Plot Black Body Curve ———x= O=———BBPlsti ————————0 8
Enter the wavelength_endpoints inpm i (i Elack body at 590000 K°
an,j the tempera_ture inthe selected p—— ] 2:9%e+03
units for the desired black body e = P
04082 26E0ESES0 kil
Initial wavelength: |4 04123 2706178550
- 04164 27EM4TS0l |1 4BetD3
Ending wavelength: |2, 04203 753149208
g g o4246 273153480 | 7 zo40s
Temperature: -5g|]|]_|]|]|] 04287 zveEsvrem] |
@K QC OF° 04328 21215259 | 5 poeson
O scal O 10x 04000 09240 1.4479 19719 2.4959
cale

Menu Applications -> Radiance -> Plot BB Curve dialogs, on the left, and
their corresponding black body radiance curves on the right for the given
temperature and wavelength ranges.
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Menu Applications -> Radiance -> Emissivity displays the following dialogs. The
default values shown were used to produce the displayed outputs from a thermal image cube.

Emissivity

A thermal radiance cube is used to generate a
black body (BB) temperature image (data) and
mask. The BB curves may be applied to the cube
to construct an emissivity cube file.

@ Plot min, max & mean temperature BB curves
__| Construct an emissivity image cube file

| Add temperature image as cube's last band
@ Save temperature image & mask

@ Mask deviation from mean temp: |2

: Mask percent of distribution: 1
Temperature image units: @ K* ) C* O F°

@ Exclude any ‘Band List' disabled bands

’ Cancel ) ( Options... ) ( oK §

Emissivity Options
Black body fit parameters:
Initial temperature: 350 (Init T)
Temperature diff divisor: 2 (DSTEP)
Temperature diff limit: W (DLIM)
Emissivity target:  0.99 (ELIM)
! Use Downwelling Rad Sig ~ {Load DR5...)
Pre-computed black body table (K™}
Minimum temperature; 273
Maximum temperature: 350
Temperature delta:  0.05

The output image at left is a mask showing the warmest, red, and coolest, blue, regions
within the thermal image cube, i.e., those temperatures 2 or more deviations from the mean.
At right is a shaded relief of the temperature image that has been similarly coded. The cool-
est region coincides with a creek. Below is the histogram of the temperature data image in

units of degrees Kelvin.

Min: 299 28
Max: 323.08
Mean: 310.329

Mode : 204.76
Median: 310.63
Surn: 10525032 SD:4.32

Jetlz ROAD_BLOCK1 Temp K2 Histogram

coords: (1,10 - (127 267)

3 Zet0Z
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Menu item Applications -> Radiance -> ISAC performs the “In Scene Atmospher-
ic Compensation” (ISAC) algorithm on a thermal hyperspectral image which as in the
Emissivity function must be in radiance units of Wm=2um. This function attempts to re-
move the effects of the atmosphere and is described in publication: JGR-Atmospheres:
Young, Johnson and Hackwell, ‘“An in-scene Method for Atmospheric Compensation of
Thermal Hyperspectral Data”, 21 December 2002.

The current options available are shown below.

In Scene Atmospheric Compensation

A synthetlc Cube 1§ generated Where The ISAC algorithm as described in ref pub:

each plane is an sdtol mask dependent JGR-Atmospheres: Young, Johnson and Hackwell,
“An in-scene Method for Atmospheric

ona Valueﬂom ﬂ’le sequence. NO 0[]1@}" Compensation of Thermal Hyperspectral Data:",
12/21/02

output is produced.
Black body signature tolerance (sdtol): |001
| Generate sequence, # of outputs: MN/A
Only bands between these limits will selniisie s W

. . Ending sdtol: MNfA
be used in computations.
Starting band for brightness comp: 21

Ending band for brightness comp: 101

If checked, any bands that are disabled in

. . . ~ ] Exclud ‘Band List' disabled band
the Windows->Band List and will also be — mxcluce any San@ List disabled bands

excluded from computation. (Cancel) (Options...)
® O 6 053 soil B O © Black Bos ISAC Options

Eand 1of 128: 7.369 pm Nota:

If a sequence has been selected in the
main ISAC dialog then the following
options are not available.

E Construct a corrected radiance file
% ™ Transmittance and upwelling plots

Create temperature image
BlaCk bOdy output &l Slope vs intercept listing
Source image mask for an sdtol
value of .0045.

B

Temperature image units: @ k> O c O F

(Canee) (aa

Various possible output products that
may be selectively enabled if sequence
has not been selected in the main dialog.

® O © Transmittance vs Wave (0.0045) 6 O O upwelling vs Wave (0.0045)

Graphs of transmit-
tance and upwelling

1.01 S

{u -3 a0
versus wavelength
051 . 250
respectively.
023 19
o.oo =2
TE 9.1 105 120 125 TE 9.1 105 120 125
Transmittance vs Wave (0.0045) Upwelling vs Wave (0.0045)
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Lens Distortion

A digitally acquired image can be geometrically corrected for lens distortion by selecting
menu Applications -> Lens Distortion. HyperCube uses the parameters as defined by the
USGS/EROS Report of Camera Calibration (visit web site: http://erosproject.cr.usgs.gov/
osl). Note that the USGS parameters define corrections, i.e., the uncorrected image coordi-
nates are transformed via these parameters to produce an x and y delta that is added to the
measured distorted coordinates to yield a distortion free x and y coordinate. HyperCube uses
the USGS parameters to generate new parameters that correspond to the inverse transforma-
tion that maps a distortion free output space into the distorted space. Besides generating a
corrected image in memory you can also read, correct and store an entire directory of TIFF

images.

Shown below is the main dialog window. It contains controls to load, view, edit and plot
the USGS reports. You can select an in-memory image for correction as well the source and
destination directories for batch processing.

Select calibration file.

Display calibration
parameters and their
inverse.

Use Cal file to correct
Image.

800

Lens Distortion

USGS calibration reports can be displayed, plotted, and used to
produce an image free of lens distortion. Additionally, an entire
directory of TIFF image files can be corrected using the same
calibration and stored within a directory.

— USCS Calibration Report

[Images /Buckeye/ Sioux FaIIs/ZlOmm_/

Cal file:

load.. ) (_ List (Edita) (P |
— Source

Image: 44214.tif [

—
Create Corrected Image )

— Batch Process

Source dir: flmages/Buckeye/Sioux Falls

Destination dir: fimages,/Buckeye, Sioux Falls/Corrected

( Selegt Src Dir... \ ( Select Dst Dir... \ ’ Process \

/
/ \

Select batch source

directory.

Select batch desti-
nation directory.

® O @ 210mm_15043597.doc Par...

Cal Date: 21 Oct ZOGE6
Camera SH: B2B623
Lens SM: 15843507

Unit=s mm
Pixel size {(H} B0.8868
Pixel =zize (V) 0.9068

Fixels e
Lines S4z28
C 214.353

xP 8.2569

YP @.4440

XIFF @

YIFF @

F1 —3.91853=—06
P2 -1.26853=—06
P32 a

Pd a

K@ 1.88734855e—62
K1 —-1.4843236%e-05
K2 S.842428601e—11

K3 -1.77141627e-13
K4 8 . BEE0EE0E+E0

II‘1n:1>< radial distance: 38

The result of selecting the List
button. The extracted param-
eters from the calibration file are
shown on the left. The computed
inverse parameters are displayed
to the left. Parameter names cor-
responds to those in the USGS

Current calibration file.

Plot correction and
inverse correction.

Display Lens Distortion
Parameters Dialog.

List in-memory images
that may be corrected.

Generate corrected
group of TIEF files.

® O ®210mm_15043597.doc Inv...

Cal Date: 31 Oct 2006
Camera SH: B20623
Lens SH: 15843507

Unitzs mm
Pixel =ize (H) ©.8068
Fixel size (V) 0.9063

Fixels 7228
Lines D428
C 214.353

XP a.2569

“P a.4449

XIPP B

“IPP B

F1 2.91873e—66

P2 1.36844=-66

P2 @

P4 @

Ka —9.97304845e-03
K1 1.426034287-05

Kz 5.22141577e-18
K3 2.58247242e-13
K4 8. BEE0EEEE+E0

IHax radial distance: 28
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Selecting Plot from the Lens Distortion dialog generates the plots shown below for the
loaded USGS Report. Those on the left display the radial and decentering correction deltas
that are added to a measured x,y coordinate to produce a corrected x,y pair. The right hand
column of plots are generated by computing the coefficients of the inverse equations defined
by the Report. Although the Report uses focal plane millimeters, axes are shown in pixels.
In this case, for a focal plane array that is 7228 pixels by 5428 lines with a pixel and line
spacing of .0068 mm and a maximum valid radius of 30 mm from the principal point.

Each plot represents a correction (delta) that is added to an image coordinate to produce a
new X,y coordinate. The left column corrections are applied to the distorted image to pro-
duce an distortion free position for that pixel value. The right column is the inverse: given a
distortionless coordinate, where is the distorted pixel (coordinates) that belongs there. The
inverse transformation is used to create the new distortion free output image. It will be the
same size as the input image. Any boundary voids that may arise are replicated from the
source image.

©® O O 210mm_15043597.doc (1) © O O 210mm_15043597.doc (1)
14.2 153
T4 Te
an 0z
-74 73
-14.9 -14.9
u} 103 2208 3309 4412 u} 1103 2206 FI09 4412
Radial correction (pixels) y Radial inverse (pixels) /
Radial distortion correction. Radial inverse correction.
| ! D 210mm_15043597.doc (x) | OO 0O 210mm_15043597.doc (x)
-0.00 1.2
-0.35 1.05
-0.70 0.70
-1.05 035
-1.39 0.00
u} 103 2208 3309 4412 u} 1103 2206 FI09 4412
W decentering correction (pixels) y W decentering inverse (pixels) /
X decentering correction. X decentering inverse.
| ! ) 210mm_15043597.doc (y) _' 210mm_15043597.doc (y)
-0.00 0.24
-0.21 0.63
-042 0.4z
-0&3 0.21
-0.84 0.00
a 1102 2206 2309 4412 a 1103 2206 Z3I09 4412
¥ decentering correction (pixels) y ¥ decentering inverse (pixels)
Y decentering correction. Y decentering inverse.
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The Edit button on the Lens Distortion dialog displays each parameter in an edit field
as shown in the dialog below. These values are very specific to the equations in which they
are used and are in millimeters (HyperCube uses Pixel size to convert everything to digital
values). Specifically, the USGS Report uses them as follows (more details can be found at

http://erosproject.cr.usgs.gov/osl):

Xbar = (X - XP) Ybar = (Y - YP), where X,Y are measured coords
and XP, YP is the principal point

R = sqrt(Xbar? + Ybar?), where R is the radius in mm

Radial correction:
Xc = Xbar*(K@ + K1*R2 + K2*R* + K3*R® + K4*R8),
Yc = Ybar*(K@ + K1*R2 + K2*R* + K3*R® + K4*R8),

Decentering correction:
Xd = (1 + P3*R? + P4*R")*(P1*(R? + 2*Xbar?) + 2*P2*Xbar*Ybar),
Yd = (1 + P3*R? + P4*R")*(P2*(R? + 2*Ybar?) + 2*P1*Xbar*Ybar),

Final new coordinates:
Xcorrected = X + Xc + Xd
Ycorrected = Y + Yc + Yd.

Note that Focal length and Max radial distance are not used in the equations. The later
parameter defines the limit of the corrections accuracy.

Lens Distortion Parameters

Edit/modify the USGS lens distortion parameters. All
values must correspond to mm measurements as defined
in the Lens Calibration Report:

(visit http:/ /erosproject.cr.usgs.gov/ osl).

Pixel size (H mm): ||0.0068 Pixels: 7228
Pixel size (V mm): 0.0068 Lines: 5428

XP:  0.2569 XIPP: 0

YP:  0.4449 YIPP: O

Pl: -3.91083e-06 P3: 0

P2: -1.36853e-06 P4: 0

KO: 1.00734085e-02 K3: -1.77141627e-13
K1: -1.48432309-05 K4: 0.00000000e+00

K2: 5.84248691e-11

Focal length: 214,353 Max radial dist: 30

The result of selecting Edit in the Lens Distortion dialog. Edited pa-
rameters are checked for blunders and consistency when OK is clicked.
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Miscellaneous

lcons

HyperCube has a family of 8 Finder icons. Five of these are regular Mac data types and
represent TEXT, JPEG, PICT, TIFF and Sun Raster Format files. The other three represent
the HyperCube application, unformatted binary data and PhotoShop™ convolution kernels as
shown in the figures below.

HyperCube application icon.

Hyper ASCII text file, e.g., *.hdr, *.wvl.

L]
L=
o
i

Image files saved in JPEG, NITF, Pict, SRF, and TIFF formats.

Unformatted image file saved as Raw.

PhotoShop™ convolution kernel of type 8BCK.

E i K

Double clicking an image icon will automatically launch HyperCube and the load the corre-
sponding image. Similarly, a *.wvl or *.hdr icon can be double clicked as well.

The Windows version does not have an icon family, only the application has an icon.
Any HyperCube documents must be opened within the application.

Error Messages

When HyperCube detects an internal error such as
running out of memory it generally can recover enough 0 Enulting dilbests Cindsifisr storage.
to allow you to at least save and print. There is one se-
rious type of error dialog that may be presented indicat-
ing that an immediate exit is warranted. But if you have
generated some result that just must be saved or printed || [Stop (exit program)]  [Continue! (crash?)]
then HyperCube can be forced to continue at risk of an
immediate crash. Generally, the exit path should be
taken especially if it is followed by another dire warning.

This error message will not appear in the Windows version.
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Capturing the Screen and Listing Pixels

The contents of the main display screen may be captured at any time other than a modal
dialog (i.e. those demanding attention) by simultaneously pressing the command 1(one) keys
(Ctrl 1 in the Windows version). This creates a new true color window of the entire display
that may be saved like any other pict image. Note that a full screen color window requires
approximately 2MB for 832 pixels by 624 lines. HyperCube checks for sufficient memory
and warns if it is insufficient.

Additionally, in the Windows version you can automatically copy the entire active win-
dow to the clipboard by depressing Ctrl Print Screen. Then choose File -> New... followed
by Edit -> Paste to place it in a window where it can be saved.

Pressing key combination: command 4 on the Mac and Ctrl 4 on the PC when the cursor
is positioned over an active (front most) image window will create one or more text win-
dows containing a listing of pixel values surrounding the cursor. The display values and the
underlying pixels (e.g., 16 bit, float) values are listed in a 15 by 15 array. True color images
produce a separate list window for each color.

Saving and Copying Scrollable Lists

Any window which has a scrollable list, e.g. spectral plot, band correlations, that does
not contain a specific Save button may still be written to a file by selecting Save from the
Edit menu. This will bring up the standard file save dialog. The data will be formatted as
tab delimited ASCII text and can be reread by any application that reads text. Also, this same
scrollable list may be copied to the clipboard as tab delimited, c/r terminated lines of text by
choosing the Edit -> Copy menu and then pasted into another application.

Loading/Saving Text Files

Any small text file can be opened and displayed in a scrollable list. This is especially
useful for examining header files. The file is opened by choosing menu File -> Open As
and Text from the format dialog popup. It can then be edited (Cut, Copy and Paste) and
resaved. The up and down arrow keys and the page up, page down keys are used to navigate
through the text. Choosing File -> New... and selecting the Text option will open a blank
Text window that may be typed into and saved as text.

An image or any selection may be saved as an ASCII text file by choosing menu File ->
Save As and Text as the format (and optionally as a matrix, see section Apply Transfor-
mation). The pixels are tab delimited with each line followed by a return. The size of the
resulting file may be 4 or 5 times larger than the source.

Note: Any embedded zeros within a text file are automatically removed when the file is
read. Carriage returns on the Windows version are followed by a newline character.

O —dmadtedhdr —BE|  Using menu File->Open As, Text and selecting a header file,
samples = 512 *.hdr, results in the window at left. This may be edited and saved,
e 2 S functioning as a simple word processor. Dragging the cursor
L‘a‘fattugppee::”;'?” within the window’s content area will automatically scroll expos-
et | ing additional lines as will the arrow and page keys. Text will
umpiels = 512 either wrap-around or limit itself to a line if a carriage return oc-
EEI’;T&SEF :5;12g sndian curs within the width of the window. The window may be resized
it as necessary.

7

HyperCube Pictorial User’s Guide  09/06/12 176



HyperCube Menus

8’ HyperCube Carbon

Fil

e Edit Applications Image

Functions

Applications Utilities  Wir] BELladlLEN Utilities  Wing m
Undo 36 Z Convert Image > Flicker Cube Reformat File... Show Info
; = Add to Cube... Flicker/Superimpose... : Show Band >
Cut #EX Attach > Wrap JPEC in NITF...
Copy #C § Statistics Buckeye Files to NITF... v fth 21-24
Paste ®;V Zoom In 8B+ = CeoTIFF, JPEG to NITF...
Clear Zoom Out ES 2
= = S —— ASCII to Library...
Flip > Arithmetic... Library to
Duplicate #®D Rotate > g;FrIay Color... Class Map Edito
Shift 1 > ljacency .1ass viap caitor...
Send to Back %8B : —— Concatenate
z Color Mapping... _aSS' e i
Options > Gray Mapping... E.ilil('.jriittj.le“: Concatenate Files...
Data Mapping... et bt Change Window Title...
N Edit  Applications ;
i Filter » Fourier... Apply Transformation..
New... BN ;
Open... %0 Magnify Image > Masale Merge LAS Files...
Open As...
p Deleta Band... warp... ASCII LIDAR to LASF
Load Selection... %L Disconnect Cube from File... Test code
Close W Embed Wavelength
Close All Cube Color Composite > The Windows menu will
—— %S | QTN image contaz.n Cascade and Tile in
Save As... Shaded Relief... the Windows version but not
Page Setup... Contour... the Mac version.
Print... 3P Stored >
Open As... is a Mac Perspective...
only menu item. Radiance >
Lens Distortion...

Utilities Windows

The availability of a specific menu function is directly keyed to the current active win-
dow. If an item is not enabled and you think it should be, it’s most likely because it is not
applicable to the front most window or is ambiguous. For example, Embed Wavelength is
enabled only when a cube window is front, likewise for Classify. Fourier and other opera-
tors can only be used when an image window is active and Convert Image is very depen-

dent upon the active window’s bit depth.

Some menu functions produce operators that become attached to the window that is ac-
tive. Color Map, Gray Map, Filter, Flicker Cube, and Fourier are examples of attached

operators. When the parent window is closed the operator window disappears.

2k HyperCube
File Edit Applications |mage Functionz  Utiikie: Windows Help

Windows version main Menu Bar.

I [=] E3
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File

New...

Open...

Open As...

Load Sel...

Close

Close All

Save

Save As...

Create a new empty image window that can be used to paste the current
clipboard. You are presented with the following dialog options which
are preset according to the contents of the clipboard.

New Window Pixels Width of window
Window size: Pixels: |1280 L|neS Helght Of WlndOW
= Lines: 1024
W'“,‘_’F’:’ “;pe: Text Create a new Text window
(J lex .
@ Image Image Create a new Image window.
") Gray scale
Ti | . .
e Gray scale 8 bit gray window
( Cancel ) € Okay ) True color 32 bit full color window

Presents the standard Mac open file dialog showing recognized files.

Available when an overview is front most. Brings up the last dialog
used to open the source image with the requested size fields set to
correspond to any selection rectangle that appears on the overview.
See section Overviews.

Close and dismiss the currently front most window. Any modified
window first presents an opportunity to save it.

Closes all open windows.
Save the current active image window as a Pict file.

Present a modified save dialog allowing you to save in Pict and
other type formats.

Page Setup... Bring up the standard printer setup dialog for the chosen printer.

Print...

Quit/Exit

Display the print dialog and print the contents of the front window.

Exit HyperCube. A warning is given to save various results.

A modified open file dialog which includes TIFF and other image files.
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Edit

Undo
Cut

Copy

Paste

Clear

Select All

Duplicate

Not implemented in the present HyperCube version.

Also not implemented as yet.

Copy the current front window to the clipboard. If a selection rectangle is

present then copy just its contents.

Paste the contents of the clipboard to the front window. You can position it

before embedding.

De-toggles enabled items in Library list, Classify points list and Cube points.

Toggles on all items in a Library list or Classify points list.

Make an exact copy of the current front window contents but not its

functionality. Equivalent to performing: Copy. New and Paste.

Send to Back Place the current front window behind all other HyperCube windows.

Options A submenu with the following sub-functions.

Options & v Sound

Detailed Messages

List Allocation

[0,0] Image Origin

Labels >

Mag/Rotate Interp >
Color Selector...

List Clipboard Contents

Pixel Exclusion...

Image to Ref Coords...

Geo/UTM Ref Grids...

Attach RPC File...

Create Geo RPC...

Ceo Coords <--> UTM Coords...

Sound
Detailed Messages
List Allocation

[0,0] Image Origin

Toggle alert sound on/off.
Toggle image file header info on/off.
Display a snapshot of internal structures.

Change the upper left coordinate origin from [1,1]
to [0,0]
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Labels A submenu specifying the font, size and position of
dynamic labels (see Dynamic Displays and Plots).

Anchor to Upper Right

Mag/Rotate Interp P+ Geneva 9

Color Selector... Ceneva 12
List Clipboard Contents System 12

Image to Ref Coords...

Pixel Exclusion... Bold

Mag/Rot Interp... Interpolation for magnify and rotate (see Image menu).

Mag/Rotate Interp L v Replicate
Color Selector... Bilinear
List Clipboard Contents Cubic

Color Selector...  Display the selection point to color correspondence
editing window.

List Clipboard... = What’s currently in the clipboard.

Pixel Exclusion... Displays a dialog specifying certain pixel values that
are excluded from histogram computations.
See section Pixel Exclusion.

Image to Ref... Display a dialog defining the correspondence between
an image coordinate and a reference coordinate.

Geo/UTM Grids... Overlay geographic or UTM lines on a referenced image.

Attach RPC ... Present an Open File dialog to select a Rational Polynomial
Coefficients (RPC) file and attach it to the active image.

Create Geo RPC... Generate Rational Polynomial Coefficients (RPC)
for an image containing a Geographic or UTM reference.

Geo Coords <---> UTM Coords...
Convert a referenced Geographic image to
a referenced UTM coordiate system and vice versa.
If the image contains Rational Polynomial Coefficients (RPC)
then also convert them.
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Applications

Shaded Relief...  Solicit the elevation and azimuth of an artificial light source
and generate a reflective relief of an image or its attached data.

Contour... Generate contour lines from an image and display the results.

Contour dma_dted.tif

er the start, end, placement and output.
jow gray values or

i

Limas

15600

i e E iz
s §
g
i

il

Stereo... Produce an anaglyphic red and cyan stereo image from elevations.
Generate elevations and orthographic images.

Mate...
Compilation...

Perspective... Generate a perspective view given a base image and its matching
digital elevations.

4] Ferypective L]
[Select twa images, The Base image forms the |

elevation matric. X2 is the perspective point.
[ meg.a, Phi and Kagpa are the sequential
phutogrammetric angle rolations about XY.2.

Databmage: | gted )

[ Generate a Start -+ End sequence, (WA | 5

[(heser |
Perspective | |

Radiance... Construct a new radiance image cube from an existing thermal
radiance cube using various techniques.

ISAC...
Plot BB Curve...

Lens Distortion... Apply USGS/EROS Report of Camera Calibration to a digitally
acquired image.
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Image

Convert Image A submenu used to change the structure of an image.

R.G,B to Color...
H,S,1 to Color...
Complement
Color to R,G,B
Color to H,5,1
Color to Indexed...
Color to Class Map

Replace Color...
Image to Mask...

Cray

Histogram Equalize
Principal Components
Color to Cube...

~

v

R,G,B to Color...  Select 8 bit images to form a color image.
H,S,l to Color... Select 8 bit hue, saturation and intensity

to form a color image.

Indexed to Color Changes 8 bit pseudo color to true color.

Complement Complement a color image.
Color to R,G,B Separate a color image into planes.
Color to H,S,| Separate a color image into hue, saturation

and intensity.

Color to Indexed Change true color to pseudo color.

g Replace Color...  Substitute one color with another.
Image to Mask... Change a specific color (gray) to a mask.
Gray Convert color to gray image submenu.
Hist Equalize... Perform various equalizations.

Principal Comp... Convert color to principal components.

Attach

Add to Cube...

Zoomin
Zoom out

Flip

Rotate

Plane to Cube Use a gray image as cube base. This

menu item toggles with Color to Cube.

Color to Cube Convert true color image into a 3 band

image cube.

New Cube Link... Change the present cube color composite

link.

Color Table Change present 8 bit pseudo color table.

A submenu that associates one image’s characteristic with another.

Data

Copy data from one image to a second image.

Class Map Make a virtual class map using a class map.
Remove Data Discard any attached 16 or 32 bit data.

Also used to convert 48 bit color to 24 bits.

Presents a dialog list from which to choose images for a new cube.

Magnify the current image window by 2.

Demagnify the current image window by 2.

A submenu allowing images and cubes to be reversed and reflected.

Left -> Right
Top -> Bottom
Band Order

Left -> Right Reverse the pixels within a line.
Top -> Bottom Reverse the order of the lines.

Band Order Change the ordering of cube bands.

Multiple 90 degree rotations of image and cube windows.

90 cw

90 cow
180 cw
General..

90 cw  Rotate image or cube 90 degrees clockwise.
90 ccw 90 degrees counter clockwise.

180 cw 180 degree rotation.

General User input of rotation.
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Shift Left and right pixel and line cyclic shifts of image windows.
Left, Right, Up, Down Direction of shift.

Even Just even numbered line.
Overwrite If toggled, results overwrites source.
Svtemsr:;t Enter Shift  Allows user specified shift value.
nter ...
Color Map... Display interactive dialog of color balance controls for color images.
Gray Map... Change the contrast and brightness of any image or cube window.
Data Map... Select the way in which data values are mapped for display.
Filter A submenu of static and interactive spatial domain image filtering.
gatic 5_><55---5 Static 5x5... Display a static 5 by 5 kernel
YNamic aXo...

convolution static dialog.
Dynamic 5x5... Display an interactive 5x5 kernel
convolution dialog.

Magnify ... Generates a new magnified/minified view of the image or
selection rectangle by the factor chosen in the submenu. Certain
plots (e.g., data histograms, eigenvalues) can also be magnified.

Delete Band  The current cube face band is deleted from the image cube display.

The cube will be disconnected from any file reference.

Disconnect... The current image cube is disconnected from any file reference.
It becomes an in-memory only image cube.

Embed Wave... Write the wavelength into each band of the loaded cube. Useful
before Save Bands function.

Cube Color Composite A submenu enabled when a cube image is front.
Generates a true color image using the values set in Definitions... to
determine which bands of the cube file to use. The new color image
is automatically linked to the cube (see sections Color Composite

and Classify Functions).
specific Wavelengths | Specific Wave Use the 3 closest bands to

Interval Wavelengths

Definitions... the values set in Definitions...

Interval Wave Integrate all bands lying in
each interval to form the red,
green and blue components.

Definitions...  Specify the red, green and blue
wavelengths for the color
composite.
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Functions

Flicker Cube Generate a new cube window devoted to flickering between bands.

Flicker/Superimpose Display a dialog of image names from which to choose the
sources for an image flicker or image superposition.

Statistics A submenu of statistical functions to be applied to the current cube.
Pair Correlations... Pair Corr... Cross correlation computation between 2 images.
Band Correlations... | Band Cortr... Cross correlation between successive cube bands.

Plot A submenu of graphical operators.
Histogram » | Histogram...  Perform a pixel distribution histogram of
Spectra (Selected Points) .
Spectra (Dynamic) the current image or cube.
Scatter... Hist (Mask...  Same as above using an image mask.
e Spectra (Se... Display the spectral plot window for the
selected active cube points.
Spectra (Dy... Dynamically display a spectral plot as the
cursor moves over a cube.
Scatter... Generate a 2 dimensional plot of the
pixel distribution between 2 images.
Profile Draw a gray level density plot of the active
image profile line. If the image is color
draw plots for red, green and blue.
Scaling... Selectable when a plot window is active.
Allows you to change the plot axes.
Arithmetic...  Open an interactive window allowing arithmetic expressions to be

performed on images.

Overlay Color... Generate a composite image from a mask and base image.

Adjacency... A submenu for comparing and outputting spatially near pixels.
Classify... Open up the classification dialog window for the current image cube.
Calibration...  Open the calibration dialog for the frontmost Classify window.

F(Signatures)... Compute eigenvector matrix of Classify signatures.

Fourier... Display an interactive dialog to perform frequency domain filtering
upon the current 8 bit image window.

Mosaic Display interactive dialogs to select and control the merging of
two or more images into a composite assemblage.

Warp... Display an interactive dialog to select and control the geometric
transformation of one image to another.
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Utilities

Reformat File... Open a dialog for reformatting the spatial and/or pixel type of a file.
Wrap JPEG... Create a NITF file containing an embedded JPEG (2000) file.
GeoTIFF, JPEG... Combine GeoTIFF geometry with JPEG to form NITF file.
ASCII to Library... Read and convert a columnar text file to a Library file.

Library to A submenu to convert the current front most library list window into

an image cube file or an ASCII text file. e

Class Map Editor...  Enabled when a classification image is front most. Permits
changing the region color and name association.

Concatenate A submenu used to select two images that will be concatenated
in either pixel or line order to form one new image.

Cubes...

Concatenate Files... Display a dialog allowing you to select multiples files
to be concatenated into a single sequential new file.

Change Window Title... Solicit a new title for the current active window.
Apply Transformation... Multiply a cube file by an orthogonal transformation.

Merge LAS Files... Combine the point clouds of several LAS files into
a new LAS point cloud file.

ASCII LIDAR to LASF Convert an ASCII LIDAR file to a LASF file.

Windows
Show Info Display a small dynamic window that shows various HyperCube
details as the cursor passes over other windows.
Show Band A submenu showing wavelengths and annotation of multiband images.
List Display a listing of the wavelengths of the current
image cube to allow editing.
Annotation Display a listing of the annotation associated with
each band that you may edit.
Cascade Windows version only. Arranges all of the open windows in an
overlapped diagonal order.
Tile Windows version only. Resizes and rearranges the open windows in
a row by row pattern.
“Names” A dynamic list in order of creation of HyperCube windows. The

front most window is preceded by a check mark.
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Index

Symbols

% 24,37
(1) 164
*.c2n file 134
*.hdr 22,93,141,143,175
band list 93
*wav 141,143,175
*.wvl 92
band list 92
.ev 125
.gs 125
.pm 125
.wav 36,92
wvl 36,92,141,143,175
[0,0] 50
[0,1] 25,101
[1,1] 50
{constant,constant,constant} 72
180 cw 182
8BCK 175
90 ccw 182
90 cw 182

A

Abs diff 108
Add to Cube... 182
Adjacency 78
Affine 90
Algorithms 108
Alpha

PNG files 20
Anaglyph 155,157
Anaglyphic

Stereo Compilation 160
Arithmetic 122,184

sequence 73
Arithmetic functions

non standard 69

standard C 68
Arithmetic operators 68
Arrow keys

flicker offset 96
ASCIl 86

dialog 18

LIDAR 15

Saving images 176
Attach Data 58
Averaging

spectral plots 106
Azimuth 155

Bands
loading 140
Band Annotation 94
Band Correlations 61,184
sequential 61
specific 61
Band List 92,108,138
revert 93
scaling 93
Band Order 45,182
Band Scrolling 95
Binary 55
Black body 169
Block size 147
Brightness 40
Buckeye 146
Byte 140
Byte order 23,143

Cc

Calibration 137
Cascade 185
chunks
PNG files 20
Classify 80,81
Classify... 108,177,184
overlays 122
Classify Each 115
Classify Mean 115,127
Classmap Editor
Color to Classmap 58
Class map
virtual 132
Class Map Editor
ESRI Shape Files 12
singularities 81
Clear 39,101,179
Clear Lib 101
Close 178
Close All 178
Coefficients 38
Daubechies 119
Haar 119
Color Balance 42
Color Composite 113,117,183
color keywords 100
save hdr 100
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Color depth

reduction 58

Remove Data 58
Color domain

histogram match 57
Color Image 118

16 bit components 21
Color map

histogram 63
Color Map... 42,177,183
Color Mapping

hue, sat, int 42
Color Mask 118
Color overlay 54
Color Selector 115,117,131
Color separation 55
Color Table 182
Color to cube 98
Color to Indexed 53,182
Color to Library 131
Color to Planes 51,182
Columns 153
Command-option-C 54,103
Complex data

HDF 13
Concatenate Files 151
Concatenate Images 150
Constructing a cube 98
Contours 156

ESRI Shape file 12
Contrast 37,40
Control-click

profiles 67
Convariance

noise 111
Convert

16 bits to 8 58
Convert Image 182
Convolution 70
Convolver

3x3 48

5x5 48

offset 48

scale 48
Coordinates 50

mosaic references 87
Copy 39,179
Copy color 103
Corner coordinates

image to reference 32
Correlation 59,61

band statistics 61

pairs 59

Corr coef 108

Countable 117

Covariance 61,109,111
band statistics 61
F(signatures) 125
Mahalanobis 110
Match Filter 110
pairs 59
principal components 52

Crash 175

Cross correlation 70

Cut 179

C language 68

D

Daubechies 119
coefficients 70

Delete 39,40

Delete Band 99

Density plot 67

Deriv diff 108

Descrete Wavelet Transform
image arithmetic 70

Detailed Messages 8,19,21,63,179

cummulative histogram 63
ERDAS Imagine 11
HDF tags 13
histogram 63
JPEG 14
LASF 18
PNG files 20
dft_nterms 82
dft_phase 82
Difference image 120
Difference plot 121
Discrete Wavelet Transform
compression 76
Double clicking 92
Dpi 142
Dragging a selection 39
Drag & Drop 107
Duplicate 39,140,179
Dynamic
filters 83
Dynamic Displays 101

E

Easting
ASCII LIDAR 154
Edit 101
Eigenvector 125
signatures 125
Elevation 155
Stereo Compilation 160
Embed Wavelengths 177,183
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Emissivity 169
Enable Dynamic Display 133
Energy
wavelets 71
ENVI®
header file 29
wavelength file 36
ERDAS Imagine® 10
Error Messages 175
ESRI 12
ESRI Shape File
exporting 134
Euclid distance 108
Excel™ 61
Export shapefile 136

F

False alarm 127
False hits 80
Fast Fouier Transform 82
Filter 183
Filtering
3x3 47
5x5 47
convolution 47
deniose 116
frequency domain 82
interactive 47
spatial 47
wavelet 119
Flicker
arrow keys 96
X,y offsets 96
Flicker Cube 96,184
Flicker Image 96
Flip 45,182
Floating point 23,140,143
Fly-by 167
Focal length 167

Form Neighborhood... 114,127,129

Fourier 82,108,177,184
high boost 83
low pass 83
no DC 108
phase 108
phase delta 108
power spectrum 83
Frequency
histogram 124
Frequency domain
functions 70

G

Gains & Offsets 26
Gains & offsets 144

GeoTIFF 21
Gram-Schmidt 125
Grayscale 182

Gray Map... 40,177,183
Green dot 128

Ground truth 118,127

H

H,S,| 51
Haar 119

coefficients 70
Harmonic 108
HDF

Hierarchical Data Format 13
Header 22

*.hdr files 29

saving 24,93
Header file

image to reference 32
Height

direction 33

RPC 33
HFA 11

Hierarchical File Architecture 11

Histogram
color mapping 42
cumulative distribution 63
Detailed Messages 63
exclusions 65
file 63,64
gray mapping 42
masked 64
of classifications 121
Plot 184
summary 63
window 63,64
Histogram equalization 56,100
matching 56
uniform 56
Hit rate 127
Hotelling 52
HSI
K-means 112
Hue 51
color mapping 42
Huffman tables
PNG files 20

Icons
appl 175
Pict 175
Raw 175
Text 175
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Icords
keyword 31
Image Arithmetic 68
** operator in 68
abs,...,atan2 68
remapping 72
shift_left... 69
Image cube
adding to an 98
constructing an 98
Image Shift 59
Image to Mask 55
Image to Reference 136
change in origin 32
Indexed to Color 53
Info
band statistics 61
Info Window 50,101
color mapping 42
cursor position 50
NITF coordinates 19
Show Info 50
spectral coords 101
Intensified color
classify 120
Intensity
color mapping 42
interlace
PNG files 20
Interleave 25,140,147
Interpolation 90
mosaic references 88
Interval Wavelengths 100
ISAC 171

J

JPEG 19,21,53
baseline 14
compression 14
embed 145
markers 14

JPEG DCT 21,146

K

KO... 174

Keywords
definitions 30

Kmeans 108,112
classes 112
class color 112
iterations 112
options 112
plots 112

L

LASF Files 15
Latitude 31
Stereo Compilation 159
stereo triangulation 158
Latitude/Longitude
Conversion 34
Left 46
Left -> Right 45,182
Lens distortion
decentering 174
focal length 174
pixel size 174
principle point 174
radius 174
Lib:File
match lists 131
Library
NEFDB 104
USATEC 104
Library... 114,130,147
List 147
Library to Cube 147
Lib Key 131
LIDAR 15
Z values 16
Linear 40
correlation 59
Link 58
Linked image 113,183
Link to Cube 51
List allocation 179
Load
Bands 99
Loading
by double clicking 92
Longitude
Stereo Compilation 159
longitude 31
lossless
PNG files 20
LZW 21

M

Magnify

bilinear 49

cubic 49

minification 183

popup menu 49

replicate 49

selection rectangle 49
Magnify Selection 183
Mag Interpolation 180

HyperCube Pictorial User’s Guide

189



Mahalanobis Overlay Color 80

classifier 108 Overview
classify 108,110 Load Selection 178
distance 108,110 TIFF 19,21
list 108,110 overview
parameters 116 LASF 15
Mask 54,55,77,182 LIDAR 15
creating 111 Overviews
Matched filter 109 scale factor 27
abundance 108,109 scaling 27
mask 108 selection rectangle 27
Match Criteria 117 starting band 27
Countable 117
Matrix 153 P
eigenvector 125 P1. 174
orthonormal 125 Page Setup... 142,178
projection 125 Pair Correlations... 59,184
save.153,176 Palette 103
Mean signature 120 palette

Menus 177 i
PNG files 20
Merge LAS Files 154 Paste 39,179

Meters per pixel 67 Percentage 117

Method 1_30 Perspective 166
More lOptlons 120 PhotoShop™ 48,175
Mosaic 84 Pict 39,175
gg?iggls %% Pixel Exclusion
Multiband 22 zﬁgﬁguz;%
N histograms 63
shaded relief 155
NEFDB 104 Pixel size
New 40,178 lens distortion 174
NITF Pixel type 23,140
coordinates 19 Planes to Color... 51
mono 143 Plane to plane 84
Overviews 28 Plot 130,184
reformatting 143 profile 67
Northing scaling 91
ASCII LIDAR 154 scatter 184
NTSC selection 91
gray() 69 spectra 101,107
Plotting Signatures 137
o Plot Scaling 101
Omega, Phi, Kappa 166 PIOt. transform
Open... 178 histogram match 57

PNG

Open As... 8,147,178 )
P Portable Network Graphics 20

Operator 42

Options 179 Pollqyggm:als
Orthogonal 84,90 5 58
Orthonormal 125 ower spectrum 70
0OS X compression 83
H ™

Pict pseudo color 53 Premiere™ 141

TIFF 8 Principal Componentls 52
Outline 85 Apply Transformation 153
Overlay 77 signatures 125
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Print... 178

spectra 106

windows 142
Print Image 142
Print Window 142
Profile 67

Control-click 67
Projection 125
Projection matrix 125
Pseudo color 53

Q

QuickTime™ 141
Quit 178

R

Radiance 169,171
Radius 78
Raw 22,140,175
Recompilation 162
Redo stats 111
Ref 137
Reference coords 29
Reformatting 143
Multiband 143
NITF 143
Raw 143
Reformat Cube File... 141,143,147,185
Remapping 38
Remap bands 38
Remove
attached data 58
Replace Color 54
Residuals
example 89
warp 89
Right 46
ROC 127
ROC curve 115
ROC Mask 118
Rotations 45,182
Rows 153
RPC
Create 34
format 35
geographic coords 158
height direction 33
Lat/Long Grids 33
TIFF files 21
Wrap JPEG 145
Rubberband 41

S

Saturation 38
color mapping 42
Save
Bands 99
images 140
Image Arithmetic 178
Overviews 28
signature 115
Save As... 178
Scale 25,101
gains & offsets 144
spectra 106
Scaling
plot 91
selection 91
wavelength 93
Scatter 66,184
Screen capture 176
Search
classmap 134
Search Domain 114,130
Selection point 103
Selection rectangle 39,40,42,52,59
data mapping 43
plots 91
Sequence 118
Sequential
correlation 61
Shaded Relief 155
Shape Files 12
Sharp <--> Blur 47
Shift-click 89,101
classify neighborhood 113
classify selection 113
profile 67
Shifts 46,183
All 46
down 69
Even 46
Left 46
left 69
line 60
offsets 60
pixel 60
Right 46
right 69
up 69
Short 140
Show Band List 36,92,98,185
cube construction 99
disable all 92
enable all 92
Show Info 185
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Sigma 26
Signature 114,130
height
width
Signed 23,143
sliders
filtering 82
Slope
X 69
Xy 69
y 69
Sobel
3x3 subset 48
5x5 48
xy gradient 48
Sound 179
Source color
natural 120
saturated 120
Specific Wavelengths 100
Spectra... 147,184
Spectral Libraries
averaging 106
example of 105
format of 104
plotting 106
Spectral Plots 101,113
examples 102
Spike supression 17
SRF 8,9,140,175
Sun Raster Files 9
Statistics 37,184
Stats Region 111
Stereo 157
anaglyph 160
compilation 160
elevations 160
ortho 160
recompilation 165
Stereo glasses 157
Stereo Triangulation 158
Sun 9
Superimpose 97
Superimposing Signatures 107,130
Synthetic cube 118,123

T

TARGA 9
TEC 104
Temperature 169
Template 109
Text

Saving 176
Thermal 169
Threshold 115

TIFF 140,175
Overviews 28
Tile 185
Toggle button 107
Top -> Bottom 45,182
Transformation 90
matrix 153
transparency
PNG files 20
True color 53
composite color 100,183
Type Il Error 127
Type | Error 127

U

Underflow 38
Undo 179
Unsigned 23,143
Use lowest elevation 17
Use source spectra color
color selection 103
image products 122
library searches 131
USGS/EROS
Lens distortation 172
UTM 21,32
ASCII LIDAR 154
conversion 34
easting 31
northing 31
reference coords 31
Stereo Compilation 159
WGS84 32
zone 31

\'

Vector 81

Vector angle 109
Vector plot 136
Version 6

Video 46

w

Warp 84,184
affine 89
non-linear 89
orthogonal 89
residuals 89

Water absorption 61,102
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Wavelength
*.wav 92
.wvl 36
bandlist 92
header 36
library 148
Save *.wav 93
scaling 93
Wavelength File 36
Wavelet
pre-filter 119
Windows version
band scrolling 95
carriage returns 176
Cascade 177
Classmap Editor 134
control-double-click 67
control key 6
Copy color 40
fatal error message 175
HyperCube version 6
icons 175
main menu 177
Open As Bands 99
Open File dialog 8
printing 142
profile plots 67
Replace Color 54
screen capture 176
screen print 176
selection rectangle 39
system requirements 6
TIFF 8
Tile 177
Window vs File 52,61
Wm-2um-1 169,171
ISAC 171
Wrap JPEG 145

X

XY
coordinates 17
LIDAR 17
X,Y,Z
columns 15

y4

Zeros 176
Zone 31
negative 31,32
Southern Hemisphere 31
Zoom 39
Zoomin 182
Zoom out 182
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